/usr/share/thumbnailer/vs-thumb is ELF binary-- should be in /usr/lib

Bug #1235325 reported by Jamie Strandboge on 2013-10-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Thumbnailer
Fix Released
Undecided
Unassigned
thumbnailer (Ubuntu)
Undecided
Unassigned

Bug Description

In adding policy to apparmor-easyprof-ubuntu for click apps, I discovered that /usr/share/thumbnailer/vs-thumb is not installed to the proper location. It should be somewhere in /usr/lib, not /usr/share. I asked about a recommendation on IRC:

10:40 < jdstrand> slangasek: hey, quick question-- libthumbnailer0 is shipping /usr/share/thumbnailer/vs-thumb, but vs-thumb is an ELF binary. I know it should go in /usr/lib, but not sure the best place to recommend
10:41 < slangasek> jdstrand: /usr/lib/$arch/thumbnailer/vs-thumb; since it's a shared library package we want it to be multiarch-clean

I am therefore going to add apparmor policy for this path for when you do fix it:
  /usr/lib/@{multiarch}/thumbnailer/vs-thumb ixr,

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thumbnailer (Ubuntu):
status: New → Confirmed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:thumbnailer at revision 57, scheduled for release in thumbnailer, milestone Unknown

Changed in thumbnailer:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thumbnailer - 1.0+13.10.20131011-0ubuntu1

---------------
thumbnailer (1.0+13.10.20131011-0ubuntu1) saucy; urgency=low

  [ Jussi Pakkanen ]
  * Fix install directory of vs-thumb. (LP: #1235325)
  * Wait for child process to die when killing it with SIGKILL.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 58
 -- Ubuntu daily release <email address hidden> Fri, 11 Oct 2013 05:41:32 +0000

Changed in thumbnailer (Ubuntu):
status: Confirmed → Fix Released
Changed in thumbnailer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers