tf-tool manpage is misleading

Bug #203973 reported by rupert angermeier on 2008-03-19
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
thinkfinger (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: thinkfinger-tools

1) i installed ubuntu hardy, 080318.1
2) thinkfinger-tools
3) version installed: 0.3+r118-0ubuntu1
4) i want to store my fingerprints for use with PAM
5) this is what happened:
rupi@stinkpad:~$ sudo tf-tool --add-user rupi
Password or swipe finger:

ThinkFinger 0.3 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <email address hidden>

Two output paths specified, but you may only specify one:
  --add-user
  rupi

PROPER PROCEDURE:
 0) sudo apt-get install libpam-thinkfinger
 1) sudo /usr/lib/pam-thinkfinger/pam-thinkfinger-enable
 2) tf-tool --acquire
 3) tf-tool --verify

The man page should be changed to reflect this.

I can confirm that behaviour. The manpage tells us to use tf-tool --add-user though it is patched out. It is supposed to copy the bir-file to /etc/pam_thinkfinger/$USER.bir
This is easy to achieve: generate your thinkfinger.bir file with tf-tool --acquire and either hardlink it to /etc/pam_libthinkfinger/ or just leave it there.
Because the ubuntu README reads:

> To verify a fingerprint run 'tf-tool --verify'. tf-tool will by default
> read a fingerprint image from ~/.thinkfinger.bir and compare that with the
> finger which is being swiped. You can override this location by passing
> the desired location as parameter.

A hint would be nice, that --add-user has been patched out.

Eduardo Cereto (dudus) wrote :

Same thing here. But I'm on intel so this is not restricted to amd64. Something caught my eye on tf-tool man page:

              >This option is available only
              >when ThinkFinger has been compiled with PAM support.

I don't know how the linkage is done in the insides. But my bet is that the problem is there. This programm was not compilled with PAM support.

The manpage for thinkfinger is misleading, but I'm afraid you're all simply wrong. ldd `which tf-tool` clearly shows that it's linked against pam.

To enroll a new user, you simply need to run "sudo tf-tool --acquire". That will be enough in hardy to enroll a user. You do not need to copy the file to /etc, you do not need to recompile with pam support. You will need to modify pam.conf to use thinkfinger however. This is in the documentation already.

Justin Dugger (jldugger) on 2008-03-22
Changed in thinkfinger:
status: New → Confirmed
Changed in thinkfinger:
importance: Undecided → Low
Leo Arias (elopio) wrote :

Justin, what do we have to modify on pam.conf?
I can't find it in the documentation.

Thanks.

Justin Dugger (jldugger) wrote :

There's a new README as of April 10th that states:

libpam-thinkfinger for Ubuntu
-----------------------------

In order to enable authentication by fingerprint, you will need to
run the /usr/lib/libpam-thinkfinger/pam-thinkfinger-enable script.

In order to acquire new fingerprints for login users you need
tf-tool, which is included in the recommended thinkfinger-tools
package and is also used to verify fingerprints.

 -- Scott James Remnant <email address hidden>, Thu, 10 Apr 2008 16:49:04 +0100

That script should handle pam.conf for you. If it does not succeed, please report a new bug!

sorcere (fibonacci-master) wrote :

The /usr/share/doc/thinkfinger-tools/README.Debian states:

In order to enable authentication by fingerprint, you will need to
run the /usr/lib/libpam-thinkfinger/pam-thinkfinger-enable script

but this is wrong, it's located at /usr/lib/pam-thinkfinger/pam-thinkfinger-enable.

Leo Arias (elopio) wrote :

Thanks to both. I'll try the script.

Vadim Tkachuk (vadim-tkachuk) wrote :

I just used sudo tf-tool --acquire and sudo tf-tool --verify to successfully store the fingerprint.
I did not have to do sudo tf-tool --add-user login_name for ThinkFinger to work on Ubuntu 8.04.

Leo Arias (elopio) wrote :

Vadim, the --add-user option is used to enable thinkfinger to work with Pluggable Authentication Modules (PAM). You don't need it if you just want to store or check your fingerprint.

Our gdm is now working as we want, thanks guys.

Ken Pratt (kenpratt) wrote :

Is there anything one has to do to have GDM present the finger swipe capability? I have 8.04 installed and am able to enroll (--acquire) and verify (--verify) my fingerprint. I ran the /usr/lib/pam-thinkfinger/pam-thinkfinger-enable script and see that the pam file was updated. However, GDM does not show a different prompt and swiping my finger does nothing.

Ken Pratt (kenpratt) wrote :

Ignore my previous comment about GDM no responding to a finger swipe. The prompt changes after a user name is entered. It would be neat if one did not have to provide a user name. Of course this assumes the fingerprints are detailed enough so that they can provide unique identity without a user name. I don't know if this is the case.

kumar (kumar-narain) wrote :

I did everything as instructed...but I found that I am made to enter the password as well as finger swipe...also I noticed that Add/remove software is not working...Am I missing something simple??

kevmitch (kevmitch) wrote :

Ok, so in summary, I guess the title of the bug says it all. The removal of "--add-user" is kind of confusing especially since the manpage hasn't been changed accordingly. "--add-user" needs to be removed from the manpage and the new functionality of "--acquire" needs to be included. Also is there a reason that pam support is not enabled by default when you install the libpam-thinkfinger package? None of this is a huge deal for me, but I'm just being nitpicky on behalf of novice users who want things to "just work". The fact that the script to enable pam exists at all already puts this miles ahead of the Debian package.

Michael Rooney (mrooney) wrote :

Yes, let's summarize the changes in more detail. --add-user should go; the same for --verify-user? Or is that still useful? And what needs to be added to the --acquire description?

Also, should there be a mention of the script in the man page?

description: updated
Michael Rooney (mrooney) wrote :

Interestingly, http://en.thinkwiki.org/wiki/How_to_enable_the_fingerprint_reader_with_ThinkFinger#Ubuntu says that it is not correct to use sudo for --acquire. I will update the workaround in the description to the instructions there, can anyone confirm or deny them? Thanks!

description: updated
Michael Rooney (mrooney) wrote :

I am assigning this to me as it is something I would like to take care of. However I need someone to confirm my instructions listed under PROPER PROCEDURE in the main description. Thanks!

Changed in thinkfinger:
assignee: nobody → michael
echo6 (echo6-uk) wrote :

Hmm, I've found that gdm will just sit there after I've swiped my fingerprint until I press carriage return. Before this update I had everything working fine, e.g. enter username swipe finger and gnome would load, no need for carriage return.

Does any one else find this, or have a cure?

Michael Rooney (mrooney) wrote :

Okay, I am working on a patch for the manpage. Is there any reason why libpam-thinkfinger isn't a Recommends? It seems like it should be, as the script it provides is apparently necessary to configure pam correctly.

Again, if anyone on this bug report would verify my proper procedure instructions in the description, it would really help me out, as I don't have a fingerprint reader. I can't fix the bug without help from the reporters/subscribers!

Changed in thinkfinger:
status: Confirmed → In Progress
Blaqlight (jalvey) wrote :

Ok everything works it authenticates fine within GDM, add remove/programs and other places sudo would be needed. I only needed to logout to the GDM greeter for it too ask without me doing anything.

Interesting thing though, is that gnome-terminal stopped asking me to auth at all when I run sudo commands within it.

Also sudo is required to even verify the fingerprint (sudo tf-tool --verify)

As for the (sudo /usr/lib/pam-thinkfinger/pam-thinkfinger-enable) command I cannot verify whether its valid as mine was already enabled and the script said as much.

Hope this helps.

Blaqlight (jalvey) wrote :

Ok everything works it authenticates fine within GDM, add remove/programs and other places sudo would be needed. I only needed to logout and log back into the GDM greeter for it too ask for me to swipe my finger without me doing anything.

Interesting thing though, is that gnome-terminal stopped asking me to auth at all when I run sudo commands within it.

Also sudo is required to even verify the fingerprint (sudo tf-tool --verify)

As for the (sudo /usr/lib/pam-thinkfinger/pam-thinkfinger-enable) command I cannot verify whether its valid as mine was already enabled and the script said as much.

Hope this helps.

Eduardo Cereto (dudus) wrote :

Also the file /usr/lib/pam-thinkfinger/pam-thinkfinger-enable should be removed from package and rewritten to be one of those scripts that run automatically after you install the package

Michael Rooney (mrooney) wrote :

Okay, I am unassigning myself as no one has verified my proper procedure and I can't generate a patch to be reviewed without more user feedback (I don't have a fingerprint reader).

Changed in thinkfinger:
assignee: michael → nobody
status: In Progress → Confirmed
rupert angermeier (r.anger) wrote :

sorry for not responding to your initial call for testing.

i just tried the PROPER PROCEDURE as you described it and all steps worked.
this is on ubuntu hardy, thinkfinger-0.3+r118-0ubuntu3

rupi@stinkpad:~$ sudo /usr/lib/pam-thinkfinger/pam-thinkfinger-enable
fingerprint reader already enabled
rupi@stinkpad:~$ tf-tool --acquire

ThinkFinger 0.3 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <email address hidden>

Initializing... done.
Please swipe your finger (successful swipes 3/3, failed swipes: 1)... done.
Storing data (/home/rupi/.thinkfinger.bir)... done.
rupi@stinkpad:~$ tf-tool --verify

ThinkFinger 0.3 (http://thinkfinger.sourceforge.net/)
Copyright (C) 2006, 2007 Timo Hoenig <email address hidden>

Initializing... done.
Please swipe your finger (successful swipes 1/1, failed swipes: 0)... done.
Result: Fingerprint does match.

aliencam (cameronk) wrote :

rupert_a , that is the correct procedure, and it worked for myself also. However, if you do not already have pam configured for it, it will not return "fingerprint reader is already enabled"

saftaplan (saftaplan) wrote :

On Ubuntu 8.10, the /usr/lib/pam-thinkfinger/pam-thinkfinger-enable seems to have disappeared although it is still advised to run in /usr/share/doc/thinkfinger-tools/README.Debian .
So, what is the correct procedure in Intrepid, then?

on amd64 the package libpam-thinkfinger-0.3+r118-0ubuntu4 provides
/usr/lib/pam-thinkfinger/pam-thinkfinger-enable

rupi@stinkpad:~$ dpkg --listfiles libpam-thinkfinger | grep
"pam-thinkfinger-enable"
/usr/lib/pam-thinkfinger/pam-thinkfinger-enable

2008/11/23 saftaplan <email address hidden>:
> On Ubuntu 8.10, the /usr/lib/pam-thinkfinger/pam-thinkfinger-enable seems to have disappeared although it is still advised to run in /usr/share/doc/thinkfinger-tools/README.Debian .
> So, what is the correct procedure in Intrepid, then?
>
> --
> tf-tool manpage is misleading
> https://bugs.launchpad.net/bugs/203973
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "thinkfinger" source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: thinkfinger-tools
>
> 1) i installed ubuntu hardy, 080318.1
> 2) thinkfinger-tools
> 3) version installed: 0.3+r118-0ubuntu1
> 4) i want to store my fingerprints for use with PAM
> 5) this is what happened:
> rupi@stinkpad:~$ sudo tf-tool --add-user rupi
> Password or swipe finger:
>
>
> ThinkFinger 0.3 (http://thinkfinger.sourceforge.net/)
> Copyright (C) 2006, 2007 Timo Hoenig <email address hidden>
>
> Two output paths specified, but you may only specify one:
> --add-user
> rupi
>
>
> PROPER PROCEDURE:
> 1) sudo /usr/lib/pam-thinkfinger/pam-thinkfinger-enable
> 2) tf-tool --acquire
> 3) tf-tool --verify
>
> The man page should be changed to reflect this.
>

saftaplan (saftaplan) wrote :

Ok, I'm sorry, I was being mislead by ThinkWiki, that implied that I only had to install thinkfinger-tools on Intrepid. After installing libpam-thinkfinger and running the script everything went OK.

Michael Rooney (mrooney) on 2008-12-25
description: updated

Hello,

   I'm using Intrepid. The libpam-thinkfinger & tf-tools (version 0.3+r118-0ubuntu3) are working fine !
Yet I think the sudo behaviour is inconsistent with the usage of pam_thinkfinger.so, when I open a new terminal, and run a command with sudo, it does not ask for a password nor require me to do a swipe, this is inconsistent with the behaviour if pam_thinkfinger.so wasn't used.

Jakub Dubovsky (james64) wrote :

Hi,

Jakub Dubovsky (james64) wrote :

Hi,
    this is pretty old discusion. In case it is still alive in some way I just would like to hear about problem with carrige return after swiping finger during log on. I have the same. Did someone out there find a solution to this thing? It's a little annoying since I installed and configured thinkfinger to be able to log in without using keyboard :)

   Thanks

PS: sorry for the dummy post before

rupert angermeier (r.anger) wrote :

On Tue, 14 Sep 2010 19:43:43 -0000, Jakub Dubovsky
<email address hidden> wrote:
> Hi,
> this is pretty old discusion. In case it is still alive in some way
I
> just would like to hear about problem with carrige return after
swiping
> finger during log on. I have the same. Did someone out there find a
> solution to this thing? It's a little annoying since I installed and
> configured thinkfinger to be able to log in without using keyboard
:)
>
> Thanks
>
> PS: sorry for the dummy post before

i run maverick beta and it works again. a little patience and upgrading to
ubuntu 10.10 will hopefully fix the problem for you :)

Daniel Polehn (dpolehn-gmail) wrote :

This hasn't been updated in a long time and appears to no longer be an issue in Ubuntu. Going ahead and marking this as invalid.

Changed in thinkfinger (Ubuntu):
status: Confirmed → Invalid
Changed in thinkfinger (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions