Backport the adaptive engine from v2.4.1 upstream

Bug #1913186 reported by Paolo Pisati
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thermald (Ubuntu)
Fix Released
Undecided
Unassigned
Focal
Fix Released
Medium
Unassigned
Groovy
Fix Released
Medium
Unassigned

Bug Description

Impact:

DPTM provides an adaptive power policy that allows for improved integration between the platform and the OS. Firmware can provide a set of complex conditions to the OS, and an OS agent (in this case thermal_daemon) is responsible for evaluating them, potentially making use of information that is easily available to the OS and not the firmware. The agent evaluates each set of conditions in turn, and once the first evaluates completely it triggers a set of actions.

Fix:

Backport the adaptive engine (and all its dependencies) from upstream v.2.4.1

Regression potential:

Both Focal and Groovy backports are substantial (Focal in particular is pretty large), so there's definitely a regression potential.
On the other hand, the entire patchset is a clean backport, taking no shortcut or trying to adapt any patch, but rather picking up all the necessary dependencies to make the entire stack apply cleanly.

--

Paolo Pisati (p-pisati)
description: updated
description: updated
Paolo Pisati (p-pisati)
description: updated
Paolo Pisati (p-pisati)
description: updated
Paolo Pisati (p-pisati)
description: updated
description: updated
Paolo Pisati (p-pisati)
description: updated
Changed in thermald (Ubuntu Focal):
status: New → In Progress
Changed in thermald (Ubuntu Groovy):
status: New → In Progress
Revision history for this message
Chris Halse Rogers (raof) wrote :

This is a *lot* of changes for Focal. This looks like hardware-enablement, which would be appropriate to SRU, but we normally accomplish that via wholesale backport.

I have two questions:
* What is the impact of the lack of thermald adaptive engine on 20.04?
* If we were to simply backport hirsute's thermald 2.4.3 how many and what sort of additional changes would we be pulling in?

Revision history for this message
Colin Ian King (colin-king) wrote :

Hi Chris,

One of our OEM partners would like the backport to focal for finer thermal control on Tiger Lake platforms, so it's a really useful feature set to have for these newer devices. This requires the backport of the newer adaptive engine, hence the size of the backport. We have had the OEM partner exhaustively test this on the target hardware and we've been soak testing this backport on various platforms and checking for subtle memory leaks etc for extended run periods, so the SRU'd backport is well testsed.

A wholesale backport of 2.4.3 thermald is possible - however it's less well tested (had less time to bake in Hirsute) so I'm more reluctant to backport this at the moment.

Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Paolo, or anyone else affected,

Accepted thermald into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/thermald/1.9.1-1ubuntu0.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in thermald (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Chris Halse Rogers (raof) wrote :

Hello Paolo, or anyone else affected,

Accepted thermald into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/thermald/2.3-4ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in thermald (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed-groovy
Revision history for this message
Colin Ian King (colin-king) wrote :

I've soak tested groovy thermald 2.3-4ubuntu1 for 2.5 hours with a laptop that is cycled through CPU loading and idle states with the air vents blocked to try to trip thermal overrun. Debug mode was enabled and also it was run with valgrind to check for memory leaks.

thermald was able to passively change CPU state to avoid thermal overrun.
thermald had no long term memory leakage.

Looks good to me.

tags: added: verification-done-groovy
removed: verification-needed-groovy
Revision history for this message
Colin Ian King (colin-king) wrote :

I've soak tested focal thermald 1.9.1-1ubuntu0.4 for 4.5 hours with a laptop that is cycled through CPU loading and idle states with the air vents blocked to try to trip thermal overrun. Debug mode was enabled and also it was run with valgrind to check for memory leaks.

thermald was able to passively change CPU state to avoid thermal overrun.
thermald had no long term memory leakage.

Looks good to me.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for thermald has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 2.3-4ubuntu1

---------------
thermald (2.3-4ubuntu1) groovy; urgency=medium

  * Backport the adaptive engine (and all the required dependencies)
    from upstream https://github.com/intel/thermal_daemon.git up to
    commit 7c2ec23 (LP: #1913186)

 -- Paolo Pisati <email address hidden> Thu, 21 Jan 2021 15:41:25 +0100

Changed in thermald (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 1.9.1-1ubuntu0.4

---------------
thermald (1.9.1-1ubuntu0.4) focal; urgency=medium

  * Backport the adaptive engine (and all the required dependencies)
    from upstream https://github.com/intel/thermal_daemon.git up to
    commit 7c2ec23 (LP: #1913186)

 -- Paolo Pisati <email address hidden> Tue, 12 Jan 2021 15:41:57 +0100

Changed in thermald (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in thermald (Ubuntu Focal):
importance: Undecided → Medium
Changed in thermald (Ubuntu Groovy):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thermald (Ubuntu):
status: New → Confirmed
Changed in thermald (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Eugene86 (eugene86) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers