Update thermald to 1.9 release

Bug #1838590 reported by Mario Limonciello on 2019-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dptfxtract (Ubuntu)
Wishlist
Anthony Wong
thermald (Ubuntu)
High
Colin Ian King

Bug Description

The thermald 1.9 release was just tagged, and has potential to help quite a bit with platform performance on some newer platforms when run with kernel 5.3. It would be nice to update eoan to this new release.

> - The major change in this version is the active power limits adjustment.
This will be useful to improve performance on some newer platform. But
this will will lead to increase in CPU and other temperatures. Hence this
is important to run dptfxtract version 1.4.1 tool to get performance
sensitive thermal limits (https://github.com/intel/dptfxtract/commits/v1.4.1).
If the default configuration picked up by thermald is not optimal, user
can select other less aggressive configuration. Refer to the README here
https://github.com/intel/dptfxtract/blob/master/README.txt

Mario Limonciello (superm1) wrote :

dptfxtract should be upgraded to 1.4.2 at the same time.

Changed in thermald (Ubuntu):
importance: Undecided → Wishlist
description: updated
Changed in dptfxtract (Ubuntu):
importance: Undecided → Wishlist
Changed in dptfxtract (Ubuntu):
assignee: nobody → Anthony Wong (anthonywong)
Colin Ian King (colin-king) wrote :

Thanks Mario, I've been tracking the progress of thermald for some weeks now, so it's on my radar. I need to also roll in some packaging improvements, so I'll try and get this done some time next week.

Colin

Changed in thermald (Ubuntu):
importance: Wishlist → Medium
assignee: nobody → Colin Ian King (colin-king)

Please use the latest dptfxtract tool version 1.4.2.

Changed in thermald (Ubuntu):
importance: Medium → High
Colin Ian King (colin-king) wrote :

@Srinivas, dptfxtract is a binary, so it can't be packaged in debian/ubuntu. Is there source?

It's carried in multiverse for that reason.

On Mon, Aug 5, 2019, 05:20 Colin Ian King <email address hidden>
wrote:

> @Srinivas, dptfxtract is a binary, so it can't be packaged in
> debian/ubuntu. Is there source?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838590
>
> Title:
> Update thermald to 1.9 release
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/dptfxtract/+bug/1838590/+subscriptions
>

Colin Ian King (colin-king) wrote :

Ah, I didn't know that, thanks Mario. @Antony, how's the update of dptfxtract progressing?

Anthony Wong (anthonywong) wrote :

I'm going to update it in these few days. The helper script will have to be adapted to the new conf file directory.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 1.9.0-1

---------------
thermald (1.9.0-1) unstable; urgency=medium

  * sync with latest upstream release 1.9 (LP: #1838590)
  * Add upstream fix:
    - dcdaf523393a Use correct format specifier for size_t
  * Update postinst, postrm, postpreinst rn_conffile package version
  * Update debian/compat to 12

 -- Colin King <email address hidden> Mon, 5 Aug 2019 09:12:15 +0100

Changed in thermald (Ubuntu):
status: New → Fix Released
Anthony Wong (anthonywong) wrote :

dptfxtract 1.4.2-0ubuntu1 uploaded to https://launchpad.net/~anthonywong/+archive/ubuntu/for-review/+packages for review.
Colin, could you help sponsor this upload?

Changed in dptfxtract (Ubuntu):
status: New → Confirmed
Colin Ian King (colin-king) wrote :

Sorry, I don't have per-package upload rights to dptfxtract, you need to ask a MOTU.

Mario Limonciello (superm1) wrote :

Reviewing the package in your PPA I do have a few comments that should be addressed.

1) It looks like the standards version has been downgraded. If being modified at all it should be bumped up to match standards version in Eoan. This should also be mentioned in debian/changelog
2) VCS-Git and VCS-Browser URLs shouldn't be updated to upstream, packaging isn't maintained there.
3) in dptfxtract-helper I'm wondering why do you need to switch to dptfxtract-static? Is there new dependency?
4) debian/rules changes look unnecessary to me, but should be mentioned in changelog if needed.
5) I think you should be updating the packaging at https://git.launchpad.net/~canonical-hwe-team/+git/dptfxtract, no?

Anthony Wong (anthonywong) wrote :

Oops, I think I took the bionic source package and updated from there... You're right we have a git tree and it should be used, I will post the correct version later.

Anthony Wong (anthonywong) wrote :

Re-uploaded to ppa:anthonywong/dptfxtract.
dptfxtract-helper uses the static build of dptfxtract as that will make backport to older ubuntu releases a bit easier, as the dynamic linked version may not work well in all environments.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dptfxtract - 1.4.2-0ubuntu1

---------------
dptfxtract (1.4.2-0ubuntu1) eoan; urgency=medium

  * New upstream release. (LP: #1838590)

 -- Anthony Wong <email address hidden> Fri, 09 Aug 2019 07:41:05 +0000

Changed in dptfxtract (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers