temp_unreadable is not initialized, will lead to thermald not reading thermal zones

Bug #1765572 reported by Colin Ian King on 2018-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thermald (Ubuntu)
Critical
Colin Ian King

Bug Description

thermald uninitialised member causes loss of temperature control, the patch 0002-Don-t-keep-on-reading-a-sensor-if-the-temperature-is.patch, added in 1.7.0-5, introduces a new cthd_sensor data member temp_unreadable but fails to initialise it.

This causes nondeterministic behaviour. If any bits of the uninitialised boolean are nonzero, it will be evaluate to true, and the sensor will be silently disabled, causing loss of temperature control.

This bug is critical because loss of temperature control risks physical hardware damage.

Changed in thermald (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Colin Ian King (colin-king)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 1.7.0-5ubuntu1

---------------
thermald (1.7.0-5ubuntu1) bionic; urgency=medium

  [ Ben Caradoc-Davies ]
  * Fix non-initialized temp_unreadable (Closes: #896132) (LP: #1765572)
    - fixes regression caused by previous fix, initialise
      temp_unreadable to restore temperature control.

 -- Colin King <email address hidden> Fri, 20 Apr 2018 02:08:23 +0100

Changed in thermald (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers