very excessive logging

Bug #1494461 reported by Jamie Strandboge on 2015-09-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thermald (Ubuntu)
High
Colin Ian King
Trusty
High
Colin Ian King
Vivid
High
Colin Ian King

Bug Description

Every 4 seconds themald is logging the exact same two messages. Eg:

Sep 10 14:13:48 xxxx thermald[981]: set cdev state index 10 state 0 wr:15000000
Sep 10 14:13:48 xxxx thermald[981]: Set : 71000, 26800, 10, 0, 0
Sep 10 14:13:52 xxxx thermald[981]: set cdev state index 10 state 0 wr:15000000
Sep 10 14:13:52 xxxx thermald[981]: Set : 71000, 26800, 10, 0, 0
Sep 10 14:13:56 xxxx thermald[981]: set cdev state index 10 state 0 wr:15000000
Sep 10 14:13:56 xxxx thermald[981]: Set : 71000, 26800, 10, 0, 0
Sep 10 14:14:00 xxxx thermald[981]: set cdev state index 10 state 0 wr:15000000
Sep 10 14:14:00 xxxx thermald[981]: Set : 71000, 26800, 10, 0, 0
Sep 10 14:14:04 xxxx thermald[981]: set cdev state index 10 state 0 wr:15000000
Sep 10 14:14:04 xxxx thermald[981]: Set : 71000, 26800, 10, 0, 0

Attached is my /etc/thermald/thermal-conf.xml.

Adding '--loglevel=warn' to ExecStart in /lib/systemd/system/thermald.service suppresses the messages. I'm not sure if this is a good default though.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: thermald 1.4.3-3~15.04.1
ProcVersionSignature: Ubuntu 4.2.0-6.6-generic 4.2.0-rc8
Uname: Linux 4.2.0-6-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.17.2-0ubuntu1.3
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Sep 10 14:12:19 2015
InstallationDate: Installed on 2015-06-13 (88 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: thermald
UpgradeStatus: No upgrade log present (probably fresh install)

Jamie Strandboge (jdstrand) wrote :
description: updated
Jamie Strandboge (jdstrand) wrote :
description: updated
description: updated
Changed in thermald (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Colin Ian King (colin-king)
Colin Ian King (colin-king) wrote :

These warnings were fixed and landed upstream with commits:

https://github.com/01org/thermal_daemon/commit/6529d07e4dfdac48b34aabbbc5ace86570da6bc6
https://github.com/01org/thermal_daemon/commit/830c56c0143d24aa65de820c4ba9eea249e66616

[SRU Justification] (Vivid, Trusty)

thermald is spamming the log with messages there are essentially debug messages. These have been fixed upstream and are in the Wily version of thermald 1.4.3-5 and are the only changes in patches between that and the current vivid and trusty versions. Therefore a backport of the wily version seems like a sane way forward.

[Test Case]
Without the patches, once can observe debug messages such as
Sep 10 14:13:48 xxxx thermald[981]: Set : 71000, 26800, 10, 0, 0
Sep 10 14:13:52 xxxx thermald[981]: set cdev state index 10 state 0

Wit the fix these messages are only observable when the loglevel is set to debug

[Regression Potential]
Since this is a change in a log message type there is minimal change. This code is already fixed upstream and working in Wily with no regressions observed.

Hello Jamie, or anyone else affected,

Accepted thermald into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/thermald/1.4.3-5~15.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in thermald (Ubuntu):
status: In Progress → Fix Released
Changed in thermald (Ubuntu Trusty):
assignee: nobody → Colin Ian King (colin-king)
Changed in thermald (Ubuntu Vivid):
assignee: nobody → Colin Ian King (colin-king)
status: New → Fix Committed
tags: added: verification-needed
Changed in thermald (Ubuntu Trusty):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Jamie, or anyone else affected,

Accepted thermald into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/thermald/1.4.3-5~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Colin Ian King (colin-king) wrote :

Verified on 14.04 trusty - logging messages are less spammy as expected

Jamie Strandboge (jdstrand) wrote :

I reverted my workaround and observed the excessive logging. I then upgraded to https://launchpad.net/ubuntu/+source/thermald/1.4.3-5~15.04.1 on vivid and thermald successfully started and is no longer excessively logging.

tags: added: verification-done-trusty verification-done-vivid
removed: verification-needed
Jamie Strandboge (jdstrand) wrote :

I added verification-done-trusty on Colin's behalf (I did not test trusty).

Colin Ian King (colin-king) wrote :

Verified on 14.04 vivid - logging messages are less spammy as expected too

Changed in thermald (Ubuntu Trusty):
importance: Undecided → High
Changed in thermald (Ubuntu Vivid):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 1.4.3-5~14.04.1

---------------
thermald (1.4.3-5~14.04.1) trusty; urgency=medium

  * Backport to trusty, fix debug spam in log (LP: #1494461)

 -- Colin King <email address hidden> Fri, 11 Sep 2015 13:19:20 +0100

Changed in thermald (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for thermald has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 1.4.3-5~15.04.1

---------------
thermald (1.4.3-5~15.04.1) vivid; urgency=medium

  * Backport to vivid, fix debug spam in log (LP: #1494461)

 -- Colin King <email address hidden> Fri, 11 Sep 2015 13:19:20 +0100

Changed in thermald (Ubuntu Vivid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers