SRU thermald backport of thermald 1.4.3-2

Bug #1479052 reported by Colin Ian King
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thermald (Ubuntu)
Invalid
High
Colin Ian King
Trusty
Fix Released
High
Colin Ian King
Vivid
Fix Released
High
Colin Ian King

Bug Description

Thermald 1.4.3 contains a delta of bug fixes and support for more recent Intel processors and kernel interfaces available for the trusty kernel that are advantageous for HWE enablement and users with newer chipsets.

This SRU is for thermald backport to Vivid and to Trusty HWE kernels.

Specific fixes that I deem as absolutely necessary:

Vivid:
 * Fix postinst (original postinst logic was braindead)
 * Fix marshalling array error
 * Fix regression in exit via dbus message
 * New DBUS message to get sensor temperature at a given index
 * Fix buffer overrun on a readlink

Trusty, the above plus also:
 * Improve accuracy of unit_value calculation
 * Null terminate buffer on error return path
 * Fix resource leak on file descriptor, close fd on error return paths
 * thermald.conf: start only at runlevels 2,3,4,5
 * Fix assumption about hwmon0
 * Adjust for coretemp path change (kernel interface change)

The update also includes various minor miscellaneous fixes, e.g
 * typos in man page
 * typos in options such as --ingore-cpu-check --> --ignore-cpu-check

[Test Case]
a) Test on various CPU types, pre-Sandybridge, Sandybridge, post-Sanybridge modern CPUs (e.g. Ivybridge, Haswell, etc)

Use CPU stressor tools (stress-ng) to force thermal overrun:
   1) lts-trusty: does it install and work and perform thermal zone controls on CPUs where it has kernel interfaces to control the H/W. Can we boot after it is installed?
   2) lts-trusty: does it install and cleanly terminate and not cause any issues on CPUs where it cannot control the H/W
   3) does it work on pre-lts trusty 3.13 kernel with intel_pstate force enabled to see it works with older kernel in pstate enable mode.

[Regression Potential]
  1) Thermald does not exit and tries to control older H/W where it has no ability to control thermal zones
  2) Thermald does not install correctly (to be checked for on older H/W or newer H/W scenarios)
  3) Thermald causes install/boot issues.

Changed in thermald (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Colin Ian King (colin-king)
description: updated
description: updated
description: updated
description: updated
description: updated
Adam Conrad (adconrad)
Changed in thermald (Ubuntu Trusty):
assignee: nobody → Colin Ian King (colin-king)
Changed in thermald (Ubuntu Vivid):
assignee: nobody → Colin Ian King (colin-king)
Changed in thermald (Ubuntu):
status: In Progress → Invalid
Changed in thermald (Ubuntu Trusty):
importance: Undecided → High
Changed in thermald (Ubuntu Vivid):
importance: Undecided → High
Changed in thermald (Ubuntu Trusty):
status: New → In Progress
Changed in thermald (Ubuntu Vivid):
status: New → In Progress
summary: - SRU thermald backport of thermald 1.4.3
+ SRU thermald backport of thermald 1.4.3-2
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello Colin, or anyone else affected,

Accepted thermald into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/thermald/1.4.3-2~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in thermald (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in thermald (Ubuntu Vivid):
status: In Progress → Fix Committed
Revision history for this message
Adam Conrad (adconrad) wrote :

Hello Colin, or anyone else affected,

Accepted thermald into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/thermald/1.4.3-2~15.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Colin Ian King (colin-king) wrote :

For 14.04.3 LTS point release:

CPU stressed with: stress-ng --matrix 0 -t 1800
CPU metrics measured with: powerstat -az 1 1800

PASSED = no regressions seen
         and thermald able to read and/or contol kernel thermal zones
  and no detrimental CPU freq control issues observed

Lenovo X220 (i3-2350M) Sandybridge
  3.19.0-25 kernel:
    td-1.1~rc2 max temp matrix test, scaling works: PASSED
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED
  3.13.0-60 kernel:
    td-1.4.3-2~14.04.1 max temp matrix test: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test: intel_pstate=enable: PASSED
    td-1.4.3-2~14.04.1 install and reboot: PASSED

HPMini210 (Atom N450)
  3.19.0-25 kernel:
    td-1.1~rc2 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED (no regressions)
  3.13.0-60 kernel:
    td-1.4.3-2~14.04.1 max temp matrix test: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test: intel_pstate=enable: PASSED (actually, too old for this)
    td-1.4.3-2~14.04.1 install and reboot: PASSED

Dell Inspiron (Core 2, 6400) Conroe
  3.19.0-25 kernel:
    td-1.1~rc2 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED (no regressions)
  3.13.0-60 kernel:
    td-1.4.3-2~14.04.1 max temp matrix test: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test: intel_pstate=enable: PASSED (actually too old for this)
    td-1.4.3-2~14.04.1 install and reboot: PASSED

Intel SDP (i7-3770) Ivy Bridge
  3.19.0-25 kernel:
    td-1.1~rc2 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED (finer control)
  3.13.0-60 kernel: (can't test, won't boot the SDP)

UEFI (Xeon E3-1275) Sandybridge
  3.19.0-25 kernel:
    td-1.1~rc2 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED
  3.13.0-60 kernel:
    td-1.4.3-2~14.04.1 max temp matrix test: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test: intel_pstate=enable: PASSED
    td-1.4.3-2~14.04.1 install and reboot: PASSED

Dell 1501 (AMD Turion64 X2 TL-50)
  3.19.0-25 kernel:
    td-1.1~rc2 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED
  3.13.0-60 kernel:
    td-1.4.3-2~14.04.1 max temp matrix test: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test: intel_pstate=enable: n/a on AMD cpu
    td-1.4.3-2~14.04.1 install and reboot: PASSED

Revision history for this message
Colin Ian King (colin-king) wrote :

15.04 test. 3.19 kernel, vivid

CPU stressed with: stress-ng --matrix 0 -t 1800
CPU metrics measured with: powerstat -az 1 1800

PASSED = no regressions seen
         and thermald able to read and/or contol kernel thermal zones
         and no detrimental CPU freq control issues observed

Lenovo X220 (i3-2350M) Sandybridge
  3.19.0-25 kernel:
    td-1.3.9 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED (finer control)

HPMini210 (Atom N450)
  3.19.0-25 kernel:
    td-1.3.9 max temp matrix test, scaling works: originally didn't work
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED

Dell Inspiron (Core 2, 6400) Conroe
  3.19.0-25 kernel:
    td-1.3.9 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED

Intel SDP (i7-3770) Ivy Bridge
  3.19.0-25 kernel:
    td-1.3.9 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED (finer control)

UEFI (Xeon E3-1275) Sandybridge
  3.19.0-25 kernel:
    td-1.3.9 max temp matrix test, scaling works: OK
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED (finer control)

Acer Aspire One (AMD Dual-Core C60)
    td-1.3.9 max temp matrix test, scaling works: not supported
    td-1.4.3-2~14.04.1 install and reboot: PASSED (no issues)
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED (cpu not supported)

Dell 1501 (AMD Turion64 X2 TL-50)
  3.19.0-25 kernel:
    td-1.3.9 max temp matrix test, scaling works: originally didn't work
    td-1.4.3-2~14.04.1 install and reboot: PASSED
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: PASSED

VM (kvm) Sandybridge emulation
    td-1.3.9 max temp matrix test, scaling works: OK (won't start, expected)
    td-1.4.3-2~14.04.1 install and reboot: PASSSED (thermald won't start, expected)
    td-1.4.3-2~14.04.1 max temp matrix test, scaling works: n/a (not themald)

Revision history for this message
Colin Ian King (colin-king) wrote :

Final tests, for 14.04.3 LTS point release, scenario where H/W does not support thermald. Test case:

1. Boot machine - check it works OK on default install
2. Update to new thermald
3. Check that thermald exits (as expected since it detects it cannot support the given H/W)
4. Reboot, check machine books fine
5. Check that thermald is not running (as expected)

Tested on virtual H/W in a VM: PASSED
Tested on Acer Aspire One (AMD Dual-Core C60): PASSED

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 1.4.3-2~14.04.1

---------------
thermald (1.4.3-2~14.04.1) trusty; urgency=medium

  * Backport to trusty to match HWE kernels, enabling
      more Intel platforms (LP: #1479052)
    - Improved support for recent Intel processors and kernel
      thermal control interfaces for wider chipset support.
    - Minor fixes, more robust thermald

 -- Colin King <email address hidden> Tue, 28 Jul 2015 18:55:00 +0100

Changed in thermald (Ubuntu Trusty):
status: Fix Committed → Fix Released
Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of the Stable Release Update for thermald has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thermald - 1.4.3-2~15.04.1

---------------
thermald (1.4.3-2~15.04.1) vivid; urgency=medium

  * Backport to vivid enabling more Intel platforms (LP: #1479052)
    - Improved support for recent Intel processors and kernel
      thermal control interfaces for wider chipset support.
    - Minor fixes, more robust thermald

 -- Colin King <email address hidden> Tue, 28 Jul 2015 18:55:00 +0100

Changed in thermald (Ubuntu Vivid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers