tgtd needs init script or upstart job

Bug #574554 reported by Brian Pitts on 2010-05-03
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Jaguarundi
Medium
Unassigned
tgt (Ubuntu)
Medium
Chuck Short
Lucid
Medium
Dustin Kirkland 
Maverick
Medium
Chuck Short

Bug Description

Binary package hint: tgt

This package currently lacks a script for starting the tgt daemon during system boot.

Related branches

Changed in tgt (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
Changed in tgt (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
milestone: none → maverick-alpha-2
Chuck Short (zulcss) wrote :
Chuck Short (zulcss) wrote :

The foundations team still hasnt reviewed the upstart script.

I would recommend not deploying this script as-is.

Using "and" in a "start on" condition links the two events, so neither can complete until the other occurs, and links them to your service so that neither can complete until your service starts.

In your script, this would link the "net-device-up IFACE=lo" event and the "filesystem" event together, and to you your service.

Since these are also used by key services required to boot the system, it's possible that tying them together would be a BAD THING. One could envision a scenario whereby the system wouldn't boot due to the service not starting correctly.

The rc-sysinit script already uses these events, for now it might be better to do "start on started rc-sysinit"

Thierry Carrez (ttx) on 2010-06-29
Changed in tgt (Ubuntu Maverick):
milestone: maverick-alpha-2 → maverick-alpha-3
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tgt - 1:1.0.4-1ubuntu1

---------------
tgt (1:1.0.4-1ubuntu1) maverick; urgency=low

  * debian/rules, debian/tgt.tgtd.upstart: Add upstart script. (LP: #574554)
 -- Chuck Short <email address hidden> Thu, 17 Jun 2010 10:22:39 -0400

Changed in tgt (Ubuntu Maverick):
status: Triaged → Fix Released

Chuck, your upstart job is missing a step. After launching tgtd, you need to run "tgt-admin -e" so that the config file /etc/tgt/targets.conf is parsed and the targets actually started.

Changed in tgt (Ubuntu Maverick):
status: Fix Released → Confirmed

Adding "post-start exec /usr/sbin/tgt-admin -e" to the upstart job works for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tgt - 1:1.0.4-1ubuntu2

---------------
tgt (1:1.0.4-1ubuntu2) maverick; urgency=low

  * debian/usptart: Add post-start exec to upstart script. (LP: #574554)
 -- Chuck Short <email address hidden> Fri, 16 Jul 2010 10:47:33 -0400

Changed in tgt (Ubuntu Maverick):
status: Confirmed → Fix Released
OlivierP (unineurone) wrote :

Any chance to get this into lucid backports ?

OlivierP (unineurone) wrote :

Reopening, not fixed.

Tried tgt 1.0.4-1ubuntu2 & 1.0.4-1ubuntu3 (on Lucid), fails with unknown job.
/etc/init/tgt.conf , post-start contains a typo:
"post-start exe /usr/sbin/tgt-admin -e"

Correcting:
post-start exec /usr/sbin/tgt-admin -e

Changed in tgt (Ubuntu Maverick):
status: Fix Released → In Progress
Dave Walker (davewalker) wrote :

Debdiff for Maverick

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tgt - 1:1.0.4-1ubuntu4

---------------
tgt (1:1.0.4-1ubuntu4) maverick; urgency=low

  * debian/upstart: Corrected typo with post-start command; Resolving
    "unknown job" error. (LP: #574554)
 -- Dave Walker (Daviey) <email address hidden> Mon, 09 Aug 2010 23:49:42 +0100

Changed in tgt (Ubuntu Maverick):
status: In Progress → Fix Released
Nick Barcet (nijaba) wrote :

Should this bug be nominated for an SRU in Lucid?

Chuck Short (zulcss) wrote :

Nick,

No

chuck

Dustin Kirkland  (kirkland) wrote :

Hey Chuck,

I thought maybe it should. tgt is pretty useless in Lucid without an upstart job, isn't it?

I just nominated it and marked it 'triaged/medium' for Lucid.

If you still disagree, please mark it won't-fix in Lucid.

Thanks, Chuck!
:-Dustin

Changed in tgt (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Chuck Short (zulcss)
assignee: Chuck Short (zulcss) → Dustin Kirkland (kirkland)
Chuck Short (zulcss) wrote :

Usually upstart backporting is not a good candidate for SRU.

chuck

Changed in tgt (Ubuntu Lucid):
status: Triaged → Won't Fix
Nick Barcet (nijaba) wrote :

Could we have a discussion about the impact, rather than just say no? I am lacking understanding of where adding a startup script where there was none could cause a regression...

Thanks,
Nick

Changed in jaguarundi:
status: New → Confirmed
importance: Undecided → Medium
Nick Barcet (nijaba) wrote :

After discussion in #ubuntu-devel, it was decided that fixing this in an SRU to lucid would be too dangerous:
"it would suddently start the daemon for people who have it installed, so that might be an unexpected behaviour change"

However, providing this updated package in lucid-backport would be completely acceptable and Chuck will soon upload it there. Once this is done, we can then use it by:

a) add the following to /ect/apt/preferences (or create the file if it does not exist):
Package: *
Pin: release a=lucid-backports
Pin-Priority: 400

b) install the backported package with:
sudo apt-get install -t lucid-backports tgt

More details on the logic at: https://help.ubuntu.com/community/UbuntuBackports#Use pinning to limit the backports repository

Yaron Sheffer (yaronf) wrote :

A few months later: was the back-ported package ever released for Lucid? I cannot find it at http://packages.ubuntu.com/lucid-backports/allpackages

Thanks,
       Yaron

M.Morana (mahmoh) on 2011-03-12
Changed in jaguarundi:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers