Please merge tgt 1.0.61-1 (main) from Debian unstable (main)

Bug #1524982 reported by Ryan Harper on 2015-12-10
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tgt (Ubuntu)
Wishlist
Unassigned

Bug Description

Please merge tgt 1.0.61-1 (main) from Debian unstable (main)

Ryan Harper (raharper) wrote :

debdiff between previous ubuntu version (1.0.57-1ubuntu2) and upstream debian (1.0.61-1).

Changed in tgt (Ubuntu):
importance: Undecided → Wishlist
status: New → In Progress
Ryan Harper (raharper) wrote :

debdiff between current ubuntu (1.0.57-1ubuntu2) and new ubuntu version (1.0.61-1ubuntu1).

Changed in tgt (Ubuntu):
status: In Progress → Confirmed

The attachment "debdiff_ubuntu_1.0.57-1ubuntu2_to_debian_1.0.61-1.diff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Daniel Holbach (dholbach) wrote :

It looks like there's now 1.0.62 in Debian - could you remerge?

Artur Rona (ari-tczew) on 2015-12-13
Changed in tgt (Ubuntu):
status: Confirmed → Incomplete
Ryan Harper (raharper) wrote :

Sorry missed the notification, I'll remerge 1.0.62.

Ryan Harper (raharper) wrote :

debdiff between previous ubuntu version (1.0.57-1ubuntu2) and upstream debian unstable (1.0.62-1).

Ryan Harper (raharper) wrote :

debdiff between current ubuntu (1.0.57-1ubuntu2) and new ubuntu version (1.0.62-1ubuntu1).

Changed in tgt (Ubuntu):
status: Incomplete → Confirmed
Robie Basak (racb) wrote :

Thanks, I'll take this review.

Hi Ryan,

Thank you for re-merging 1.0.62.

The diff that is most important to me is New Debian -> New Ubuntu, since that
is the "Ubuntu delta" that we try to minimise. It's no problem for me to
generate it based on what you provided, but note that my review below is
primarily based on looking at this diff so you might want to generate it too.

For clarity, the "new delta" is 1.0.62-1 -> 1.0.62-1ubuntu1 as created by you
(but manually generated by me as above), and the "old delta" is 1.0.57-1 ->
1.0.57-1ubuntu2 which we can also generate. What we want to transform the old
delta into a minimal new delta, dropping anything that is no longer needed and
possibly adding anything that needs fixing up.

The changelog and "update-maintainer" are correctly merged. Thank you.

But things dropped from the delta should be documented in the new changelog
entry. For example, Mathieu's fix in debian/tgt.service has been taken up by
Debian.

I see things documented as "remaining changes" but I don't see them in the
new delta. For example, I see no remaining delta in any patches.

I also see things in the new delta that are not documented in the changelog:

* glusterfs support is dropped, but this is no longer documented.

* debian/tests/daemon are both changed, and I don't know why.

* debian/bash-completion is modified, and I don't know why.

Some unnecessary parts of the delta that I think should now be dropped:

* The upstart script, since tgt isn't used on the phone and we no longer use
  upstart. So Debian could carry the upstart script, but there is no need for
  us to maintain a delta for it in Ubuntu.

* "+XS-Testsuite: autopkgtest" is no longer needed: the latest dpkg does the
  necessary stuff automatically now. Debian can carry it if they want, but
  there is no need for us to maintain a delta for it in Ubuntu.

You left conflict markers in debian/watch.

What we want is the delta minimised and completely explained in the changelog
entry in the merge. Then a future merger only needs to look at the previous
diff, changelog entry and any uploads made subsequent to the merge in order to
re-merge.

Please could you fix the above? Note that I haven't build or dep8 tested this -
I'm assuming it builds and tests pass.

Michael Terry (mterry) wrote :

I took this on and just uploaded 1.0.62-1ubuntu1. I was able to drop all deltas but the glusterfs one.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tgt - 1:1.0.62-1ubuntu1

---------------
tgt (1:1.0.62-1ubuntu1) xenial; urgency=low

  * Merge from Debian unstable (LP: #1524982, LP: #1518440). Remaining
    changes:
    - Drop glusterfs support, since it is not in main.
  * debian/upstart:
    - Dropped, we no longer use upstart (except on Touch, where tgt
      isn't used). Isn't worth a delta.
  * debian/watch:
    - Drop merge conflict markers accidentally left in.
  * debian/tests/*:
    - Drop delta with Debian here, they imported our tests and improved
      them a while back.
  * debian/tgt.service:
    - Drop delta here, Debian made the same change.
  * debian/bash-completion:
    - Dropped, Debian has the same thing, just as tgt.bash-completion.

 -- Michael Terry <email address hidden> Mon, 21 Dec 2015 14:20:23 -0500

Changed in tgt (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers