no ipv6 support (use udp4 in inetd.conf)

Bug #73233 reported by kriss
10
Affects Status Importance Assigned to Milestone
tftp-hpa (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: tftpd-hpa

Hi,

Like all TFTP daemons in ubuntu tftpd-hpa does not support ipv6
(see: https://lists.ubuntu.com/archives/sounder/2006-July/008297.html)

Change the entry in inetd.conf to udp4

Tags: bitesize ipv6
Revision history for this message
kriss (kriss) wrote :
description: updated
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

 Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in tftp-hpa:
status: New → Confirmed
Revision history for this message
Joe Smith (yasumoto7) wrote :

Here's a debdiff (my first). Please let me know if there's anything I forggot. I'm not sure if this is an issue in Debian, but I'll check in #motu for some help.

Revision history for this message
Joe Smith (yasumoto7) wrote :

Fixed the changelog to include the launchpad bug number. Thanks geser

Revision history for this message
Mathias Gug (mathiaz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Intrepid Ibex.

tftpd-hpa works correctly with udp. Please make sure that the bug is still relevant for the release you're preparing a debdiff for.

Changed in tftp-hpa:
status: Confirmed → Fix Released
Revision history for this message
VadimL (vadim-mbdsys) wrote :

When i'm using udp4 in inetd.conf on interpid i'm getting following form xinetd:

xinetd[29119]: inetd.conf - Protocol udp4 not in /etc/protocols [file=/etc/inetd.conf] [line=3]

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers