[SRU] Please upgrade tftpd-hpa in lucid to at least 5.0-14

Bug #683955 reported by Michael Haro on 2010-12-02
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tftp-hpa (Debian)
Fix Released
Unknown
tftp-hpa (Ubuntu)
Low
Unassigned
Lucid
Medium
Chuck Short
Natty
Low
Unassigned

Bug Description

Binary package hint: tftp-hpa

Debian resolved bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=541184, tftpd-hpa: tftpd stops logging after logrotate has "rotated" stating that this is fixed in 5.0-14.

Please update the version of tftpd-hpa in lucid to this version so that the daemon will continue logging.

Thanks.

scm (scm) on 2010-12-02
tags: added: glucid
James Page (james-page) on 2010-12-02
tags: added: lucid
removed: glucid
James Page (james-page) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in tftp-hpa (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Dave Walker (davewalker) wrote :

Confirming, my Lucid tftp server has a distinct lack of entries in syslog since rotation.

Joel Ebel (jbebel) on 2010-12-02
tags: added: glucid
Changed in tftp-hpa (Ubuntu Lucid):
importance: Undecided → Medium
Changed in tftp-hpa (Ubuntu Lucid):
assignee: nobody → Chuck Short (zulcss)
milestone: none → lucid-updates
status: New → Confirmed
Chuck Short (zulcss) wrote :

This has been fixed in Natty im backporting the patch for lucid.

chuck

Changed in tftp-hpa (Ubuntu Natty):
status: Triaged → Fix Released
Chuck Short (zulcss) on 2010-12-16
summary: - Please upgrade tftpd-hpa in lucid to at least 5.0-14
+ [SRU] Please upgrade tftpd-hpa in lucid to at least 5.0-14
Chuck Short (zulcss) wrote :

Tftp-hpa in lucid was shipped with a bug that when the log files are rotated nothing is written in the log files after the restart. This has been fixed in natty with a recent merge of tftp-hpa. I have backported the back to lucid and have attached the debdiff to this bug.

To reproduce:

1. Install tftpd-hpa
2. Check to see if log files for tftpd-hpa is running.
3. Rotate the /etc/cron.daily/logrotate
4. Check to see if tftpd-hpa is writting to the log files.

If you have any questions please let me know.

Chuck Short (zulcss) wrote :

Tftp-hpa in lucid was shipped with a bug that when the log files are rotated nothing is written in the log files after the restart. This has been fixed in natty with a recent merge of tftp-hpa. I have backported the back to lucid and have attached the debdiff to this bug.

To reproduce:

1. Install tftpd-hpa
2. Check to see if log files for tftpd-hpa is running.
3. Rotate the /etc/cron.daily/logrotate
4. Check to see if tftpd-hpa is writting to the log files.

If you have any questions please let me know.

Accepted tftp-hpa into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tftp-hpa (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Imre Gergely (cemc) wrote :

I can't reproduce this. I just happen to have an LTSP server installed (Lucid 32bit), which uses tftpd-hpa for thin client bootup, and it works just fine.

root@ifptr-ltsp:/var/log# apt-cache policy tftpd-hpa
tftpd-hpa:
  Installed: 5.0-11ubuntu2
  Candidate: 5.0-11ubuntu2
  Version table:
 *** 5.0-11ubuntu2 0
        500 http://ro.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

What I did:

- fired up the ltsp server
- tail -f /var/log/syslog |grep tftp
- fired up a thin client, saw this in the logs:

Dec 21 21:04:29 localhost in.tftpd[2239]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.0
Dec 21 21:04:29 localhost in.tftpd[2239]: tftp: client does not accept options
Dec 21 21:04:29 localhost in.tftpd[2240]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.0
Dec 21 21:04:29 localhost in.tftpd[2241]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/3a9a0138-979c-d611-acb4-7924b73424e4
Dec 21 21:04:29 localhost in.tftpd[2242]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/01-00-0b-cd-de-d1-cb
Dec 21 21:04:29 localhost in.tftpd[2243]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C0A80001
Dec 21 21:04:29 localhost in.tftpd[2244]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C0A8000
Dec 21 21:04:29 localhost in.tftpd[2245]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C0A800
Dec 21 21:04:29 localhost in.tftpd[2246]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C0A80
Dec 21 21:04:29 localhost in.tftpd[2247]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C0A8
Dec 21 21:04:29 localhost in.tftpd[2248]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C0A
Dec 21 21:04:29 localhost in.tftpd[2249]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C0
Dec 21 21:04:29 localhost in.tftpd[2250]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/C
Dec 21 21:04:29 localhost in.tftpd[2251]: RRQ from 192.168.0.1 filename /ltsp/i386/pxelinux.cfg/default
Dec 21 21:04:29 localhost in.tftpd[2252]: RRQ from 192.168.0.1 filename /ltsp/i386/vmlinuz
Dec 21 21:04:30 localhost in.tftpd[2253]: RRQ from 192.168.0.1 filename /ltsp/i386/initrd.img
Dec 21 21:04:36 localhost in.tftpd[2256]: RRQ from 192.168.0.1 filename /ltsp/i386//lts.conf

- ran logrotate (forced, because /etc/cron.daily/logrotate doesn't necessarily rotate the syslog if you run it manually):
/usr/sbin/logrotate -f /etc/logrotate.conf
- check /var/log/syslog* that indeed it was rotated
- re-ran tail -f /var/log/syslog (to watch the new syslog file and NOT syslog.1)
- rebooted the thin client, saw the exact same thing logged to syslog (in.tftpd was running all this time, I didn't restart it)

root@ifptr-ltsp:/var/log# apt-cache policy rsyslog
rsyslog:
  Installed: 4.2.0-2ubuntu8.1
  Candidate: 4.2.0-2ubuntu8.1

What am I doing wrong?

Michael Haro (mharo) wrote :

apt-get install tftpd-hpa=5.0-11ubuntu2

using a tftp client fetch a file. note that it shows up in the log.
restart rsyslog
fetch the file again. note that it doesn't show up in the log.

apt-get install tftpd-hpa=5.0-11ubuntu2.1
using a tftp client fetch a file. note that it shows up in the log.
restart rsyslog
fetch the file again. note that it does show up in the log.

Looks like the proposed package fixes the problem I'm experiencing.

Martin Pitt (pitti) on 2010-12-21
tags: added: verification-done
removed: verification-needed

As a note, you need to turn on verbosity by adding -v to TFTP_OPTIONS in /etc/default/tftpd-hpa, otherwise the daemon do not log file get. Useful to know when testing.

Beside, I can confirm the proposed update fix the bug too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tftp-hpa - 5.0-11ubuntu2.1

---------------
tftp-hpa (5.0-11ubuntu2.1) lucid-proposed; urgency=low

  * debian/patches/02-socket.patch: Backport upstream patch
    to fix syslog bug when rotating log files. (LP: #683955)
  * Rediffed debian/patches/03-progname.patch to take account
    of the new patch.
 -- Chuck Short <email address hidden> Thu, 16 Dec 2010 10:29:41 -0500

Changed in tftp-hpa (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in tftp-hpa (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.