Typing in Texmaker causes high CPU usage in Xorg

Bug #368092 reported by skorasaurus on 2009-04-27
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
texmaker (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: texmaker

I have also noticed while I type in texmaker, x-org's CPU usage increases dramatically. It peaks up to 88% if I type consistently.
As soon as I stop typing, the usage decreases dramatically to 5-15%, its normal rate.

I just upgraded from intrepid and did not have these problems using intrepid.

Another user has experienced this problem as well - http://ohioloco.ubuntuforums.org/showthread.php?t=1125410

Regards,
Will

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: texmaker 1.8-1ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: texmaker
Uname: Linux 2.6.28-11-generic i686

skorasaurus (skoraw) wrote :
skorasaurus (skoraw) wrote :

I have also attached my Xorg's log (from /var/log/Xorg.0.log)

Johannes Roth (jsroth) wrote :

Can confirm the bug here, Texmaker 1.8 and Jaunty on a Thinkpad T60

hinogi (stefan-schneider) wrote :

I made the same observation with the CPU loadout with Texmaker 1.8 and Ubuntu 9.04 on an Acer Travelmate C300.

Søren Vind (sorenvind) wrote :

I can also confirm this bug. Running on a Lenovo x200, Jaunty amd64 and texmaker 1.8. It makes texmaker more or less unusable.

Oliver Garrod (oliver-psy) wrote :

I have the same problem. Fujitsu-Siemens Amilo D 8820, Ubuntu 9.04 i386, Texmaker 1.8.
FWIW, I seem to get the same problem with Kile as well.

I have this problem with Kile 2.1 and Ubuntu 9.04 on a ThinkPad R51

Simon Steinbeiß (ochosi) wrote :

i experience exactly the same like bjarnheidur. but i would assume that those problems are not connected to the texmaker bug, so i submitted a new, separate bugreport for kile (#380888).

Robert (robert-lovrincic-kip) wrote :

I have the same problem with Jaunty amd64 and Texmaker 1.8.

tian (nopararas) wrote :

Workaround
texmaker -graphicssystem raster
It is the same problem and wokarround as posted for kile in:
https://bugs.launchpad.net/ubuntu/+source/kile/+bug/361843

skorasaurus (skoraw) wrote :

After upgrading to Karmic, I am no longer experiencing this bug.

I'm using Texmaker 1.9.2 and 2.6.31-17-generic

If anyone is still experiencing this bug, I'll reopen it.

Changed in texmaker (Ubuntu):
status: New → Fix Released
nemarona (nemarona) wrote :

I can confirm that the bug is still present in Ubuntu 11.10 after upgrading from 11.04 (where I never noticed it). For me it only occurs after I switch from some other window to the Texmaker window.

John Woods (john-o-woods) wrote :

I'm using 11.10 and I still have this problem. The -graphicssystem raster workaround works for me, but I also seem to get this bug in gedit.

fivetonsofflax (gibmirspam) wrote :

I can confirm this bug for 11.10 (64bit). The workaround makes it run well, though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers