Ubuntu

GPL Ghostscript 8.61: Set UseCIEColor for UseDeviceIndependentColor to work properly

Reported by Manuel López-Ibáñez on 2008-11-05
4
Affects Status Importance Assigned to Milestone
texlive-extra (Ubuntu)
Undecided
Unassigned

Bug Description

Ghostscript in Hardy gives the following warning:

GPL Ghostscript 8.61: Set UseCIEColor for UseDeviceIndependentColor to work properly

This affects for example, epstopdf

1. wget "http://curso-estadistica.googlecode.com/svn-history/r5/trunk/tmp/Rplots.ps"
2. epstopdf Rplots.ps

The following link has more info

http://www.michaelshell.org/tex/testflow/

however I cannot silence the warning following his approach.

Changed in ghostscript (Ubuntu):
status: New → Fix Released

It still happens in 10.04:

GPL Ghostscript 8.71: Set UseCIEColor for UseDeviceIndependentColor to work properly.

using okular to see a postscript file.

Changed in ghostscript (Ubuntu):
status: Fix Released → New
Till Kamppeter (till-kamppeter) wrote :

The originally reported bug here is not a problem of Ghostscript, but of how the /usr/bin/epstopdf script calls Ghostscript. The script is part of texlive-font-utils, moving ...

Sorry for closing the bug, I confused it with the warning being issued during the print workflow. In the print workflow I have fixed the problem by calling Ghostscript with "-dColorConversionStrategy=/LeaveColorUnchanged" instead of "-dUseDeviceIndependentColor", At least in the print workflow one can do so as the pre-filter for turning incoming PostScript to PDF is not supposed to do color corrections.

affects: ghostscript (Ubuntu) → texlive-extra (Ubuntu)
Till Kamppeter (till-kamppeter) wrote :

manu, your problem is probably in the way how okular calls Ghostscript. Please file a new bug in okular.

I cannot reproduce this anymore.

Changed in texlive-extra (Ubuntu):
status: New → Fix Released

In fact, I can reproduce it with both Okular and ps2pdf, but it seems harmless.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers