[SRU] Missing dependency on ed causes texconfig to fail silently in texlive-binaries

Bug #577305 reported by Evan Broder on 2010-05-08
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
texlive-bin (Debian)
Fix Released
Unknown
texlive-bin (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

texlive-binaries lacks a dependency on ed that was previously present in texlive-base-bin. Because texconfig uses ed for, well, editing files, this causes texconfig to...no longer edit files, which causes it to silently do nothing, but without returning a non-0 error code.

IMPACT: Attempting to use texconfig on systems without ed installed causes it to do nothing without failing

DEVELOPMENT: This bug still has not been addressed in the development branch, but I've filed a bug with Debian to get the dependency added which will hopefully get synced

PATCH: Attached in http://launchpadlibrarian.net/48042338/texlive-bin_2009-5ubuntu0.1_lp577305.debdiff, with a test build in https://launchpad.net/~anders-kaseorg/+archive/ppa

INSTRUCTIONS: Create a bare-bones chroot without ed installed. Install texlive-binaries and texlive-base. Run `texconfig-sys paper letter`. Install ed. Run `texconfig-sys paper letter` again. Observe that texconfig now gives several lines of output of changed configuration files.

REGRESSION: This is just adding a single dependency, so the regression potential should be minimal

(Note that ed is depended on by ubuntu-standard, so the impact of this bug is comparatively slim, but it does affect things like build chroots)

Anders Kaseorg (andersk) on 2010-05-08
Changed in texlive-bin (Ubuntu):
status: New → Confirmed
Evan Broder (broder) wrote :
description: updated
summary: - Missing dependency on ed causes texconfig to fail silently in texlive-
- binaries
+ [SRU] Missing dependency on ed causes texconfig to fail silently in
+ texlive-binaries
Anders Kaseorg (andersk) wrote :

Better debdiff that adds ed to Depends instead of Replaces. :-)

Evan Broder (broder) on 2010-05-08
description: updated
Evan Broder (broder) wrote :

Anders uploaded the package to his PPA (https://launchpad.net/~anders-kaseorg/+archive/ppa). I've verified that the package there eliminates this bug and causes texconfig to work again.

description: updated
John Dong (jdong) wrote :

ACK to Anders's "better" debdiff ;-)

Changed in texlive-bin (Debian):
status: Unknown → New
Benjamin Drung (bdrung) wrote :

No response from Debian in three month. Don't wait any longer for getting it fixed in Debian first.

Benjamin Drung (bdrung) wrote :

uploaded Anders's debdiff to lucid-proposed

Changed in texlive-bin (Ubuntu Lucid):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package texlive-bin - 2009-6ubuntu1

---------------
texlive-bin (2009-6ubuntu1) maverick; urgency=low

  * Add missing dependency on ed to texlive-binaries. (Closes: #580732,
    LP: #577305)
 -- Anders Kaseorg <email address hidden> Sun, 15 Aug 2010 00:24:43 +0200

Changed in texlive-bin (Ubuntu):
status: Confirmed → Fix Released

On Sa, 14 Aug 2010, Benjamin Drung wrote:
> No response from Debian in three month. Don't wait any longer for
> getting it fixed in Debian first.

Ahhh .. ever thought about checking the repository? I have packages
ready but I need to prepare n email to release managers, as we (Debian)
are in freeze.

Funny how fast you draw conclusions.

Best wishes

Norbert
------------------------------------------------------------------------
Norbert Preining preining@{jaist.ac.jp, logic.at, debian.org}
JAIST, Japan TeX Live & Debian Developer
DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
------------------------------------------------------------------------
QUALL (vb.)
To speak with the voice of one who requires another to do something
for them.
   --- Douglas Adams, The Meaning of Liff

Benjamin Drung (bdrung) wrote :

http://packages.qa.debian.org/t/texlive-bin.html doesn't link to a repository. The Debian bug doesn't have a comment and to 'pending' tag. I haven't done more investigation.

I wanted to get this bug report from the sponsors list. We can sync the package once the fixed package hits Debian.

Steve Langasek (vorlon) wrote :

On Tue, Aug 17, 2010 at 02:09:29AM -0000, Norbert Preining wrote:
> Ahhh .. ever thought about checking the repository?

If you want people to know about your repository, please document it in
debian/control using the fields defined in 6.2.5.2 of the Debian developer's
reference. The texlive-bin source package currently has no such field
defined, which means the location of your repository is not discoverable
using the normal Debian procedures.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Accepted texlive-bin into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

> If you want people to know about your repository, please document it in
> debian/control using the fields defined in 6.2.5.2 of the Debian developer's
> reference.

I will do that.

Still I expect people taking our work from Debian and using it in Ubuntu to know without further ado where the repository is.

BTW, most Ubuntu patches are as useless as a pit in the bag, because they are based on the actual debian source package. But the source packages of the arch-indep packages are generated from a different setup, so ehatever patches there come in do not help at all.

> The texlive-bin source package currently has no such field
> defined, which means the location of your repository is not discoverable
> using the normal Debian procedures.

google-that-for-me ...

If one wants to contribute there are teo simple things:
- read the debian-tex-maint@ debian ml
- checkout the actual repository
and send patches relative to that.

Anything else is mostly nuisance, sorry to say that. I stopped reading quite some time ago the Ubuntu bug reports becausr the noise-info level is so low that it is wasted time (typical quality: "foobar is broken" turning out that disk space is running out).

If those happy Ubuntu hackers would fix things at the root that would be such an improvement ...

enough ranting

Norbert

I can reproduce the problem in Lucid _and_ it is not fixed in Maverick.
The problem is that texconfig fails to run /usr/share/texmf/texconfig/tcfmgr which is provided by texlive-base which in turn needs ed.
So a possible fix could be that texlive-binaries depends on texlive-base which in turn should depend on ed because tcfmgr (or one of the callee) needs it.

The same issue occurs in maverick. To reproduce with the current version in maverick:
$ apt-get remove --purge texlive-base texlive-binaries ed
$ apt-get install texlive-binaries
$ texconfig paper a4 (nothing happens)
$ apt-get install texlive-base
$ texconfig paper a4
$ texconfig paper letter
Shows modified config lines (in lucid is displays nothing because ed was not installed). That works but the fix is the wrong way round.

Marking as verification-failed.

Changed in texlive-bin (Ubuntu Lucid):
status: Fix Committed → In Progress
Changed in texlive-bin (Ubuntu):
status: Fix Released → In Progress
tags: added: verification-failed
removed: verification-needed
summary: - [SRU] Missing dependency on ed causes texconfig to fail silently in
- texlive-binaries
+ [SRU] Missing dependency on texlive-base causes texconfig to fail
+ silently in texlive-binaries

Jean-Baptiste: Are you sure you are looking at current versions of the packages (2009-5ubuntu0.2 in lucid-proposed, 2009-6ubuntu1 in maverick)? If so, after you ran
  $ apt-get remove --purge texlive-base texlive-binaries ed
  $ apt-get install texlive-binaries
the new dependency would have caused ed to be installed throughout the remainder of your tests. If it still didn’t work with ed installed, then you must be seeing a different bug.

The following programs in the texlive-binaries package use ed:
  /usr/share/texlive-bin/debianize-fmtutil
  /usr/bin/fmtutil
  /usr/bin/texconfig
  /usr/bin/updmap
  /usr/bin/mktexfmt
and nothing in texlive-base uses ed. So the dependency really is in the right place.

Hi Anders,

The fix for ed is fine. it's another issue introduced in lucid. The problem is only with tcfmgr that is not installed when you install only texlive-binaries.

I think that's a regression introduced in lucid because in karmic tcfmgr was shipped in texlive-base-bin together with texconfig and other binaries. Since lucid they are shipped separately and texlive-base is not necessarily installed but fmtutil, texconfig, updmap and mktexfmt (in texlive-binaries) use it.

Anyway, I verified the ed fix in maverick and lucid and it's okay.

Thanks.

Changed in texlive-bin (Ubuntu Lucid):
status: In Progress → Fix Committed
summary: - [SRU] Missing dependency on texlive-base causes texconfig to fail
- silently in texlive-binaries
+ [SRU] Missing dependency on ed causes texconfig to fail silently in
+ texlive-binaries
Changed in texlive-bin (Ubuntu):
status: In Progress → Fix Released
tags: added: verification-done
removed: verification-failed
description: updated

On Fr, 20 Aug 2010, Jean-Baptiste Lallement wrote:
> I think that's a regression introduced in lucid because in karmic tcfmgr
> was shipped in texlive-base-bin together with texconfig and other

texlive-binaries are *NOT* supposed to be used by itself. This package
is only here to provide the plain binaries build from the sourc.etar.gz
to separate arch-indep from arch-depend packages.

Hardly any of these programs will work in a normal way when only
texlive-binaries is installed.

Best wishes

Norbert
------------------------------------------------------------------------
Norbert Preining preining@{jaist.ac.jp, logic.at, debian.org}
JAIST, Japan TeX Live & Debian Developer
DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
------------------------------------------------------------------------
HASTINGS (pl.n.)
Things said on the spur of the moment to explain to someone who comes
into a room unexpectedly precisely what it is you are doing.
   --- Douglas Adams, The Meaning of Liff

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package texlive-bin - 2009-5ubuntu0.2

---------------
texlive-bin (2009-5ubuntu0.2) lucid-proposed; urgency=low

  * Add missing dependency on ed to texlive-binaries. (LP: #577305)
 -- Anders Kaseorg <email address hidden> Sat, 08 May 2010 02:35:38 -0400

Changed in texlive-bin (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in texlive-bin (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.