texlive-pictures package should depend on ruby

Bug #713210 reported by Daniel Cordeiro on 2011-02-04
20
This bug affects 5 people
Affects Status Importance Assigned to Milestone
texlive-base (Debian)
Fix Released
Unknown
texlive-base (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: texlive-base

Hi,

Package texlive-pictures does not depends (or recommends) ruby. However, I found that /usr/bin/epspdf and /usr/bin/epspdftk depends on ruby.

I do have ruby1.9.1 installed, but both scripts call "ruby" directly and ruby1.9.1 provides the command "ruby1.9.1".

Thanks,
Daniel

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: texlive-pictures 2009-10
ProcVersionSignature: Ubuntu 2.6.35-26.46-generic 2.6.35.10
Uname: Linux 2.6.35-26-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Feb 4 14:45:20 2011
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=pt_BR.utf8
 LANGUAGE=pt_BR:en
SourcePackage: texlive-base

Daniel Cordeiro (dcordeiro) wrote :
Daniel Cordeiro (dcordeiro) wrote :

Just an small update, epspdf does not work in ruby1.9.1. It must depend on ruby1.8 (and libtcltk-ruby1.8 for epspdftk).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in texlive-base (Ubuntu):
status: New → Confirmed
Changed in texlive-base (Debian):
status: Unknown → New
Changed in texlive-base (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.