Ubuntu

powerdot in texlive-latex-recommended missing enumitem.sty

Reported by jimmy on 2008-09-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
texlive-base (Ubuntu)
Undecided
Unassigned

Bug Description

latex reports enumitem.sty as missing when I try to make simple powerdot presentation. I find that texlive-latex-extra has the enumitem latex package.

Simple latex powerdot follows

===============cut here===========

\documentclass{powerdot}

\title{Simple Test}
\author{JB}

\begin{document}
\maketitle

\begin{slide}{Quick Basics}

\begin{itemize}
\item demonstrate missing enumitem.sty
\end{itemize}

\end{slide}

\end{document}

===============cut here==========

============Error message=========

This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
 %&-line parsing enabled.
entering extended mode
(./simple.tex
LaTeX2e <2005/12/01>
Babel <v3.8h> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, loaded.
(/usr/share/texmf-texlive/tex/latex/powerdot/powerdot.cls
Document Class: powerdot 2005/12/06 v1.3 powerdot presentation class (HA,CE)
(/usr/share/texmf-texlive/tex/latex/xkeyval/xkeyval.sty
(/usr/share/texmf-texlive/tex/latex/xkeyval/xkeyval.tex
(/usr/share/texmf-texlive/tex/latex/xkeyval/keyval.tex)))
(/usr/share/texmf-texlive/tex/latex/base/article.cls
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
(/usr/share/texmf-texlive/tex/latex/base/size10.clo))
(/usr/share/texmf-texlive/tex/latex/base/size11.clo)
(/usr/share/texmf-texlive/tex/latex/geometry/geometry.sty)
(/usr/share/texmf-texlive/tex/latex/hyperref/hyperref.sty
(/usr/share/texmf-texlive/tex/latex/hyperref/pd1enc.def)
(/etc/texmf/tex/latex/config/hyperref.cfg)
(/usr/share/texmf-texlive/tex/latex/oberdiek/kvoptions.sty)
Implicit mode ON; LaTeX internals redefined
(/usr/share/texmf-texlive/tex/latex/ltxmisc/url.sty))
*hyperref using driver hdvips*
(/usr/share/texmf-texlive/tex/latex/hyperref/hdvips.def
(/usr/share/texmf-texlive/tex/latex/hyperref/pdfmark.def))
(/usr/share/texmf-texlive/tex/latex/graphics/graphicx.sty
(/usr/share/texmf-texlive/tex/latex/graphics/graphics.sty
(/usr/share/texmf-texlive/tex/latex/graphics/trig.sty)
(/etc/texmf/tex/latex/config/graphics.cfg)
(/usr/share/texmf-texlive/tex/latex/graphics/dvips.def)))
(/usr/share/texmf-texlive/tex/latex/pstricks/pstricks.sty
(/usr/share/texmf-texlive/tex/generic/pstricks/pstricks.tex
`PSTricks' v1.15 <2006/12/22> (tvz)
(/usr/share/texmf-texlive/tex/generic/pstricks/pstricks.con))
(/usr/share/texmf/tex/latex/xcolor/xcolor.sty
(/etc/texmf/tex/latex/config/color.cfg)))

! LaTeX Error: File `enumitem.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:

==============End error===================

jimmy (jimmy-cancer) wrote :

The distribution is Kubuntu 8.04.1. texlive-latex-recommended version 2007-13.

Stefan Kottwitz (stefan.k) wrote :

I can confirm it. See powerdot.cls 2005/12/06 v1.3 delivered with texlive 2007-13 line 155: \RequirePackage{enumitem}[2004/07/19]
powerdot depends on enumitem.

On Mo, 08 Sep 2008, Stefan Kottwitz wrote:
> I can confirm it. See powerdot.cls 2005/12/06 v1.3 delivered with texlive 2007-13 line 155: \RequirePackage{enumitem}[2004/07/19]
> powerdot depends on enumitem.

Well, that is life. Not all dependencies can be fixed with such a huge
amount of style files.

Please install texlive-latex-extra and be happy.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
ARTHUR What is an Algolian Zylatburger anyway?
FORD They're a kind of meatburger made from the most unpleasant parts
 of a creature well known for its total lack of any pleasant
 parts.
ARTHUR So you mean that the Universe does actually end not with a bang
 but with a Wimpy?
                 --- Cut dialogue from Fit the Fifth.
                 --- Douglas Adams, The Hitchhikers Guide to the Galaxy

Stefan Kottwitz (stefan.k) wrote :

I agree, it's not a big inconvenience and can easily be solved. I would just suggest to fix dependencies at least for important class files, perhaps with texlive 2008, I would be glad to contribute by testing or with suggestions.

Norbert Preining (preining) wrote :

On Mo, 08 Sep 2008, Stefan Kottwitz wrote:
> just suggest to fix dependencies at least for important class files,

I wouldn't say that powerdot is that important ...

> perhaps with texlive 2008, I would be glad to contribute by testing or
> with suggestions.

That is too late, TL2008 has been release already. It would have been
necessary to report that to upstream (which in part is also me, but I
cannot care for upstream, Debian, and forwarding all those bugs from
Ubuntu/Debian, too, I am doing what I can already).

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
ARAGLIN (n. archaic)
A medieval practical joke played by young squires on a knight aspirant
the afternoon he is due to start his vigil. As the knight arrives at
the castle the squires attempt to raise the drawbridge very suddenly
as the knight and his charger step on to it.
   --- Douglas Adams, The Meaning of Liff

Stefan Kottwitz (stefan.k) wrote :

> I wouldn't say that powerdot is that important ...
Not for me, but I know it as alternative to the beamer class for quick development of slides without pgf, using pstricks, as successor of prosper, HA-prosper. I prefer beamer but i wouldnt consider powerdot as really unimportant.

> That is too late, TL2008 has been release already
I know that it's been released, but is it too late to adjust the dependencies in Ubuntu Linux? I don't mean to change powerdot, just to reconsider dependencies. On one side enumitem is recommendable, on the other side, if powerdot is considered as not so important, it could be moved from texlive-latex-recommended to texlive-latex-extra like enumitem.

Norbert Preining (preining) wrote :

On Di, 09 Sep 2008, Stefan Kottwitz wrote:
> I know that it's been released, but is it too late to adjust the
> dependencies in Ubuntu Linux?

texlive-latex-recommended *depending* on texlive-latex-extra??

That would make the whole concept *completely* useless. For that we
could install *ONE* big package *texlive* that ships simply everything.

Sorry, no.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
BOTLEY
The prominent stain on a man's trouser crotch seen on his return from
the lavatory. A botley proper is caused by an accident with the push
taps, and should not be confused with any stain caused by insufficient
waggling of the willy.
   --- Douglas Adams, The Meaning of Liff

Stefan Kottwitz (stefan.k) wrote :

> texlive-latex-recommended *depending* on texlive-latex-extra??
Of course not. It would be sufficient to move powerdot to texlive-latex-extra, or to move enumitem to texlive-latex-recommended. Why should powerdot be "recommended" but enumitem, needed by powerdot, not. One could decide to move powerdot to texlive-latex-extra if enumitem wouldn't be "recommended", though I frequently noticed questions regarding lists solvable by enumitem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers