Please merge texinfo 4.13a.dfsg.1-8 from Debian unstable

Bug #833791 reported by أحمد المحمودي (Ahmed El-Mahmoudy) on 2011-08-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
texinfo (Ubuntu)
Undecided
Unassigned

Bug Description

texinfo (4.13a.dfsg.1-8ubuntu1) oneiric; urgency=low

  * Merge from debian unstable (LP: #661725), remaining changes:
    - debian/patches/int2size_t-fix-page-truncation: Cherrypick upstream
      variable size fix which manifested as info pages being truncated
      on a tab character.
  * Dropped change that got applied in Debian:
    + debian/patches/minor-buffer-size-fix: increase stack buffer size
      for sprintf of numeric values (LP: #569802).

 -- أحمد المحمودي (Ahmed El-Mahmoudy) <email address hidden> Thu, 25 Aug 2011 15:40:21 +0200

texinfo (4.13a.dfsg.1-8) unstable; urgency=low

  [ Hilmar Preusse ]
  * Actually apply patch texi2dvi_non-C_locale, really (Closes: #584191)
  * debian/patches/minor-buffer-size-fix: increase stack buffer size
    for sprintf of numeric values (Closes: #639114).

 -- Norbert Preining <email address hidden> Wed, 24 Aug 2011 23:56:17 +0900

texinfo (4.13a.dfsg.1-7) unstable; urgency=low

  * "grep [A-z]" does not work in non-C locale (Closes: #584191)
  * add option -h/--help to update-info-dir, and fix the man page according
    to it. Patch by Jari Aalto <email address hidden> (Closes: #541468)
  * fix lintian errors (missing misc:Depends deps in all packages)
  * remove conflicts on xemacs-support, it does not exist
  * bump standards version to 3.9.2: change conflicts to breaks as we
    are only moving files around (Closes: #611104)
  * info dumps core if # of window rows drops below 6 (Closes: #611151)
  * d/rules: depend build on $(QUILT_STAMPFN) instead of patch, this fixes
    an rare FTBFS caused by the build target having been run twice
    (Closes: #612502)
  * Add texi2dvi-local-fallback-syntax.diff to make texinfo run on dash
    (Closes: #619786)
  * Add funny build targets to make lintian happy

 -- Norbert Preining <email address hidden> Wed, 24 Aug 2011 08:26:25 +0900

Related branches

description: updated
Changed in texinfo (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package texinfo - 4.13a.dfsg.1-8ubuntu1

---------------
texinfo (4.13a.dfsg.1-8ubuntu1) oneiric; urgency=low

  * Merge from debian unstable (LP: #833791), remaining changes:
    - debian/patches/int2size_t-fix-page-truncation: Cherrypick upstream
      variable size fix which manifested as info pages being truncated
      on a tab character.
  * Dropped change that got applied in Debian:
    + debian/patches/minor-buffer-size-fix: increase stack buffer size
      for sprintf of numeric values (LP: #569802).

texinfo (4.13a.dfsg.1-8) unstable; urgency=low

  [ Hilmar Preusse ]
  * Actually apply patch texi2dvi_non-C_locale, really (Closes: #584191)
  * debian/patches/minor-buffer-size-fix: increase stack buffer size
    for sprintf of numeric values (Closes: #639114).

texinfo (4.13a.dfsg.1-7) unstable; urgency=low

  * "grep [A-z]" does not work in non-C locale (Closes: #584191)
  * add option -h/--help to update-info-dir, and fix the man page according
    to it. Patch by Jari Aalto <email address hidden> (Closes: #541468)
  * fix lintian errors (missing misc:Depends deps in all packages)
  * remove conflicts on xemacs-support, it does not exist
  * bump standards version to 3.9.2: change conflicts to breaks as we
    are only moving files around (Closes: #611104)
  * info dumps core if # of window rows drops below 6 (Closes: #611151)
  * d/rules: depend build on $(QUILT_STAMPFN) instead of patch, this fixes
    an rare FTBFS caused by the build target having been run twice
    (Closes: #612502)
  * Add texi2dvi-local-fallback-syntax.diff to make texinfo run on dash
    (Closes: #619786)
  * Add funny build targets to make lintian happy
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden> Tue, 06 Sep 2011 13:27:07 +0200

Changed in texinfo (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments