info reader now chokes on tab characters in info files

Bug #394808 reported by Max Bowsher
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
texinfo (Ubuntu)
Fix Released
Medium
Unassigned
Karmic
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: texinfo

I was attempting to view "info bash" and "info readline", and noticed that the menu items are missing from the display.

Upon investigation, it appears that the info reader now chokes on files containing a tab character, ignoring all remaining content up to the next start-of-node marker.

ProblemType: Bug
Architecture: amd64
Date: Thu Jul 2 18:05:30 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: info 4.13a.dfsg.1-4
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-10.12-generic
SourcePackage: texinfo
Uname: Linux 2.6.30-10-generic x86_64

Related branches

Revision history for this message
Max Bowsher (maxb) wrote :
Max Bowsher (maxb)
tags: added: regression-potential
Revision history for this message
C de-Avillez (hggdh2) wrote :

I ran a quick test, using GIT texinfo. After building, './info/ginfo bash' displayed the correct menu.

So this is confirmed, and we have to find the fix in GIT.

Changed in texinfo (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
C de-Avillez (hggdh2) wrote :
Revision history for this message
Max Bowsher (maxb) wrote :
Revision history for this message
C de-Avillez (hggdh2) wrote :

Marking as triaged. Max was able to find the fix in GIT (through some bisecting), and proposed a debdiff to correct it. Sponsors for Main are subscribed.

Changed in texinfo (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Max Bowsher (maxb) wrote :

Prompted by the character of the fix, I found an i386 machine to check on - as you might expect, the bug is not present there - only on amd64 etc. where int is a different size than size_t.

Revision history for this message
Max Bowsher (maxb) wrote :

I have subscribed ubuntu-release to this bug. I feel it is worthy of going into Karmic because being unable to read/navigate some info documentation is of severe impact to administrators of Ubuntu servers. (And quite irksome for other users too)

Revision history for this message
C de-Avillez (hggdh2) wrote :

One more point on why it is needed: most GNU packages ship with full documentation under 'info', and only the most common options in 'man' format (e..g., coreutils). So yes, I agree this is needed.

Revision history for this message
Norbert Preining (preining) wrote :

Hi everyone,

as the texindo/Debian maintainer, I don't understand what you are talking about. I am running amd64, I am running the same package, and info readline and TAB TAB does work without any problem.

I actually don't see that problem, and I will for sure not include a patch for a fix that is not showing up here.

All the best

Norbert

Revision history for this message
C de-Avillez (hggdh2) wrote :

Hi Norbert,

This is what I see with the official texinfo:

Revision history for this message
C de-Avillez (hggdh2) wrote :

and this is with GIT

Revision history for this message
Norbert Preining (preining) wrote : Re: [Bug 394808] Re: info reader now chokes on tab characters in info files

On Mi, 21 Okt 2009, C de-Avillez wrote:
> This is what I see with the official texinfo:

I don't have bash.info, and I cannot find it in Debian...

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining Associate Professor
JAIST Japan Advanced Institute of Science and Technology <email address hidden>
Vienna University of Technology <email address hidden>
Debian Developer (Debian TeX Task Force) <email address hidden>
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
LUSBY (n.)
The fold of flesh pushing forward over the top of a bra which is too
small for the lady inside it.
   --- Douglas Adams, The Meaning of Liff

Revision history for this message
Martin Pitt (pitti) wrote :

I can replicate it. "info readline" has a truncated menu (in fact, no menu). "info sed" works (this doesn't have tabs).

The patch looks fairly weird to me, though. What's so big in an info page to make an int overflow?

Max, do you have a pointer to the git change, for reference?

Revision history for this message
Martin Pitt (pitti) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

I confirm that the patch works correctly. Uploaded to unapproved, will go in after Karmic Release Candidate.

Changed in texinfo (Ubuntu Karmic):
status: Triaged → Fix Committed
Revision history for this message
C de-Avillez (hggdh2) wrote :

Now, we should still try to find out *why* the original Debian package does not show it. I was going to open a Debian bug on this but, per Norbert, there is no need, since he cannot replicate it (and the package was sync-ed!). Something changed in Ubuntu, but not on Debian?

Revision history for this message
Steve Langasek (vorlon) wrote :

Have reviewed the change and it looks to me like a correct fix for the bug; this is ok for karmic, but not a critical blocker for the release, so will only be accepted into the release pocket if something happens that requires us to respin all candidate ISOs. Otherwise, it can be uploaded to karmic-proposed for an SRU.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package texinfo - 4.13a.dfsg.1-4ubuntu1

---------------
texinfo (4.13a.dfsg.1-4ubuntu1) karmic; urgency=low

  * Cherrypick upstream variable size fix which manifested as info pages being
    truncated on a tab character. (LP: #394808)

 -- Max Bowsher <email address hidden> Tue, 20 Oct 2009 18:28:40 +0100

Changed in texinfo (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers