"Report a problem..." menu option is broken

Bug #816266 reported by Stephen Rees-Carter on 2011-07-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
testdrive (Ubuntu)
Medium
Andres Rodriguez

Bug Description

Clicking the "Report a Problem..." menu option under "Help" does nothing.
When running it from command line, this Traceback is produced:

valorin@gandalf:~$ testdrive-gtk
Traceback (most recent call last):
  File "<string>", line 5, in <module>
  File "/usr/share/launchpad-integration/launchpadintegration/main.py", line 48, in main
    pkginfo = PackageInfo.fromPackageName(options.package, logger)
  File "/usr/share/launchpad-integration/launchpadintegration/packageinfo.py", line 219, in fromPackageName
    '"%s"' % package)
launchpadintegration.packageinfo.PackageNotFoundError: Could not look up package info for "testdrive"

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: testdrive-gtk 3.13-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-11.47-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
Architecture: amd64
Date: Tue Jul 26 16:57:34 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: testdrive
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Stephen Rees-Carter (valorin) wrote :
Robert Roth (evfool) on 2011-07-26
Changed in testdrive (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
importance: Low → Medium
Revision history for this message
Jeremy Bicha (jbicha) wrote :

This bug happens if testdrive-gtk is installed but the testdrive metapackage is not installed. Changing the LPI package to testdrive-gtk fixes this.

Changed in testdrive (Ubuntu):
status: Confirmed → Triaged
Changed in testdrive (Ubuntu):
status: Triaged → Confirmed
assignee: nobody → Andres Rodriguez (andreserl)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package testdrive - 3.15-0ubuntu1

---------------
testdrive (3.15-0ubuntu1) precise; urgency=low

  * Re-enable 'Add Other ISO' button display. (LP: #884243)
  * Change UEC references to Cloud. (LP: #873231)
  * bin/testdrive-gtk: Change LPI package to testdrive-gtk (LP: #816266).
    Thanks to Jeremy Bicha for the fix.
 -- Andres Rodriguez <email address hidden> Mon, 31 Oct 2011 12:21:00 -0400

Changed in testdrive (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers