Testdrive incorrectly links "ubuntu mobile" to "kubuntu mobile"

Bug #645052 reported by Nicolas DERIVE
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
testdrive (Ubuntu)
Low
Andres Rodriguez

Bug Description

Binary package hint: testdrive

In the ubuntu tab, sync and launch "ubuntu mobile", you got "kubuntu mobile" and not the ubuntu one.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: testdrive 3.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
CheckboxSubmission: c4273c0f4f2b8d26cd6bf31cadfd2912
CheckboxSystem: a871981cb5bdf4d6ebd55be46becf77e
Date: Wed Sep 22 11:39:09 2010
Dependencies:

EcryptfsInUse: Yes
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
 LANGUAGE=fr_FR:fr:en_GB:en
SourcePackage: testdrive

Revision history for this message
Nicolas DERIVE (kalon33) wrote :

There is also no "kubuntu mobile" choice in kubuntu tab.

summary: - Testdrives incorrectly links "ubuntu mobile" to "kubuntu mobile"
+ Testdrive incorrectly links "ubuntu mobile" to "kubuntu mobile"
Changed in testdrive (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Andres Rodriguez (andreserl)
Revision history for this message
Andres Rodriguez (andreserl) wrote :

Hi Nicolas,

Thank you for your bug report and trying to make TestDrive better.

I just gave a deeper look into the issue of the incorrect links TestDrive. It is a bug in the ISO manifest that we use, however it has now been fixed.

On the other side, yes "Kubuntu Mobile" is not showed in kubuntu since we don't support mobile ISO's just yet. I'll fix this son.

Thank you for your report again :)

Changed in testdrive (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Andres Rodriguez (andreserl) wrote :

btw.. this will be fixed in the next upstream release.

Changed in testdrive (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Ian Lawrence (ianlawrence) wrote :

It will be fixed in the next upstream release of Kubuntu Mobile? We build daily if that is what you mean

Revision history for this message
Andres Rodriguez (andreserl) wrote :

Ian,

What I meant is that it will be fixed in the next TestDrive Upstream Release. In fact, it is currently fixed but in testdrive's trunk.

However, the reason why it Ubuntu Mobile "linked" to Kubuntu Mobile is because [1] was doing so, but now it is fixed given that I pointed that out to cjwatson. On the other hand, TestDrive will only display ISO's available in [1]. (In case you are currently using cdimage off course)

[1]: http://cdimage.ubuntu.com/.manifest-daily

Revision history for this message
Ian Lawrence (ianlawrence) wrote :

Hey Andres,

Yes we are using cdimage:
kubuntu-mobile maverick /kubuntu-mobile/daily-live/current/maverick-mobile-i386.iso 701143040
Having kubuntu mobile in TestDrive will be awesome so thanks for your hard work on this

Revision history for this message
Andres Rodriguez (andreserl) wrote :

Ian,

I will release the new upstream version really soon and upload to PPA.

Cheers

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package testdrive - 3.1-0ubuntu1

---------------
testdrive (3.1-0ubuntu1) natty; urgency=low

  * UI Improvements. Thanks to Andrew (and471).
  * testdrive-cli: Add support to change ISO image repository.
  * Support for UEC Images: (LP: #619974)
    - testdrive-cli: Added initial support.
  * Improve the way the downloading widget is displayed. (LP: #618166)
  * testdrive-gtk: Fix preferences dialog issue. (LP: #630364)
  * testdrive/testdrive.py: Fix loading of CACHE_ISO if changed.
  * Allow Mobile ISO's to be TestDrived. (LP: #645052)
  * Fix some identation issues that appeared with new quickly version, and
    some minor cleanups.
 -- Andres Rodriguez <email address hidden> Wed, 20 Oct 2010 16:41:15 -0400

Changed in testdrive (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers