testdrive assumes that virtualbox will support a 64 bit guest.

Bug #497984 reported by Neil Wallace on 2009-12-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TestDrive
Medium
Dustin Kirkland 
testdrive (Ubuntu)
Medium
Unassigned

Bug Description

very impressed with testdrive, the installation was flawless, it new my machine couldn't support KVM, so installed a testdrive machine in virtualbox, using the iso for the 64bit version of lucid.

The machine boots, but complains about i386 architecture.

Trouble is, my machine is one of those which doesn't support vt-x (no bios option to switch it on either).

I need to delete all iso's, vdi's and conf files and start again??

Paul Rudkin (paulgit) wrote :

I had this issue also, the script currently assumes that if you are running on a 64bit host your are able to run 64bit guests with vt-x support. As a temporary work around I modified the select ISO script to present the i386 options if your are running on a 64bit host, this will allow you to download and run i386 images (I have attached it to this bug for now)

I am working on a better solution that will automatically detect if your processor has vt-x support and if it does only provide you with the 64bit options. Hopefully I will get that sorted over the weekend.

Changed in testdrive:
status: New → Confirmed
assignee: nobody → Paul Rudkin (rudders)
Neil Wallace (rowinggolfer) wrote :

Paul, many thanks.

Dustin Kirkland  (kirkland) wrote :

Hi Paul-

I'll be happy to take a patch that solves this.

Can you (or someone) paste /proc/cpuinfo on a system affected by this vt-x problem?

Thanks!

Changed in testdrive:
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in testdrive:
status: Triaged → In Progress
importance: Medium → High
assignee: Paul Rudkin (rudders) → Dustin Kirkland (kirkland)
Changed in testdrive (Ubuntu):
status: New → Fix Committed
assignee: nobody → Dustin Kirkland (kirkland)
importance: Undecided → High
Changed in testdrive:
importance: High → Medium
Changed in testdrive (Ubuntu):
importance: High → Medium
Changed in testdrive:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package testdrive - 1.16-0ubuntu1

---------------
testdrive (1.16-0ubuntu1) lucid; urgency=low

  * testdrive, testdrive-select-iso: separate the img and iso in the
    cache directory
  * doc/testdrive.1, testdrive: respect xdg, LP: #501766
  * debian/control: depend on virtualbox >= 3.0.8 (Karmic), which currently
    seems to be the oldest successfully tested version of virtualbox to
    work with testdrive, LP: #499413
  * testdrive-select-iso: if the user doesn't have VT, then defaul to
    i386 images, LP: #497984
  * testdrive, testdrive.desktop: make sure error messages get shown to
    the user, if running from the desktop menu, LP: #497955

  [ Paul Rudkin and Dustin Kirkland ]
  * testdrive: support virtualbox 3.1, LP: #495178
 -- Dustin Kirkland <email address hidden> Sun, 13 Dec 2009 22:51:23 -0600

Changed in testdrive (Ubuntu):
status: Fix Committed → Fix Released
Paul Rudkin (paulgit) wrote :

Dustin

Below is the output of /proc/cpuinfo from my system. I think the solution would be to search /proc/cpuinfo for 'vmx' or 'svm' and if these flags are present then go with KVM with VTx support.

Would you like me to go ahead and create a patch for this?

Paul

---------

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 Duo CPU T5450 @ 1.66GHz
stepping : 13
cpu MHz : 1000.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall lm constant_tsc arch_perfmon pebs bts rep_good pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 3324.71
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 Duo CPU T5450 @ 1.66GHz
stepping : 13
cpu MHz : 1000.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 3325.01
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Changed in testdrive:
status: Fix Committed → Fix Released
Neil Wallace (rowinggolfer) wrote :

fixed for me with the latest version - many thanks.

O. Emmerson (oemmerson) wrote :

I tried to test a 64bit image today (I am running 64bit Karmic) and got caught out with this problem.
I go the message about kvm not being supported and installed virtualbox. The 64bit Desktop image was no.1 in the list of options and since I am running it I thought it would be fine. But when virtualbox boots the image I get a warning about VT-x/AMD-V being enabled but not operational and then a message saying it's only detected a i686 cpu and is unable to boot.

I have attached the output from /proc/cpuinfo

Okay, I don't really use VirtualBox...

Can someone please definitively tell me under precisely what
circumstances VirtualBox can boot a 64-bit Ubuntu guest?

Changed in testdrive (Ubuntu):
status: Fix Released → Incomplete
tags: added: patch
tags: added: patch-forwarded-upstream
removed: patch
Changed in testdrive (Ubuntu):
assignee: Dustin Kirkland (kirkland) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments