"global name 'gobject' is not defined" error on TestDrive just installed on fresh Raring

Bug #1162027 reported by Carla Sella
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
testdrive (Ubuntu)
Fix Released
Critical
Andres Rodriguez

Bug Description

When you install Testdrive on a new Raring installation (I tried both on a PC with Raring installed just a few days ago and on a notebook with Raring installed yesterday) testdrive does not start.
If you launch testdrive-gtk from terminal you get:

letozaf@letozaf-HP-G62-Notebook-PC:~$ testdrive-gtk
Traceback (most recent call last):
  File "/usr/bin/testdrive-gtk", line 1000, in <module>
    window = TestdrivegtkWindow()
  File "/usr/bin/testdrive-gtk", line 113, in __new__
    new_object.finish_initializing(builder)
  File "/usr/bin/testdrive-gtk", line 165, in finish_initializing
    self.application_indicator_menu()
  File "/usr/bin/testdrive-gtk", line 191, in application_indicator_menu
    gobject.timeout_add_seconds(self.timea, self.on_check_qa_releases_available, self.timea)
NameError: global name 'gobject' is not defined

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: testdrive-gtk 3.17-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
Uname: Linux 3.8.0-15-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Fri Mar 29 21:34:11 2013
InstallationDate: Installed on 2013-03-28 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130328)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: testdrive
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Carla Sella (carla-sella) wrote :
Revision history for this message
Carla Sella (carla-sella) wrote :

I tried installing it via apt-get install testdrive-gtk and also pressing super key, going to the Application lense, searching for testdrive and clicking on testdrive and selectin install.

Revision history for this message
Carla Sella (carla-sella) wrote :
Revision history for this message
Carla Sella (carla-sella) wrote :
summary: "global name 'gobject' is not defined" error on TestDrive just
- installed on new Raring
+ installed on fresh Raring
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in testdrive (Ubuntu):
status: New → Confirmed
Revision history for this message
Carla Sella (carla-sella) wrote :

I reproduced the bug on a Virtualbox VM.
I installed Raring Desktop AMD 64 (this ISO: http://cdimage.ubuntu.com/daily-live/20130328/raring-desktop-amd64.iso), rebooted the VM.
Installed Testdrive pressing super key to open the Dash, went to the Appications lense, searched for testdrive, clicked on it and selected to install.
After Testdrive was installed, I clicked on it's icon on the launcher but Testdrive did not open.
So I opened Terminal typed in tesdrive-gtk and got the error:

letozaf@letozaf-VirtualBox:~$ testdrive-gtk
Traceback (most recent call last):
  File "/usr/bin/testdrive-gtk", line 1000, in <module>
    window = TestdrivegtkWindow()
  File "/usr/bin/testdrive-gtk", line 113, in __new__
    new_object.finish_initializing(builder)
  File "/usr/bin/testdrive-gtk", line 165, in finish_initializing
    self.application_indicator_menu()
  File "/usr/bin/testdrive-gtk", line 191, in application_indicator_menu
    gobject.timeout_add_seconds(self.timea, self.on_check_qa_releases_available, self.timea)
NameError: global name 'gobject' is not defined
letozaf@letozaf-VirtualBox:~$

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1162027

tags: added: iso-testing
Revision history for this message
BenginM (sary) wrote :

Salutations! , i was just about to report the same bug .. glad that you bet me to it! :)

sary@n1x:~$ lsb_release -ad; uname -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04
Codename: raring
Linux n1x 3.8.0-16-generic #26-Ubuntu SMP Mon Apr 1 19:52:57 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
sary@n1x:~$

sary@n1x:~$ testdrive-gtk
Traceback (most recent call last):
  File "/usr/bin/testdrive-gtk", line 1000, in <module>
    window = TestdrivegtkWindow()
  File "/usr/bin/testdrive-gtk", line 113, in __new__
    new_object.finish_initializing(builder)
  File "/usr/bin/testdrive-gtk", line 165, in finish_initializing
    self.application_indicator_menu()
  File "/usr/bin/testdrive-gtk", line 191, in application_indicator_menu
    gobject.timeout_add_seconds(self.timea, self.on_check_qa_releases_available, self.timea)
NameError: global name 'gobject' is not defined
sary@n1x:~$

# So I guess there wont be a QA iso testing for me, it would've been my first! .. cheah!

Revision history for this message
Jackson Doak (noskcaj) wrote :

this bug doesn't occur in cli version. the cli version is crippled however.

Changed in testdrive (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Andres Rodriguez (andreserl)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package testdrive - 3.20-0ubuntu1

---------------
testdrive (3.20-0ubuntu1) raring; urgency=low

  * bin/testdrive-gtk: Do not import 'indicate' module, which will
    cause testdrive-gtk to crash on fresh installs (LP: #1162027)
 -- Andres Rodriguez <email address hidden> Tue, 16 Apr 2013 10:01:40 -0700

Changed in testdrive (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers