package libtesseract4 (not installed) failed to install/upgrade: Versuch, »/usr/lib/libtesseract.so.3.0.4« zu überschreiben, welches auch in Paket libtesseract3v5 3.04.00-5ubuntu1 ist

Bug #1548481 reported by starkus on 2016-02-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tesseract (Ubuntu)
Medium
Unassigned

Bug Description

Vormals nicht ausgewähltes Paket libtesseract4 wird gewählt.
Vorbereitung zum Entpacken von .../libtesseract4_3.04.01-2_amd64.deb ...
Entpacken von libtesseract4 (3.04.01-2) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libtesseract4_3.04.01-2_amd64.deb (--unpack):
 Versuch, »/usr/lib/libtesseract.so.3.0.4« zu überschreiben, welches auch in Paket libtesseract3v5 3.04.00-5ubuntu1 ist
dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Vorbereitung zum Entpacken von .../gimagereader_3.1.2+git368fa8f-1build1_amd64.deb ...
Entpacken von gimagereader (3.1.2+git368fa8f-1build1) über (3.1.2+git368fa8f-1) ...

...

Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libtesseract4_3.04.01-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

...

sudo apt-get update && sudo dpkg --configure -a && sudo apt-get dist-upgrade && sudo apt-get upgrade && sudo apt-get install -f && sudo apt-get autoremove && sudo apt-get clean && sudo apt-get autoclean

worked well... but

...

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gimagereader:
 gimagereader hängt ab von libtesseract4; aber:
  Paket libtesseract4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes gimagereader (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert

...

sudo apt-get purge gimagereader
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libgtksourceviewmm-3.0-0v5 libgtkspellmm-3.0-0v5 liblept4 liblept5
  libopenjp2-7 libtesseract3v5
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  gimagereader*
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 1.000 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 253431 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von gimagereader (3.1.2+git368fa8f-1build1) ...
Trigger für libglib2.0-0:amd64 (2.47.5-1) werden verarbeitet ...
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.15-0ubuntu1) werden verarbeitet ...
Trigger für gnome-menus (3.13.3-6ubuntu3) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu3) werden verarbeitet ...

Everthing okay for that configuration.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libtesseract4 (not installed)
ProcVersionSignature: Ubuntu 4.4.0-6.21-generic 4.4.1
Uname: Linux 4.4.0-6-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
Date: Mon Feb 22 19:58:01 2016
ErrorMessage: Versuch, »/usr/lib/libtesseract.so.3.0.4« zu überschreiben, welches auch in Paket libtesseract3v5 3.04.00-5ubuntu1 ist
InstallationDate: Installed on 2015-09-20 (155 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Release amd64 (20150422)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.2.3
SourcePackage: tesseract
Title: package libtesseract4 (not installed) failed to install/upgrade: Versuch, »/usr/lib/libtesseract.so.3.0.4« zu überschreiben, welches auch in Paket libtesseract3v5 3.04.00-5ubuntu1 ist
UpgradeStatus: Upgraded to xenial on 2016-01-22 (30 days ago)

starkus (starkus) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tesseract (Ubuntu):
status: New → Confirmed
starkus (starkus) wrote :

after purging gimagereader and using the autoremove feature from apt, I could install gimagereader again. The autoremoved packages got installed again and there were no unsolved dependencies...

Changed in tesseract (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers