Ubuntu

terminator crashed with SIGSEGV in PyEval_EvalFrameEx()

Reported by Terry on 2012-03-09
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Terminator
Undecided
Unassigned
terminator (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned
Raring
High
Unassigned

Bug Description

[Impact]
Segfaults the application when repositioning windows, taking any unsaved content with it. :-)

[Test Case]
Drag a window to a new horizontal position within another window. Only seems to work with at least 4 windows (2x2). Reproducible every time if dragged to top position of a window and to bottom position of same window without releasing it. Or just dragging a window around randomly :)

[Regression Potential]
Probably none. The patch only affects dragging functionality, so might affect behavior there, but even in such a case eliminating the crash would be worth it!

[Original Report]
$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

$ apt-cache policy terminator
terminator:
  Installed: 0.96-0ubuntu1
  Candidate: 0.96-0ubuntu1
  Version table:
 *** 0.96-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: terminator 0.96-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu1
Architecture: amd64
Date: Fri Mar 9 23:30:49 2012
Disassembly: => 0x0: Cannot access memory at address 0x0
EcryptfsInUse: Yes
ExecutablePath: /usr/share/terminator/terminator
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/terminator
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: terminator
StacktraceTop:
 ?? ()
 PyEval_EvalFrameEx ()
 PyEval_EvalCodeEx ()
 ?? ()
 PyObject_Call ()
Title: terminator crashed with SIGSEGV in PyEval_EvalFrameEx()
UpgradeStatus: Upgraded to precise on 2012-01-08 (61 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Terry (terry-kryogenic) wrote :

StacktraceTop:
 ?? ()
 PyEval_EvalFrameEx ()
 PyEval_EvalCodeEx ()
 function_call ()
 PyObject_Call ()

Changed in terminator (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in terminator (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2012-04-28
visibility: private → public
Bryce Harrington (bryce) wrote :

Got a similar crash just now. Also was repositioning windows, it locked up and crashed. Stacktrace is slightly different but same general theme.

Segfault happened at: 0x1: Cannot access memory at address 0x1
PC (0x00000001) not located in a known VMA region (needed executable
 region)!

Changed in terminator (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Terry (terry-kryogenic) wrote :

I didn't think that Python being a high level language should segfault caused by a bug in a Python script? Especially where something as low level as VMA is concerned. If this isn't the case then I would love to know. Just a thought anyway.

Chris Jones (cmsj) wrote :

I believe I have fixed the terminal dragging crasher in trunk.

Changed in terminator:
status: New → Fix Committed
Vincent Fortier (th0ma7) wrote :

Great! Will the fix be backported to LTS ? thnx btw!

Chris Jones (cmsj) on 2013-04-30
Changed in terminator:
status: Fix Committed → Fix Released
Bryce Harrington (bryce) wrote :

The crash is not present in saucy's terminator. I performed a bisection search to isolate r1357 as the fix. I can fairly easily crash r1356, but could not repro the crash in r1357 or newer.

r1357 indicates it is a fix for upstream bug #1089190, which seems to describe this same problem.

Changed in terminator (Ubuntu):
status: Triaged → Fix Released
Changed in terminator (Ubuntu Precise):
status: New → In Progress
Changed in terminator (Ubuntu Quantal):
status: New → In Progress
Changed in terminator (Ubuntu Raring):
status: New → In Progress
Changed in terminator (Ubuntu Quantal):
importance: Undecided → High
Changed in terminator (Ubuntu Raring):
importance: Undecided → High
Changed in terminator (Ubuntu Precise):
importance: Undecided → High
Bryce Harrington (bryce) on 2013-09-12
description: updated
Bryce Harrington (bryce) wrote :

Uploaded patch to precise, quantal, and raring.

Changed in terminator (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in terminator (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in terminator (Ubuntu Raring):
status: In Progress → Fix Committed

Hello Terry, or anyone else affected,

Accepted terminator into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/terminator/0.96-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Terry, or anyone else affected,

Accepted terminator into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/terminator/0.96-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Terry, or anyone else affected,

Accepted terminator into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/terminator/0.96-0ubuntu1.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Simon Déziel (sdeziel) on 2013-09-23
tags: added: verification-done-precise
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package terminator - 0.96-0ubuntu1.0.1

---------------
terminator (0.96-0ubuntu1.0.1) precise-proposed; urgency=low

  * Add drag_crash.patch: Cherrypicked patch (rev 1357), "Extra guarding
    against crashy gtk functions", to fix crash when dragging a terminal
    window to a new horizontal position within another window.
    (LP: #951236)
 -- Bryce Harrington <email address hidden> Wed, 11 Sep 2013 18:42:37 -0700

Changed in terminator (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers