Ringtone cannot be heard when jack/headphones plugged

Bug #1483888 reported by Stefan on 2015-08-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu UX
High
Olga Kemmet
telephony-service (Ubuntu)
High
Tiago Salem Herrmann

Bug Description

Aquaris E5: Ringtone cannot be heard when jack/headphones are plugged.

This I consider a bug, since user cannot depend on the such a device with hearing calls in the morning.

Typical scenario: listening to music/watching movies during the night and falling asleep. It already happened several times to me that I did not get awakened by the phone in the morning, since headphones were plugged into the device and all the sounds could be heard only in headphones.

(The equivalent for the alarm clock is bug 1364647.)

Related branches

affects: indicator-power (Ubuntu) → pulseaudio (Ubuntu)
Matthew Paul Thomas (mpt) wrote :

This is a design question for the Phone app, not for pulseaudio. The Phone app might choose to, for example, play the ringtone just through headphones for the first two or three seconds, to give you a chance to answer the call without waking up people nearby; and then switch to playing through speaker, in case your headphones aren't in your ears. I'm not saying it should necessarily do that, that's just one possibility.

Unfortunately, the Phone app spec currently doesn't even mention ringing. <https://goo.gl/0hy3A1> The design for ringing should also describe what should happen if other audio is playing when the call arrives.

affects: pulseaudio (Ubuntu) → dialer-app (Ubuntu)
description: updated
summary: - Aquaris E5: Ringtone + buzzer cannot be heard when jack/headphones
- plugged
+ Aquaris E5: Ringtone cannot be heard when jack/headphones plugged

the dialer app is an application, it's not open all the time nor handling the ringing, reassigning to telephony-service instead

affects: dialer-app (Ubuntu) → telephony-service (Ubuntu)
Changed in telephony-service (Ubuntu):
importance: Undecided → High
summary: - Aquaris E5: Ringtone cannot be heard when jack/headphones plugged
+ Ringtone cannot be heard when jack/headphones plugged
Sebastien Bacher (seb128) wrote :

bug #1364647 is about the alarm issue

Changed in telephony-service (Ubuntu):
assignee: nobody → Olga Kemmet (olga-kemmet)
Sebastien Bacher (seb128) wrote :

that seems like an important issue, can we get that on the ota7 list?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telephony-service (Ubuntu):
status: New → Confirmed
Changed in telephony-service (Ubuntu):
assignee: Olga Kemmet (olga-kemmet) → nobody
Pat McGowan (pat-mcgowan) wrote :

Other phones seem to always ring through speakers unless silent mode is on

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → ww46-2015
status: New → Confirmed

not just Aquarius E5 is affected by this bug - also affects my Meizu MX5, and still not working following latest update

On 21 Oct 2015, at 19:20, Pat McGowan wrote:

> Other phones seem to always ring through speakers unless silent mode is
> on
>
> ** Changed in: canonical-devices-system-image
> Importance: Undecided => High
>
> ** Changed in: canonical-devices-system-image
> Status: New => Confirmed
>
> ** Changed in: canonical-devices-system-image
> Milestone: None => ww46-2015
>
> ** Changed in: canonical-devices-system-image
> Assignee: (unassigned) => Bill Filler (bfiller)
>
> ** Also affects: ubuntu-ux
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1479395).
> https://bugs.launchpad.net/bugs/1483888
>
> Title:
> Ringtone cannot be heard when jack/headphones plugged
>
> Status in Canonical System Image:
> Confirmed
> Status in Ubuntu UX:
> New
> Status in telephony-service package in Ubuntu:
> Confirmed
>
> Bug description:
> Aquaris E5: Ringtone cannot be heard when jack/headphones are plugged.
>
> This I consider a bug, since user cannot depend on the such a device
> with hearing calls in the morning.
>
> Typical scenario: listening to music/watching movies during the night
> and falling asleep. It already happened several times to me that I did
> not get awakened by the phone in the morning, since headphones were
> plugged into the device and all the sounds could be heard only in
> headphones.
>
> (The equivalent for the alarm clock is bug 1364647.)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1483888/+subscriptions

Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Olga Kemmet (olga-kemmet)
Bill Filler (bfiller) on 2015-10-30
Changed in telephony-service (Ubuntu):
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Bill Filler (bfiller) wrote :

+1 on what pat said
we should ring through both headphones and speaker, unless silent mode is on then just through headphones

Bill Filler (bfiller) on 2015-11-03
Changed in telephony-service (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in telephony-service (Ubuntu):
status: In Progress → Fix Released
Stefan (boldos) wrote :

This has been fixed a long time ago.
Thank you :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers