Calling from car using bluetooth, call is placed on ril_0, even though ril_1 is default

Bug #1418040 reported by Jonas G. Drange on 2015-02-04
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
John McAleely
bluez (Ubuntu)
Critical
Unassigned
ofono (Ubuntu)
Critical
Alfonso Sanchez-Beato
telephony-service (Ubuntu)
Critical
Tiago Salem Herrmann
ubuntu-system-settings (Ubuntu)
Critical
Ken VanDine

Bug Description

What happened
Placed call from car over bluetooth
Call was placed on my first SIM card, even though I selected my second SIM as default for calls

What should have happened
The call should have been placed on my second SIM

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: telephony-service 0.1+15.04.20150124-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.15.1-0ubuntu4
Architecture: armhf
Date: Wed Feb 4 14:25:44 2015
InstallationDate: Installed on 2015-02-02 (2 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20150202-020204)
SourcePackage: telephony-service
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jonas G. Drange (jonas-drange) wrote :
description: updated
Bill Filler (bfiller) on 2015-02-05
Changed in telephony-service (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Tiago Salem Herrmann (tiagosh)
tags: added: ww07
no longer affects: telephony-service
Gustavo Pichorim Boiko (boiko) wrote :

I guess the problem here is that telephony-service is not involved in the process of placing the call: that's all done at the ofono level.
When telepathy-ofono (and thus telephony-service) get notified about the call, it is already placed in the wrong modem.

I don't know how this is handle inside ofono, but maybe there is a way for us to set a property saying which of the modems should be used when placing calls via HFP?

Changed in telephony-service (Ubuntu):
assignee: Tiago Salem Herrmann (tiagosh) → Gustavo Pichorim Boiko (boiko)
Changed in telephony-service (Ubuntu RTM):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ofono (Ubuntu):
status: New → Confirmed
Changed in telephony-service (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: none → ww34-2015
assignee: nobody → John McAleely (john.mcaleely)
importance: Undecided → Critical
status: New → Confirmed
Bill Filler (bfiller) on 2015-07-24
Changed in ofono (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Changed in telephony-service (Ubuntu RTM):
status: New → Confirmed
Changed in ofono (Ubuntu):
importance: Undecided → Critical
Changed in telephony-service (Ubuntu RTM):
importance: Undecided → Critical

Actually, the call is started by a "Dial" DBus call to an ofono modem started from bluetoothd. Currently we are not using ofono's HFP implementation, but the BlueZ one. This will change when we move from BlueZ 4 to BlueZ 5. But for the moment the one which chooses the modem to use is BlueZ.

Changed in bluez (Ubuntu):
status: New → Confirmed

Some research shows that audio/telephony-ofono.c in BlueZ 4 source tree only accounts for one modem in the system. Currently there is no way to specify a preferred modem.

John McAleely (john.mcaleely) wrote :

I agree, lets fix this when we move to bluez5, so I propose to defer this bug until then.

Changed in canonical-devices-system-image:
milestone: ww34-2015 → none

As a matter of fact I will also add that the slot chosen to start a call is kind of random and can change after a reboot. It would be possible to fix it in the code as a quick work around to have as a minimum a deterministic behaviour.

Changed in bluez (Ubuntu):
importance: Undecided → Critical
Changed in telephony-service (Ubuntu RTM):
status: Confirmed → Triaged
Changed in telephony-service (Ubuntu):
status: Confirmed → Triaged
Changed in ofono (Ubuntu):
status: Confirmed → Triaged
Changed in bluez (Ubuntu):
status: Confirmed → Triaged
Simon Fels (morphis) on 2015-09-08
tags: added: after-bluez5 bluetooth
Changed in canonical-devices-system-image:
milestone: none → backlog
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Simon Fels (morphis) on 2015-11-24
Changed in bluez (Ubuntu):
status: Triaged → Invalid
Uranicus (matthias.ritter) wrote :

Knowing that this bug is in progress, I want to share an interesting finding (at least for me).

I am on rc-proposed (with bluez5, see details below). When SIM 1 is (randomly picked) used, the battery status is shown in the car display. When SIM 2 is used, the battery status shows 100% loading.

system-image-cli -i:

current build number: 196
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-12-05 18:28:01
version version: 196
version ubuntu: 20151204.1
version device: 20151028-869191d
version custom: 20151111–36-46-vivid

Tony Espy (awe) wrote :

@Uranicus

Thanks for the heads-up re: battery status. The plugin that handles battery status currently doesn't properly handle dual-SIM. It's on our list to resolve before OTA9 is released.

Dirk-Jan van Leeuwen (dj-h) wrote :

Today I found out that outgoing calls on the bluetooth enabled Toyota Touch&Go system went out through sim2, although I have selected sim1 as the default for outgoing calls.

$ system-image-cli --info
current build number: 29
device name: krillin
channel: ubuntu-touch/stable/bq-aquaris.en
last update: 2016-01-27 21:18:09
version version: 29
version ubuntu: 20160123.1
version tag: OTA-9
version device: 20160108-efc96d8
version custom: 20160111-926-36--vivid

Bill Filler (bfiller) wrote :

We need to get to the bottom of this one guys. What is the latest status? Users are still reporting the issue even though we've moved to Bluez5, so there is a still an issue.

Changed in canonical-devices-system-image:
milestone: backlog → ww08-2016
Changed in telephony-service (Ubuntu):
assignee: Gustavo Pichorim Boiko (boiko) → Tiago Salem Herrmann (tiagosh)
no longer affects: telephony-service (Ubuntu RTM)
Tiago Salem Herrmann (tiagosh) wrote :

Yes, this is still an issue. We agreed with Alfonso that ofono will use AccountsService to get the default sim card for calls.
It needs some work on telephony-service and system-settings.

Robie Basak (racb) wrote :

If this will take a while, then would it be possible to have ofono default to a deterministic SIM for outbound calls as an interim workaround? Eg. sort them by some key and take the lowest one, or use the lowest numbered port or something. Then I could swap the SIM cards around (if needed) to get the behaviour I need without having to wait for a full solution.

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Critical
Changed in ofono (Ubuntu):
status: Triaged → Fix Released
Changed in canonical-devices-system-image:
milestone: ww08-2016 → 11
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in telephony-service (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.10.20160523-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.10.20160523-0ubuntu1) yakkety; urgency=medium

  * Catch connection errors asynchronously

 -- Ken VanDine <email address hidden> Mon, 23 May 2016 12:27:38 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers