silent mode doesn't silence keyboard or dialpad

Bug #1384274 reported by Selene ToyKeeper on 2014-10-22
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Pat McGowan
telephony-service (Ubuntu)
High
Sebastien Bacher
Vivid
High
Unassigned

Bug Description

As of krillin rtm image 120, silent mode works to silence the phone and SMS ringers, but does not affect anything else. To meet expectations of users from other platforms, it should also silence the keyboard and dialpad sounds, and probably the three beeps which trigger when the other end of a call hangs up.

As for music, videos, and alarms, almost all platforms still play audio for those regardless of the silent mode setting. (one exception is the Palm Treo, which used a physical kill switch for sound and thus silenced *everything*)

Related branches

Sebastien Bacher (seb128) wrote :

that's not an issue with settings, as you said the option works for things that respect it like the phone and sms, that's an issue with the osk and the dialer

affects: ubuntu-system-settings (Ubuntu) → dialer-app
Selene ToyKeeper (toykeeper) wrote :

Thanks, I'm a little sleep-deprived this morning and got the wrong project. :)

Selene ToyKeeper (toykeeper) wrote :

Something else which doesn't get silenced is the three beeps which get triggered when the other end of a call hangs up.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dialer-app (Ubuntu):
status: New → Confirmed
affects: dialer-app → dialer-app (Ubuntu)
Changed in telephony-service (Ubuntu):
status: New → Confirmed
affects: dialer-app (Ubuntu) → telephony-service (Ubuntu)
Changed in telephony-service (Ubuntu):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Sebastien Bacher (seb128)
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
milestone: none → ww28-2015
status: New → In Progress
Changed in telephony-service (Ubuntu Vivid):
status: New → Fix Committed
importance: Undecided → High
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telephony-service - 0.1+15.10.20150709-0ubuntu1

---------------
telephony-service (0.1+15.10.20150709-0ubuntu1) wily; urgency=medium

  [ Gustavo Pichorim Boiko ]
  * Sync the fixes that were released in OTA5: (LP: #1384274, #1433068,
    #1412709, #1427286, #1453004)

 -- CI Train Bot <email address hidden> Thu, 09 Jul 2015 13:46:05 +0000

Changed in telephony-service (Ubuntu):
status: In Progress → Fix Released

This bug still affects the keyboard in OTA-8 with vegeta and also with my krillin in RC-204. If "keyboard sound" is enabled in sound options it doesn't matter if volume is up or down or if silent mode is on.

Jean-Baptiste Lallement (jibel) wrote :

@Victor, thanks. The dialler is silent in silent mode but I confirm that the keyboard isn't if keyboard sound is on. This is reported in bug 1382860

no longer affects: ubuntu-keyboard
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers