No sound notification for Call/SMS

Bug #1234087 reported by Omer Akram on 2013-10-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
telephony-service
Fix Released
Critical
Tiago Salem Herrmann
telephony-service (Ubuntu)
Critical
Unassigned
Saucy
Critical
Unassigned

Bug Description

using today's image (75) I see no sound notification when I receive a call/sms

1. flash the latest image
2. call your phone from another phone

What happens:
The screen lightens up and the OSD for call appears and I can pickup the call but there is no ringtone ringing.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: telephony-service 0.1+13.10.20130926.1-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.5-0ubuntu1
Architecture: armhf
Date: Wed Oct 2 15:42:12 2013
InstallationDate: Installed on 2013-10-01 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20131001.3)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: telephony-service
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Omer Akram (om26er) wrote :
Changed in telephony-service:
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telephony-service (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2013-10-02
Changed in telephony-service:
status: New → Confirmed
Omer Akram (om26er) on 2013-10-02
Changed in telephony-service:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Tiago Salem Herrmann (tiagosh) wrote :

I see these messages coming from telephony-service-approver:

defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"
defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"
QMediaPlaylistNavigator: Jump outside playlist range
QObject::moveToThread: Cannot move objects with a parent

Sergio Schvezov (sergiusens) wrote :

QMediaPlaylistNavigator: Jump outside playlist range

this seems to happen even on the image without the overriden/diverted qtmultimedia

Sergio Schvezov (sergiusens) wrote :

Here's the problem: http://paste.ubuntu.com/6185964/

summary:
loaded library "/usr/lib/arm-linux-gnueabihf/qt5/plugins/mediaservice/libgstmediaplayer.so"
QLibraryPrivate::loadPlugin failed on "/usr/lib/arm-linux-gnueabihf/qt5/plugins/mediaservice/libgstmediaplayer.so" : "Cannot load library /usr/lib/arm-linux-gnueabihf/qt5/plugins/mediaservice/libgstmediaplayer.so: (/usr/lib/arm-linux-gnueabihf/libqgsttools_p.so.1: undefined symbol: _ZTI12QQuickWindow)"
defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"

Didier Roche (didrocks) wrote :

Fixed in image 78

Changed in telephony-service (Ubuntu Saucy):
status: Confirmed → Fix Released
Changed in telephony-service:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers