telepathy-stream-engine crashed with signal 5 in g_return_if_fail_warning()

Bug #322368 reported by shockawe5 on 2009-01-28
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
stream-engine
Won't Fix
Critical
telepathy-stream-engine (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: telepathy-stream-engine

Using Ubuntu 9.04 alpha 3

Tried calling someone using Empathy and Google Talk. I expected to be able to have a voice and video chat with other participant (who is using the Google Talk on Windows with the Gmail interface). What actually happened was that telepathy-stream-engine reported that it had crashed and the call did not go through.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/telepathy/telepathy-stream-engine
Package: telepathy-stream-engine 0.5.3-1
ProcCmdline: /usr/lib/telepathy/telepathy-stream-engine
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Signal: 5
SourcePackage: telepathy-stream-engine
StacktraceTop:
 g_return_if_fail_warning () from /usr/lib/libglib-2.0.so.0
 g_object_ref () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/farsight-0.1-3/librtp-session.so
 g_object_get_valist () from /usr/lib/libgobject-2.0.so.0
 g_object_get () from /usr/lib/libgobject-2.0.so.0
Title: telepathy-stream-engine crashed with signal 5 in g_return_if_fail_warning()
Uname: Linux 2.6.28-5-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

shockawe5 (shockawe5) wrote :

StacktraceTop:IA__g_return_if_fail_warning (
IA__g_object_ref (_object=0x0)
farsight_rtp_stream_get_property (object=0xa0a6860,
IA__g_object_get_valist (object=0xa0a6860,
IA__g_object_get (_object=0xa0a6860,

Changed in telepathy-stream-engine:
importance: Undecided → Medium

There are two separate bug reports with different backtraces filed for Ubuntu Jaunty (development) on Launchpad, both of which start their crash at
stream-engine-main.c:335
One was on i686, other was on x86_64

https://launchpad.net/bugs/322368
Backtrace: http://launchpadlibrarian.net/21723726/ThreadStacktrace.txt
"Tried calling someone using Empathy and Google Talk. I expected to be able to have a voice and video chat with other participant (who is using the Google Talk on Windows with the Gmail interface). What actually happened was that telepathy-stream-engine reported that it had crashed and the call did not go through."

https://launchpad.net/bugs/325903
Backtrace: http://launchpadlibrarian.net/22022825/ThreadStacktrace.txt
"Trying to start a voice/video conversation with someone."

Because of the multiple crashes I set High priority on this bug, please forgive me if I was wrong to do so. I have linked to the backtraces, but if you need them attached here, just let me know. If further information is required on either bug report, please post on the Launchpad report if possible so that the original reporter(s) can see your questions/responses. Thank you.

Connor Imes (ckimes) wrote :

Thank you for reporting this. I have marked bug 325903 as a duplicate and passed these traces upstream to the developers. You can read their comments at http://bugs.freedesktop.org/show_bug.cgi?id=19977

Changed in telepathy-stream-engine:
status: New → Triaged
Changed in stream-engine:
status: Unknown → Confirmed

This bug: https://bugs.launchpad.net/ubuntu/+source/telepathy-stream-engine/+bug/333032
got telepathy-stream-engine crashed with signal 5 in g_object_ref()
Both that guy and me on AMD64. Is it the same?

Stream-engine is no longer used in empathy 2.26.

Changed in stream-engine:
status: Confirmed → Won't Fix
Connor Imes (ckimes) wrote :

This bug was closed upstream as WONTFIX stating "Stream-engine is no longer used in empathy 2.26."
I will close the bug here as well.

Changed in telepathy-stream-engine:
status: Triaged → Won't Fix
Changed in stream-engine:
importance: Unknown → Critical
Changed in stream-engine:
importance: Critical → Unknown
Changed in stream-engine:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.