Can't place or recive SIP calls

Bug #446708 reported by Jeremy Nickurak on 2009-10-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Empathy
Unknown
Medium
telepathy-sofiasip
Won't Fix
Medium
telepathy-rakia (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

atrus@yeesha:/etc/apt/sources.list.d$ apt-cache policy empathy
empathy:
  Installed: 2.28.0.1-1ubuntu3
  Candidate: 2.28.0.1-1ubuntu3

Sending and receiving calls worked a few weeks ago.

Attempting to call out yields:

(empathy:12518): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
(empathy:12518): tp-fs-DEBUG: GetSessionHandlers replied:
(empathy:12518): tp-fs-DEBUG: - session /org/freedesktop/Telepathy/Connection/sofiasip/sip/_31789031191_40did_2evoip_2eles_2enet/MediaChannel0/MediaSession2
(empathy:12518): tp-fs-DEBUG: type rtp
(empathy:12518): tp-fs-DEBUG: adding session handler /org/freedesktop/Telepathy/Connection/sofiasip/sip/_31789031191_40did_2evoip_2eles_2enet/MediaChannel0/MediaSession2, type rtp
(empathy:12518): tp-fs-DEBUG: calling MediaSessionHandler::Ready
(empathy:12518): tp-fs-DEBUG: New stream, stream_id=0, media_type=0, direction=2
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: called (send_local:1 send_supported:0)
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 102: audio SPEEX clock:8000 channels:1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 103: audio SPEEX clock:16000 channels:1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 96: audio SIREN clock:16000 channels:0 bitrate=16000
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 0: audio PCMU clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 8: audio PCMA clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 3: audio GSM clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 99: audio telephone-event clock:16000 channels:0 events=0-15
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 100: audio telephone-event clock:8000 channels:0 events=0-15
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec SPEEX [102]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec SPEEX [103]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec SIREN [96]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec PCMU [0]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec PCMA [8]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec GSM [3]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec telephone-event [99]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec telephone-event [100]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: calling MediaStreamHandler::Ready
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) set_stream_playing: 0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) set_stream_sending: 0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_bus_message: Codecs changed
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: called (send_local:0 send_supported:0)
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 102: audio SPEEX clock:8000 channels:1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 103: audio SPEEX clock:16000 channels:1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 96: audio SIREN clock:16000 channels:0 bitrate=16000
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 0: audio PCMU clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 8: audio PCMA clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 3: audio GSM clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 99: audio telephone-event clock:16000 channels:0 events=0-15
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 100: audio telephone-event clock:8000 channels:0 events=0-15
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) cb_fs_new_local_candidate: called
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) cb_fs_new_local_candidate: called
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) cb_fs_local_candidates_prepared: called
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) cb_fs_local_candidates_prepared: candidate->ip = '142.244.160.36'
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) cb_fs_local_candidates_prepared: candidate->ip = '142.244.160.36'
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) set_stream_playing: 1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) tf_stream_request_resource: Requesting resource for direction 2
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) tf_stream_request_resource: Requesting resource for direction 2 returned 1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) close: close requested by connection manager

Created an attachment (id=29982)
sogiasip.log

Jeremy Nickurak (nickurak) wrote :
Download full text (5.3 KiB)

Binary package hint: empathy

atrus@yeesha:/etc/apt/sources.list.d$ apt-cache policy empathy
empathy:
  Installed: 2.28.0.1-1ubuntu3
  Candidate: 2.28.0.1-1ubuntu3

Sending and receiving calls worked a few weeks ago.

Attempting to call out yields:

(empathy:12518): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
(empathy:12518): tp-fs-DEBUG: GetSessionHandlers replied:
(empathy:12518): tp-fs-DEBUG: - session /org/freedesktop/Telepathy/Connection/sofiasip/sip/_31789031191_40did_2evoip_2eles_2enet/MediaChannel0/MediaSession2
(empathy:12518): tp-fs-DEBUG: type rtp
(empathy:12518): tp-fs-DEBUG: adding session handler /org/freedesktop/Telepathy/Connection/sofiasip/sip/_31789031191_40did_2evoip_2eles_2enet/MediaChannel0/MediaSession2, type rtp
(empathy:12518): tp-fs-DEBUG: calling MediaSessionHandler::Ready
(empathy:12518): tp-fs-DEBUG: New stream, stream_id=0, media_type=0, direction=2
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: called (send_local:1 send_supported:0)
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 102: audio SPEEX clock:8000 channels:1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 103: audio SPEEX clock:16000 channels:1
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 96: audio SIREN clock:16000 channels:0 bitrate=16000
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 0: audio PCMU clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 8: audio PCMA clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 3: audio GSM clock:8000 channels:0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 99: audio telephone-event clock:16000 channels:0 events=0-15
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: 100: audio telephone-event clock:8000 channels:0 events=0-15
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec SPEEX [102]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec SPEEX [103]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec SIREN [96]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec PCMU [0]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec PCMA [8]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec GSM [3]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec telephone-event [99]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) fs_codecs_to_tp: adding codec telephone-event [100]
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) _tf_stream_try_sending_codecs: calling MediaStreamHandler::Ready
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (audio) set_stream_playing: 0
(empathy:12518): tp-fs-DEBUG: stream 0 0x8a5e608 (au...

Read more...

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in empathy (Ubuntu):
importance: Undecided → Low

The proxy responds with 480 request timeout. Probably the VoIP gateway becomes terminally confused with your SDP offer. Which, among other interesting things, contains two DTMF payloads with different bitrates. I'll file a Farsight bug about this.

As a possible workaround, try to switch off the funky 16 bit codecs such as SPEEX and SIREN.

(In reply to comment #3)
> As a possible workaround, try to switch off the funky 16 bit codecs such as
> SPEEX and SIREN.

I mean the 16kbps codecs, of course.

Thanks for looking into this. I just disabled SPEEX and SIREN by editing the non-configuration file /usr/share/empathy/codec-preferences. It doesn't change anything. The codecs now appear as follows in the debug log, but everything else remains the same.

(empathy:15241): tp-fs-DEBUG: New stream, stream_id=0, media_type=0, direction=2
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) get_all_properties_cb: Adding STUN server (old API) 217.10.79.2:10000
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) _tf_stream_try_sending_codecs: called (send_local:1 send_supported:0)
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) _tf_stream_try_sending_codecs: 0: audio PCMU clock:8000 channels:0
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) _tf_stream_try_sending_codecs: 8: audio PCMA clock:8000 channels:0
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) _tf_stream_try_sending_codecs: 3: audio GSM clock:8000 channels:0
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) _tf_stream_try_sending_codecs: 99: audio telephone-event clock:8000 channels:0 events=0-15
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) fs_codecs_to_tp: adding codec PCMU [0]
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) fs_codecs_to_tp: adding codec PCMA [8]
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) fs_codecs_to_tp: adding codec GSM [3]
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) fs_codecs_to_tp: adding codec telephone-event [99]
(empathy:15241): tp-fs-DEBUG: stream 0 0x191e180 (audio) _tf_stream_try_sending_codecs: calling MediaStreamHandler::Ready

So, if this is listed as 'notourbug', whose bug is it?

Sebastien Bacher (seb128) wrote :
affects: empathy (Ubuntu) → telepathy-sofiasip (Ubuntu)
Changed in telepathy-sofiasip (Ubuntu):
status: New → Triaged
Changed in telepathy-sofiasip:
status: Unknown → Invalid

(In reply to comment #6)
> So, if this is listed as 'notourbug', whose bug is it?

The gateway's, or the proxy's, if my assumption is right.
It should ignore the payloads in SDP it does not support.

(In reply to comment #5)
> Thanks for looking into this. I just disabled SPEEX and SIREN by editing the
> non-configuration file /usr/share/empathy/codec-preferences. It doesn't change
> anything. The codecs now appear as follows in the debug log, but everything
> else remains the same.

Try also disabling the GSM codec.
It might be also the telephone-event payload (DTMF) that's causing trouble, I don't remember how to disable it.

Alright, I disabled both telephone-event and GSM, and I still can't connect. Attached are my latest logs from empathy and telepathy-sofiasip, and my codec-preferences file. This is also with the latest packages from debian unstable, i.e. empathy 2.28.1.1-1 and telepathy-sofiasip 0.5.18-1.

Created an attachment (id=30776)
New Empathy Log

Created an attachment (id=30777)
New Sofiasip Log

Created an attachment (id=30778)
coded-preferences

To get a useful log from tp-ssip, you need to set TPORT_LOG=1
Also, when you attach files, please set the right mime-type (in this case, text/plain)

Thanks for mentioning the tport debug option. Looking at these logs, I see a "407 Proxy Authentication Failed" message. I'm investigating with my sip provider to figure out what's going on.

Wouldn't it be nice if empathy would pass this error on to the user?

Changed in empathy:
importance: Unknown → Medium
Changed in telepathy-sofiasip:
importance: Unknown → Medium
status: Invalid → Won't Fix
Changed in telepathy-sofiasip:
importance: Medium → Unknown
Changed in telepathy-sofiasip:
importance: Unknown → Medium
Colin Watson (cjwatson) on 2012-10-10
affects: telepathy-sofiasip (Ubuntu) → telepathy-rakia (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.