Stop build-depending on libfarstream-0.1-dev and gstreamer 0.10

Bug #1538772 reported by Bryan Quigley on 2016-01-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
telepathy-qt (Ubuntu)
Undecided
Unassigned
telepathy-qt5 (Ubuntu)
Undecided
Unassigned

Bug Description

This is the old gst0.10 farstream, you don't want this anymore.

This is keeping the following source packages unnessarily in main (and maybe existing):
gstreamer0.10-nice

This holds the obsolete farstream source in Ubuntu, which got removed in Debian (#802204).

Bug in xenial.

tags: added: gst0.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telepathy-qt5 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

This is quite messy -- *both* the telepathy-qt and telepathy-qt5 packages haven't been updated in a while, the Ubuntu specific diversion of telepathy-qt5 is now obsolete as Debian's telepathy-qt source package builds both Qt4 and Qt5 versions, and this does not only affect the -farstream binary (which can simply be removed, no rdepends) but it uses libgstreamer0.10-dev as well.

So ideally we could just sync this, but this currently fails on

The following packages have unmet dependencies:
 sbuild-build-depends-telepathy-qt-dummy : Depends: libssl1.0.2 but it is not installable

However, this is just a minor Debian packaging quirk, and easily rectified. I put test packages into https://launchpad.net/~pitti/+archive/ubuntu/ppa, some testing would be highly appreciated!

Martin Pitt (pitti) on 2016-03-10
summary: - Stop build-depending on libfarstream-0.1-dev
+ Stop build-depending on libfarstream-0.1-dev and gstreamer 0.10
Martin Pitt (pitti) on 2016-03-10
description: updated
Bryan Quigley (bryanquigley) wrote :

I tried testing with empathy on two 16.04 machines using two Google Talk accounts.
AFAICT, empathy video/voice chats are very unreliable with or without this change. My best experience was with this change though, could hear me talking for about 30 seconds... Apparently this is a known issue possibly related to Google switching to hangouts, see Gnome bug 734082 as an example.

Going to see if Jabber/SIP work better.

Bryan Quigley (bryanquigley) wrote :

And it seems like I forgot that empathy actually doesn't use this, not being qt and all. Oops.

I tested it with a Kubuntu 16.04 LiveCD and the instant messaging app/account management page (which does depends on it) works fine with this PPA. I tested by adding a Google account, which doesn't support voice/video in either case.

Bryan Quigley (bryanquigley) wrote :

This is the last fix keeping src:gst-plugins-good0.10 in archive.

Bryan Quigley (bryanquigley) wrote :

@pitti
You mentioned on IRC that "our -qt5 package has a ton of touch patches" . I only find find-gstreamer-include-dirs.patch in the telepathy-qt5 source package. What am I missing?

Bryan Quigley (bryanquigley) wrote :

BTW, because of the archive change gstreamer0.10 packages are no longer main. :)

Martin Pitt (pitti) wrote :
Changed in telepathy-qt5 (Ubuntu):
status: Confirmed → Fix Released
Changed in telepathy-qt (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers