history-service crash calling back number from indicator

Bug #1458990 reported by Bill Filler on 2015-05-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
history-service (Ubuntu)
Undecided
Gustavo Pichorim Boiko
telepathy-ofono (Ubuntu)
Undecided
Gustavo Pichorim Boiko

Bug Description

latest arale, image 16

Steps to reproduce:
- recv a call from a known contact but don't answer it
- pull down indicator, tap the call back button
- dialer is invoked with the number
- press call button

Expected Results:
- number is called and header shows the contact name

Actual results:
- the header is blank, and don't think the call was placed (or it might have been placed and failed)

Related branches

Bill Filler (bfiller) wrote :
Bill Filler (bfiller) wrote :
Bill Filler (bfiller) wrote :
Gustavo Pichorim Boiko (boiko) wrote :

From the logs it looks like telepathy-ofono stopped responding and thus caused history-service to get an empty list of participants.

I will change the code not to crash, but still it would be nice to investigate why telepathy-ofono got stuck. My bet would be pulseaudio, but that needs investigation.

Changed in history-service (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in telepathy-ofono (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package history-service - 0.1+15.10.20150828.1-0ubuntu1

---------------
history-service (0.1+15.10.20150828.1-0ubuntu1) wily; urgency=medium

  [ Gustavo Pichorim Boiko ]
  * Do not override the build type. Also remove a block of unused code
    from debian/rules.
  * Fix flags.
  * Prevent the history-daemon from crashing in the event of an ended
    call not having any remote member. (LP: #1458990)

  [ Tiago Salem Herrmann ]
  * Correctly set mCanFetchMore in the HistoryGroupedThreadsModel.
  * Generate eventId when there is none Set status to "Accepted" if the
    channel does not support delivery reports
  * Manually add self id to participants list if needed. (LP: #1486187)

 -- CI Train Bot <email address hidden> Fri, 28 Aug 2015 10:16:13 +0000

Changed in history-service (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers