[mako] After 5-10 incoming calls ( ended remotely ), no more ring/snap decision

Bug #1226298 reported by Omer Akram on 2013-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
telepathy-ofono
Critical
Tiago Salem Herrmann
linux-mako (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
David Henningsson
Saucy
Undecided
David Henningsson
telepathy-ofono (Ubuntu)
Critical
Tiago Salem Herrmann

Bug Description

When calling to my Ubuntu Phone it seems sometimes there is no notification for the Call to accept/decline the call and at the same time there is no sound. The screen just lightens up but nothing more.

The way I found to reproduce this was was that:

keep trying to call the Ubuntu phone from another phone till you see no notification or ringtone for the Call

generally it takes me 4-5 attempts to reproduce the problem

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ofono 1.12-0ubuntu8
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.1-0ubuntu4
Architecture: armhf
Date: Mon Sep 16 21:31:27 2013
InstallationDate: Installed on 2013-09-14 (2 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130914.1)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: ofono
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Omer Akram (om26er) wrote :
summary: - No sound or notification for calls at times but the screen does lighten
- up
+ No sound or OSD notification for calls at times but the screen does
+ lighten up
affects: ofono → telephony-service
Changed in telephony-service:
importance: Undecided → Critical
description: updated
affects: ofono (Ubuntu) → telephony-service (Ubuntu)
Changed in telephony-service:
assignee: nobody → Tiago Salem Herrmann (tiagosh)

Also to note that when this problem happens there is no sound working in other apps like in system-settings ringtone selection section

Nicholas Skaggs (nskaggs) wrote :

After 5 calls, every call thereafter fails on the device.

Changed in telephony-service:
status: New → Confirmed
Changed in telephony-service (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2013-09-17
tags: added: qa-touch
Pat McGowan (pat-mcgowan) wrote :

I did this with two calls in quick succession, as soon as I hung up first call I immediately called again.

Changed in telephony-service (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Pat McGowan (pat-mcgowan) wrote :
Pat McGowan (pat-mcgowan) wrote :
Pat McGowan (pat-mcgowan) wrote :
Tony Espy (awe) wrote :

I reproduced this on my mako running this morning's build. After the fifth call the phone stopped responding.

So, I decided to monitor the ofono VoiceCallManager interface ( /usr/share/ofono/scripts/monitor-ofono ). My first try to call after starting the script worked! So it appears whatever gets jammed up, manages to un-jam itself. That said, after four or more calls it wedged again and no ringtones/notifications. I also confirmed that for ever single incoming call, a CallAdded signal gets fired, and when the remote party hangs up, the call is disconnected/removed.

Changed in telephony-service (Ubuntu Saucy):
assignee: Gustavo Pichorim Boiko (boiko) → Tiago Salem Herrmann (tiagosh)
Tony Espy (awe) wrote :

I tried to reproduce this on maguro using today's build and could not. I tried upwards of 50 incoming calls and it never failed to display the snap decision. That said, the ringtone did fail on the first call, however I think this is a separate problem.

I also re-tried today's build on mako, and can still make it fail per the above descriptions.

summary: - No sound or OSD notification for calls at times but the screen does
- lighten up
+ [mako] After 5-10 incoming calls ( ended remotely ), no more ring/snap
+ decision
Julien Funk (jaboing) on 2013-09-19
tags: added: jfunk-20130918
David Henningsson (diwic) wrote :

I think this is a feature. I mean, if somebody calls you 5 - 10 times in a row, how annoying isn't that? I would certainly like to block that person for a while. ;-)

Just kidding. I can reproduce it here, and I think it's PulseAudio related (or even further down in the audio stack).

I also noticed two things:
 - If you wait a few minutes without calling the phone, it seems it resolves itself.
 - If you wait a few minutes while calling (just let it ring), eventually the dialog will come up, but not the ringtone.

Julien Funk (jaboing) on 2013-09-23
tags: added: jfunk
removed: jfunk-20130918
tags: removed: jfunk
David Henningsson (diwic) wrote :

Just adding combined pulseaudio + kernel syslog from when it happens for reference, here are the first signs of error:

Sep 24 11:57:55 ubuntu-phablet pulseaudio[747]: [pulseaudio] module-android-audio-hal.c: Setting mode to normal through set_parameters (Nexus 4 workaround)
Sep 24 11:57:55 ubuntu-phablet pulseaudio[747]: [alsa-source-MultiMedia1 (*)] alsa-source.c: Wakeup from ALSA!
Sep 24 11:57:55 ubuntu-phablet kernel: [ 179.245841] SLIM_CL: skip reconfig sequence
Sep 24 11:57:55 ubuntu-phablet kernel: [ 179.423622] SLIM_CL: skip reconfig sequence
Sep 24 11:57:55 ubuntu-phablet kernel: [ 179.453624] SLIM_CL: skip reconfig sequence
Sep 24 11:57:55 ubuntu-phablet kernel: [ 179.459575] SLIM_CL: skip reconfig sequence
Sep 24 11:57:56 ubuntu-phablet kernel: [ 179.507218] SLIM_CL: skip reconfig sequence
Sep 24 11:57:56 ubuntu-phablet kernel: [ 180.498000] tabla_codec_enable_chmask: Slim close tx/rx wait timeout
Sep 24 11:57:56 ubuntu-phablet kernel: [ 180.498641] tabla_codec_enable_slimrx: Disconnect RX port ret = 0
Sep 24 11:57:56 ubuntu-phablet kernel: [ 180.501449] overflow error on port a, value 5
Sep 24 11:57:56 ubuntu-phablet pulseaudio[747]: [pulseaudio] module-android-audio-hal.c: device set_parameters returned error -22

Changed in pulseaudio (Ubuntu Saucy):
assignee: nobody → David Henningsson (diwic)
status: New → Fix Committed
David Henningsson (diwic) wrote :

I believe a fix is here:
http://bazaar.launchpad.net/~ubuntu-audio-dev/pulseaudio/ubuntu/revision/603

You're encouraged to test and make sure it works for you.

David Henningsson (diwic) wrote :

Sep 24 11:57:56 ubuntu-phablet kernel: [ 180.498000] tabla_codec_enable_chmask: Slim close tx/rx wait timeout
Sep 24 11:57:56 ubuntu-phablet kernel: [ 180.498641] tabla_codec_enable_slimrx: Disconnect RX port ret = 0
Sep 24 11:57:56 ubuntu-phablet kernel: [ 180.501449] overflow error on port a, value 5

I believe this indicates some type of kernel error. I don't mind if anyone takes a look at the kernel to see if this scenario (tearing down a voice call with streams running) can be handled more gracefully, but I don't think it's urgent, because we have a working fix/workaround in PulseAudio (close the streams before tearing down the voice call).

Changed in telephony-service:
status: Confirmed → Fix Committed
affects: telephony-service → telepathy-ofono
affects: telephony-service (Ubuntu Saucy) → telepathy-ofono (Ubuntu Saucy)
Changed in telepathy-ofono (Ubuntu Saucy):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:4.0-0ubuntu5

---------------
pulseaudio (1:4.0-0ubuntu5) saucy; urgency=low

  [ David Henningsson ]
  * Ubuntu phone: Suspend sinks/sources before tearing down voice calls
    (LP: #1226298)
 -- Ricardo Salveti de Araujo <email address hidden> Wed, 25 Sep 2013 13:06:49 -0300

Changed in pulseaudio (Ubuntu Saucy):
status: Fix Committed → Fix Released
David Henningsson (diwic) wrote :

This is not a kernel error. Userspace just needs to be more careful about not touching certain mixer controls while a PCM stream is running. It is uncommon for this to happen on desktop/HDA, but likely to be more common in the ASoC world.

Changed in linux-mako (Ubuntu Saucy):
status: New → Invalid
Changed in telepathy-ofono:
status: Fix Committed → Invalid
status: Invalid → Fix Released
Changed in linux-mako (Ubuntu):
status: New → Invalid
Changed in telepathy-ofono:
status: Fix Released → Fix Committed
Changed in telepathy-ofono:
status: Fix Committed → Fix Released
Changed in telepathy-ofono (Ubuntu):
status: Fix Committed → Fix Released
no longer affects: telepathy-ofono (Ubuntu Saucy)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers