AppArmor profile does not allow creating of ~/.cache/dconf

Bug #939126 reported by David Edmundson on 2012-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
telepathy-mission-control-5 (Ubuntu)
High
Jamie Strandboge
Precise
High
Unassigned

Bug Description

This causes telepathy-gabble (and other CMs) to throw a critical_error when creating this directory if it does not exist already.

To reproduce:
 delete ~/.cache/dconf

killall telepathy-gabble
start GABBLE_PERSIST=1 GABBLE_DEBUG=all /usr/lib/telepathy/telepathy-gabble

this will error when the first account is connected.

The full list we need permissions for is as following:

${HOME}/.cache/
${HOME}/.cache/telepathy/
${HOME}/.cache/wocky/
${HOME}/.cache/wocky/caps/
${HOME}/.config/indicators/
${HOME}/.config/indicators/messages/
${HOME}/.config/indicators/messages/applications-blacklist/
${HOME}/.{cache,config}/dconf/user
${HOME}/.local/share/telepathy/
${HOME}/.local/share/TpLogger/
${HOME}/.mission-control/

Changed in telepathy-mission-control-5 (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → High
status: New → Triaged
Jamie Strandboge (jdstrand) wrote :

Thank you for using Ubuntu and reporting a bug. I am not able to reproduce this. I have created a working XMPP account. I then used your reproducer and it was fine. Can you give more details including the denial messages? Thanks.

Changed in telepathy-mission-control-5 (Ubuntu):
status: Triaged → Incomplete

We see it all the time in KDE Telepathy with users who only have telepathy as the app that uses libdconf.

Telepathy gabble quits with:
"unable to create '/home/username/.cache/dconf'; dconf will not work properly"
The issue is in dconf_shmdir_from_environment() in libdconf.

It doesn't seem to affect Gnome users very much as some other app will have created this directory first.

I did miss a step in my instructions:
make sure you disconnect any jabber accounts (as otherwise telepathy-gabble will automatically spawn after you kill it, before launching by hand)
connect the jabber account after launching telepathy-gabble manually, this is when the error occurs.

I'm using Oeneric, but I think this still happens in precise as it was brought up on the kubuntu-devel ML when talking about telepathy.

Jamie Strandboge (jdstrand) wrote :

I'm happy to fix it but I did make sure telepathy-gabble was not running and still could reproduce. I wasn't clear on the denial message: can you give me the denial message from /var/log/kern.log when it fails? Thanks

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-mission-control-5 - 1:5.12.0-0ubuntu5

---------------
telepathy-mission-control-5 (1:5.12.0-0ubuntu5) quantal; urgency=low

  * debian/apparmor-profile:
    - add dbus-session abstraction to mission-control-5 to allow auto-logins
      to work properly (LP: #992619)
    - allow creating ~/.cache/dconf for new users (LP: #939126)
 -- Jamie Strandboge <email address hidden> Mon, 18 Jun 2012 07:51:38 -0500

Changed in telepathy-mission-control-5 (Ubuntu):
status: Incomplete → Fix Released
Changed in telepathy-mission-control-5 (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers