mission-control-5 crashed with SIGSEGV in g_str_hash()

Bug #814511 reported by Alexander Hunziker on 2011-07-22
160
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Telepathy Mission Control 5
Fix Released
Medium
telepathy-mission-control-5 (Ubuntu)
Medium
Unassigned

Bug Description

I opened a chat window in empathy, thereafter MC crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: telepathy-mission-control-5 1:5.9.0-1 [modified: usr/share/doc/telepathy-mission-control-5/changelog.Debian.gz]
ProcVersionSignature: Ubuntu 3.0.0-6.7-generic 3.0.0-rc7
Uname: Linux 3.0.0-6-generic x86_64
Architecture: amd64
Date: Fri Jul 22 11:37:26 2011
ExecutablePath: /usr/lib/telepathy/mission-control-5
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: /usr/lib/telepathy/mission-control-5
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en
 LANG=en_DK.utf8
SegvAnalysis:
 Segfault happened at: 0x7f49366dbd90 <g_str_hash>: movzbl (%rdi),%edx
 PC (0x7f49366dbd90) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: telepathy-mission-control-5
StacktraceTop:
 g_str_hash () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: mission-control-5 crashed with SIGSEGV in g_str_hash()
UpgradeStatus: Upgraded to oneiric on 2011-07-19 (3 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 g_str_hash (v=0x0) at /build/buildd/glib2.0-2.29.10/./glib/gstring.c:142
 g_hash_table_lookup_node (hash_table=0xea9800, key=0x0) at /build/buildd/glib2.0-2.29.10/./glib/ghash.c:360
 g_hash_table_lookup (hash_table=0xea9800, key=0x0) at /build/buildd/glib2.0-2.29.10/./glib/ghash.c:1022
 mcd_dispatcher_client_needs_recovery_cb (client=0xef4460, self=0xeb1000) at mcd-dispatcher.c:683
 g_closure_invoke (closure=0xf2d080, return_value=0x0, n_param_values=1, param_values=0xf04ae0, invocation_hint=<value optimized out>) at /build/buildd/glib2.0-2.29.10/./gobject/gclosure.c:773

Changed in telepathy-mission-control-5 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in telepathy-mission-control-5 (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugs.freedesktop.org/show_bug.cgi?id=39766

visibility: private → public
Changed in telepathy-mission-control-5 (Ubuntu):
status: Confirmed → Triaged
Changed in mission-control-5:
importance: Unknown → Critical
status: Unknown → Confirmed
Detlef Lechner (detlef-lechner) wrote :

I affected too.
$ uname -a
Linux T61 3.0.0-8-server #11-Ubuntu SMP Fri Aug 12 22:04:11 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Xavier Claessens (zdra) on 2011-08-22
Changed in mission-control-5:
importance: Critical → Unknown
status: Confirmed → Unknown
Changed in mission-control-5:
importance: Unknown → Medium
status: Unknown → Confirmed

Is this not a duplicate of bug 726301?

Changed in mission-control-5:
status: Confirmed → Fix Released
tags: added: bugpattern-needed
MN (istheendnigh) wrote :

The bug was similar—but not exactly the same—for me: I was typing in a chat bubble in gnome-shell and an Empathy window popped up out of the blue, prompting this crash.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.