mission-control-5 crashed with SIGSEGV in g_slist_find()

Bug #1132555 reported by Daniel Winzen
382
This bug affects 85 people
Affects Status Importance Assigned to Milestone
telepathy-mission-control-5 (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

I don't know when or why this happened, this error-message was in the background, so for a long time not noticed by me.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: telepathy-mission-control-5 1:5.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Thu Feb 21 22:31:18 2013
ExecutablePath: /usr/lib/telepathy/mission-control-5
InstallationDate: Installed on 2012-04-03 (326 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120403)
KernLog:

MarkForUpload: True
ProcAttrCurrent: /usr/lib/telepathy/mission-control-5 (enforce)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-3.8.0-7-generic root=UUID=0A320B17320B0781 loop=/hostname/disks/root.disk ro quiet splash vt.handoff=7
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 TERM=xterm
 LANG=de_DE.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f997de7f320 <g_slist_find+16>: cmp %rsi,(%rax)
 PC (0x7f997de7f320) ok
 source "%rsi" ok
 destination "(%rax)" (0x00000040) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: telepathy-mission-control-5
StacktraceTop:
 g_slist_find () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libdbus-glib-1.so.2
 g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: mission-control-5 crashed with SIGSEGV in g_slist_find()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Revision history for this message
Daniel Winzen (q-d-deactivatedaccount) wrote :
information type: Private → Public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 g_slist_find (list=0x40, data=data@entry=0x207a4f0) at /build/buildd/glib2.0-2.35.8/./glib/gslist.c:727
 g_object_notify_queue_add (nqueue=nqueue@entry=0x2067130, pspec=0x207a4f0, object=<optimized out>) at /build/buildd/glib2.0-2.35.8/./gobject/gobject.c:305
 object_set_property (nqueue=0x2067130, value=0x205e1f8, pspec=0x207a4f0, object=0x2064350) at /build/buildd/glib2.0-2.35.8/./gobject/gobject.c:1363
 g_object_constructor (type=<optimized out>, n_construct_properties=<optimized out>, construct_params=<optimized out>) at /build/buildd/glib2.0-2.35.8/./gobject/gobject.c:1869
 dbus_g_proxy_manager_register (manager=0x2059af0, proxy=0x2059af0) at dbus-gproxy.c:1002

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in telepathy-mission-control-5 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telepathy-mission-control-5 (Ubuntu):
status: New → Confirmed
Revision history for this message
Ivan Mikushin (i-mikushin) wrote :

I'm having this on gnome-shell reload.

Revision history for this message
Kam Pow (kampowchicken) wrote :

Happened to me after I logged out and logged back in. It happened multiple times already.

Revision history for this message
HaruSiga77 (tolkien-world) wrote :

I have gnome shell too, but I use the kernel 3.9rc4.

Revision history for this message
Dallman Ross (spamless) wrote :

I logged in and noticed my computer clock was two hours behind, so I went in to Date/Time and updated it. When I tried to close the Date/Time applet, the crash pop-up screen displayed itself.

sladner84 (sladner84)
Changed in telepathy-mission-control-5 (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Fix Released
Revision history for this message
Patrik Lundquist (patrik-lundquist) wrote :

It is obviously not fixed since the last uploaded release 1:5.14.0-0ubuntu1 is from 2013-01-10.

Revision history for this message
BenginM (sary) wrote :

this occur after a login attempt :, gnome-shell 3.8 enabled from gnome3 ppa :

sary@n1x:~$ lsb_release -rda; uname -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04
Codename: raring
Linux n1x 3.8.0-17-generic #27-Ubuntu SMP Sun Apr 7 19:39:35 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
sary@n1x:~$

sary@n1x:~$ apt-cache policy gnome-shell
gnome-shell:
  Installed: 3.8.0.1-0ubuntu1+js17~raring3.1
  Candidate: 3.8.0.1-0ubuntu1+js17~raring3.1
  Version table:
 *** 3.8.0.1-0ubuntu1+js17~raring3.1 0
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     3.8.0.1-0ubuntu1+js17~raring3 0
        500 http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu/ raring/main amd64 Packages
     3.6.3.1-0ubuntu4 0
        500 http://sa.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
sary@n1x:~$

Revision history for this message
Michael Sparmann (theseven) wrote :

Does not appear to be fixed in the official repositories yet, despite being in "Fix Released" state since more than 6 weeks?

Revision history for this message
Nils Toedtmann (m-launchpad-net-mail-nils-toedtmann-net) wrote :

It's not fixed for me either. Fully patched 13.04 with Gnome 3.8 from PPA. Seems to only happen when starting gnome shell, not in Unity.

Revision history for this message
Jonathan (jonathan-uxbr) wrote :

Also not fixed for me on fully patched Ubuntu 13.04 running gnome shell as packaged by the gnome team (ubuntu-gnome).

Revision history for this message
martyfelker (martyfelker-gmail) wrote :

Happened to me using Ubuntu 13.01 kernel 3.10. Obviously has not been fixed for some time.

Revision history for this message
kai (kkrapu) wrote :

Happens to me lately upon log in. I'm using gnome 3.8 from the gnome team ppa. It's been fine for weeks, but last few days I've had this crash. Didn't do any changes to the system that I can recall, might have been there was some updates after which it started happening, but I'm not sure about that.

Revision history for this message
Jiří Podvolecký (jiri-podvolecky) wrote :

Styl in 13.10

Revision history for this message
HamilJF (john-hamilton) wrote :

Not fixed for me either... ran a full set of updates last night and sent off an automated error message this morning. Running 13.04 on an AMD64, Unity shell (but who knows what is going on in the background). How do we get the status to 'unfixed' ?

Revision history for this message
Eric Morgan (gemorgan) wrote :

This bug has been bothering me for 2 Ubuntu versions now and over a year... :( Every single time I boot and log in.

Revision history for this message
Yann Simon (yann-simon-fr) wrote :

Not fixed for me neither...

Revision history for this message
RJP Computing (rpusztai) wrote :

Not fixed for me either. It happens when rebooting or logging out and then back in as well.

Revision history for this message
Cengizhan Yücel (cengizhan.yuecel) wrote :

I R also affected for many months, still not fixed. :o(

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers