ICQ doesn't work since June 10, 2011

Bug #795932 reported by Timur I. Davletshin on 2011-06-11
244
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Telepathy Haze
Unknown
Medium
telepathy-haze (Fedora)
Fix Released
High
telepathy-haze (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: empathy

Empathy stopped working after yet another protocol change in ICQ. Gives no additional information. Other clients like pidgin still work.

Disabling ssl in pidgin is required for proper login. But empathy gives no way to switch it.

Simon Dierl (simon.dierl) wrote :

Same problem over here, what shows up in the log for haze:

clientLogin response statusCode was 440 (0): <response xmlns="https://api.login.aol.com">
  <statusCode>440</statusCode>
  <statusText>Invalid DevId</statusText>
</response>

Google-Fu indicates that the problem is existent among libpurple users in general, Adium users apparently can't log in, too. Seems like ICQ banned the DevId used by libpurple.

Maxim Darak (maxim-darak) wrote :

ICQ in empathy doesn't work.. In Pidgin works normally... :-/ And i have enabled ssl in pidgin.

Description of problem:
Since Jun 11 2011 Empathy cannot connect to ICQ network. A "Network Error" message is displayed.

Version-Release number of selected component (if applicable):
empathy-2.32.2-1

How reproducible:
Every time

Steps to Reproduce:
1. Create an ICQ account in Empathy
2. Launch Empathy
3. Get a "Network Error" message

Actual results:
A "Network Error" message without any further details or log records.

Expected results:
Successful connection (as it was before Jun 11)

Additional info:
F14 with all updates. The issue is not related to system update.

In similar situations before (e.g., Nov 2010) switching SSL off helped. Pidgin can still connect, but only with SSL disabled.

Empathy does not have an option to disable SSL or to ignore SSL errors (it seems there was one, but is now gone? Or patched-off Fedora?). Setting "use-client-login" to "false" via mc-tool does not help. Empathy no longer recognizes "use-ssl" option via mc-tool.

I have the same bug.

https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=712674 - could be the key for searching solution. But enabling SSL seems not working

Following solution worked for me:

Find out your icq account name:
mc-tool list | grep icq
mc-tool update <account name> bool:use-ssl=0
mc-tool update <account name> bool:use-clientlogin=0

Maxim Darak (maxim-darak) wrote :

@Timur I. Davletshin
Thanks.. Works in empathy for me :-)

Maxim Darak (maxim-darak) wrote :

My friend have ubuntu 11.04 and gnome3 + gnome-shell. Empathy version is 3.0.2. For him this fix not working..

mc-tool update: Protocol 'icq' does not have parameter 'use-ssl' - confirming, doesn't work in 11.04

Recent version of libpurple renamed the use-ssl parameter. tp-haze will need patching to map the Telepathy names to the new libpurple semantics.

Will Thompson <email address hidden> wrote:

I just took a quick look. Recent versions of libpurple renamed that
parameter. Looks like Haze will need patching to map the Telepathy names
to the new libpurple semantics: it's got a string parameter "encryption"
which takes a bunch of values. Helpfully the names of the values are
different for different prpls…

--
Will

Is there any upstream bug report somewhere?

Omer Akram (om26er) on 2011-06-13
affects: empathy (Ubuntu) → telepathy-haze (Ubuntu)
Changed in telepathy-haze (Ubuntu):
importance: Undecided → High
status: New → Confirmed

(In reply to comment #3)
> Is there any upstream bug report somewhere?

Haven't checked yet. It's been discussed briefly on telepathy mailing list.

http://lists.freedesktop.org/archives/telepathy/2011-June/005601.html

Problem is with libpurple's default client key. It looks like it's blocked now by ICQ servers. If you changed it to for example client key used by pidgin it will be working again.

*** Bug 713113 has been marked as a duplicate of this bug. ***

#5 I have:

~$ mc-tool update haze/icq/_3<icq_uin>0 bool:use-ssl=0
mc-tool update: Protocol 'icq' does not have parameter 'use-ssl'

and I cant fix it! ( I already saw this hint but I though it was dated)

Changed in telepathy-haze (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in telepathy-haze (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → High
status: New → Confirmed
tags: added: patch
Eugene Romanenko (eros2) wrote :

This should help:

mc-tool update `mc-tool list | grep icq` string:encryption=no_encryption
mc-tool update `mc-tool list | grep icq` bool:use-clientlogin=0

eros2's solution works for me (gnome-shell, empathy 3.1.1)

tom (tasker) wrote :

If you have more than one ICQ account, please change the 'icq' parameter after 'grep' in eros2's solution to your ICQ number:

mc-tool update `mc-tool list | grep <ICQNUMBER>` string:encryption=no_encryption
mc-tool update `mc-tool list | grep <ICQNUMBER>` bool:use-clientlogin=0

For example your number is 123456
mc-tool update `mc-tool list | grep 123456` string:encryption=no_encryption
mc-tool update `mc-tool list | grep 123456` bool:use-clientlogin=0

Remember to change your connection type back when the bug is fixed. Just delete and add your ICQ account again.

Oleg Cherkasov (o1e9) wrote :

#13 works for me on 11.04 just fine. I am able to connect now.
Thanks!

no, encryption=no_encryption do not works, this is my account:
$ mc-tool show haze/icq/_3<uin>0
     Account: haze/icq/_3<uin>0
Display Name: ICQ (<uin>)
  Normalized: <uin>
     Enabled: enabled
        Icon: im-icq
    Nickname: <uin>
     Service: icq
   Automatic: available (2) ""
     Current: offline (1) ""
   Requested: busy (6) ""

      (string) password = <uin>
      (string) server = login.oscar.aol.com
      (string) encryption = no_encryption
        (bool) use-clientlogin = false
        (uint) port = 5190
      (string) account = <uin>

server, port? something else is wrong?

Is there a way to override the libpurple key without recompiling? Seems like the best fix would to update libpurple to make that possible and have the install process generate a unique key for each machine.

I'm not crazy about any workaround that's going to be sending my ID/pass in the clear.

I can confirm that solution #13 also worked for me on Ubuntu 11.04.

Changed in telepathy-haze:
importance: Unknown → Medium
status: Unknown → New
Günter (guenter-grodotzki) wrote :

Thank you #13 and #15 works now again.

Changed in telepathy-haze:
status: New → Unknown
zhekanax (zhekanax) wrote :

How do I apply the patch in #11 to package?
Any other workarounds seems not working

Changed in telepathy-haze (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Ken VanDine (ken-vandine)
Changed in telepathy-haze (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Ken VanDine (ken-vandine)
Laurent Bigonville (bigon) wrote :

Just uploaded tp-haze 0.5.0 to debian, my ICQ account is working with it

This package has changed ownership in the Fedora Package Database. Reassigning to the new owner of this component.

telepathy-haze-0.5.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/telepathy-haze-0.5.0-1.fc15

I believe this bug has been fixed with the latest tp-haze, Since I don't use ICQ, I would appreciate it if one of the folks experiencing this bug could verify that telepathy-haze-0.5.0-1.fc15 fixed this. Thanks.

Package telepathy-haze-0.5.0-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing telepathy-haze-0.5.0-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/telepathy-haze-0.5.0-1.fc15
then log in and leave karma (feedback).

telepathy-haze-0.5.0-1.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

same setting as in #17 . I installed ubuntu 11.10 here, and in another machine, in new machine it works what installed from scratch (ubuntu 11.10), but upgrade does not work, neither #13 nor #15

Changed in telepathy-haze (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in telepathy-haze (Ubuntu Natty):
assignee: Ken VanDine (ken-vandine) → nobody
status: Confirmed → Won't Fix
Changed in telepathy-haze (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.