empathy can't import contacts for "gg"

Bug #411845 reported by Boniek on 2009-08-11
124
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Telepathy Haze
Confirmed
Medium
telepathy-haze (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

There is no way to import any contacts if you are using gg protocol which is very popular in Poland. Why do we have to change pidgin to empathy which don't work good for us?

Boniek (boniek12p) wrote :

Binary package hint: empathy

There is no way to import any contacts if you are using gg protocol which is very popular in Poland. Why do we have to change pidgin to empathy which don't work good for us?

Alex Lourie (alourie) wrote :

Empathy does support Gadu Gadu. What do you mean you can't import contacts? Aren't they stored on the server?

Boniek (boniek12p) wrote :

Yes, it supports, but if I have my contacts stored on server or in a file there is no way to import them all at once to .

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in empathy (Ubuntu):
importance: Undecided → Low
Boniek (boniek12p) wrote :

I've sent the bug to upstream

*** Bug 23795 has been marked as a duplicate of this bug. ***

Boniek (boniek12p) wrote :
affects: empathy (Ubuntu) → telepathy-haze (Ubuntu)
Changed in telepathy-haze:
status: Unknown → Confirmed
Boniek (boniek12p) on 2010-01-17
Changed in telepathy-haze (Ubuntu):
status: New → Confirmed

telepathy-sunshine is connection manager that allows for gg import,and add GG8 protocol support http://git.collabora.co.uk/?p=user/kkszysiu/telepathy-sunshine.git;a=summary
Fedora is rewieving it and have some packages https://bugzilla.redhat.com/show_bug.cgi?id=557546

Omer Akram (om26er) on 2010-03-04
Changed in telepathy-haze (Ubuntu):
status: Confirmed → Triaged

Best way to fix that is to package telepathy-sunshine and move it to Ubuntu main repo and make it default instead of telepathy-haze.

Don't mean to interrupt but I agree with Mr Klinikowski. Summing-up the Gadu-Gadu (gg for short) topic:

[using Empathy 2.30.1 from Ubuntu 10.4]

1. contacts list in original gg client or pidgin is stored in local file with option to manually upload to gg server
2. telepaty-haze doesn't allow to import contacts from gg server, original gg client or pidgin
3. it is possible to speak with other contacts when the exact gg# (gg account number) is known
4. it is impossible to set an alias or permanently save the contact on the list (since it isn't stored in file or synced with server)
5. chats history in gg is stored in local file however it is impossible to import chats history from original client or from pidgin

Also, there's no way to set a message for "invisible" or "offline" status which is supported by gg protocol.

I mention pidgin since it used to be the default Ubuntu IM and compatibility is important due to migration of some users.

I think above 5 issues should be provided in some update since installing telepathy-sunshine is pretty confusing for common user (who probably never compiled any source).

Changed in telepathy-haze:
importance: Unknown → Medium
Changed in telepathy-haze:
importance: Medium → Unknown
Changed in telepathy-haze:
importance: Unknown → Medium

Are there any news on the matter?

Question is why libpurple should be fixed there?

I think the ticket should be renamed to:

"[gg] invoke prpl actions to sync buddy list because of lack of functinality in Telepathy for now"

because libpurple approach is standard-like here. Official GaduGadu client does the same thing, I mean they give users opportunity to import/export contactlist from/to server rather than force to do it.

Niestety nie moge ci pomoc bo nie uzywam od dawna gg. Pzdr
On Dec 2, 2011 10:16 AM, "Julian Sikorski" <email address hidden> wrote:

> Are there any news on the matter?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (503957).
> https://bugs.launchpad.net/bugs/411845
>
> Title:
> empathy can't import contacts for "gg"
>
> Status in Telepathy Haze:
> Confirmed
> Status in “telepathy-haze” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: empathy
>
> There is no way to import any contacts if you are using gg protocol
> which is very popular in Poland. Why do we have to change pidgin to
> empathy which don't work good for us?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telepathy-haze/+bug/411845/+subscriptions
>

Grzegorz G. (grzesiek1e5) wrote :

Still isn't fixed in Gnome 3.4. Empathy doesn't even use gg numbers from gnome-contacts (contacts made using evolution 3.4).

This means Gadu-Gadu ISN'T SUPPORTED! Remove it from list or fix it!

I'm falling back to Kadu now.

Any news on the issue?

I think this topic is overdue

2014-07-05 17:07 GMT+02:00 karaluh <email address hidden>:

> Any news on the issue?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (503957).
> https://bugs.launchpad.net/bugs/411845
>
> Title:
> empathy can't import contacts for "gg"
>
> Status in Telepathy Haze:
> Confirmed
> Status in “telepathy-haze” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: empathy
>
> There is no way to import any contacts if you are using gg protocol
> which is very popular in Poland. Why do we have to change pidgin to
> empathy which don't work good for us?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telepathy-haze/+bug/411845/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.