Audio/Video chat does not work with iChat users

Bug #421567 reported by Kẏra on 2009-08-30
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Empathy
Unknown
Medium
Pidgin
New
Undecided
Unassigned
telepathy-farsight
Invalid
Undecided
Unassigned
telepathy-gabble
Confirmed
Wishlist
telepathy-gabble (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

iChat users don't appear as having audio or video chat available

Kẏra (thekyriarchy) on 2009-08-31
Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Changed in empathy:
status: Unknown → New
Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Kẏra (thekyriarchy) wrote :

iChat likely does this because conference (multiparty) video calling isn't supported (Bug #493383)

Kẏra (thekyriarchy) wrote :

Ah, actually could this be from using MeBeam? http://www.adiumxtras.com/index.php?a=xtras&xtra_id=4959

Audio/Video is incompatible with iChat users. iChat users don't appear as
having audio or video chat available and Empathy users don't appear to have it
from the iChat users perspective. Audio/video chat should be compatible with
iChat

https://bugzilla.gnome.org/show_bug.cgi?id=593604
https://bugs.launchpad.net/bugs/421567

Possible solutions from previous comments:
Might require some reverse engineering
Support of MeBeam http://www.adiumxtras.com/index.php?a=xtras&xtra_id=4959

Brian Curtis (bcurtiswx) on 2009-12-07
Changed in telepathy-farsight:
status: New → Invalid
Kẏra (thekyriarchy) wrote :

Upstream says:
Status: RESOLVED
Resolution: NOTGNOME
Where should this bug be filed?

Brian Curtis (bcurtiswx) wrote :

seems to be an XMPP problem, so telepathy-gabble and report bugs to http://bugs.freedesktop.org. Once you report the bug link i there.

Changed in telepathy-gabble:
status: Unknown → Confirmed
affects: empathy (Ubuntu) → telepathy-gabble (Ubuntu)
affects: telepathy-gabble (Ubuntu) → empathy (Ubuntu)
affects: empathy (Ubuntu) → telepathy-gabble (Ubuntu)

http://telepathy.freedesktop.org/wiki/Muji is the telepathy muji implementation. Would this fix iChat support, as suggested in https://bugzilla.gnome.org/show_bug.cgi?id=599168 ?

(In reply to comment #1)
> http://telepathy.freedesktop.org/wiki/Muji is the telepathy muji
> implementation. Would this fix iChat support, as suggested in
> https://bugzilla.gnome.org/show_bug.cgi?id=599168 ?

No, iChat doesn't implement Muji. I believe they negotiate a SIP session for video calls.

So gabble would have to spawn a sofiasip connection somehow?

Jeremy Nickurak (nickurak) wrote :

599168 is support for multi-user audio/video support, which is suggested as the reason iChat doesn't work with empathy

Changed in empathy:
status: New → Unknown
Jeremy Nickurak (nickurak) wrote :

OTOH, Will Thompson @ https://bugs.freedesktop.org/show_bug.cgi?id=25501 suggests:

> No, iChat doesn't implement Muji. I believe they negotiate a SIP session for
> video calls.

If that's the case, we're back to http://bugzilla.gnome.org/show_bug.cgi?id=593604 on the gnome side.

Jeremy Nickurak (nickurak) wrote :

reportedly, MUJI support wouldn't actually fix iChat.

If iChat doesn't use the XMPP standard for audio/video calls (Jingle), then implementing support for whatever it *does* use is a quite extensive piece of feature work, rather than just a bugfix. (severity normal -> enhancement)

Changed in telepathy-gabble:
importance: Unknown → Wishlist
Changed in empathy:
importance: Unknown → Medium
Changed in telepathy-gabble:
importance: Wishlist → Unknown
Changed in telepathy-gabble:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.