Ubuntu

[MIR] empathy dependencies

Reported by Martin Pitt on 2009-06-18
40
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GStreamer
Invalid
Undecided
Unassigned
farsight2 (Fedora)
Fix Released
Unknown
farsight2 (Ubuntu)
High
Ken VanDine
Karmic
High
Ken VanDine
geoclue (Ubuntu)
Undecided
Ken VanDine
Karmic
Undecided
Ken VanDine
gssdp (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
gst-plugins-bad0.10 (Ubuntu)
Undecided
Ken VanDine
Karmic
Undecided
Ken VanDine
gst-plugins-good0.10 (Ubuntu)
Undecided
Ken VanDine
Karmic
Undecided
Ken VanDine
gstreamer0.10 (Ubuntu)
High
Unassigned
Karmic
High
Unassigned
gupnp (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
gupnp-igd (Ubuntu)
High
Martin Pitt
Karmic
High
Martin Pitt
libnice (Ubuntu)
High
Ken VanDine
Karmic
High
Ken VanDine
papyon (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
telepathy-butterfly (Ubuntu)
High
Ken VanDine
Karmic
High
Ken VanDine
telepathy-farsight (Ubuntu)
High
Ken VanDine
Karmic
High
Ken VanDine
telepathy-mission-control-5 (Ubuntu)
Undecided
Ken VanDine
Karmic
Undecided
Ken VanDine

Bug Description

empathy (in main now) needs telepathy-farsight and libgstfarsight0.10-0 from farsight2.

I promoted them to main now to unbreak CD builds, but they need a proper MIRs.

Martin Pitt (pitti) on 2009-06-18
Changed in telepathy-farsight (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
status: New → Incomplete
Changed in telepathy-farsight (Ubuntu Karmic):
milestone: none → karmic-alpha-3
Changed in farsight2 (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
milestone: none → karmic-alpha-3
status: New → Incomplete
Steve Langasek (vorlon) on 2009-06-19
Changed in telepathy-farsight (Ubuntu Karmic):
importance: Undecided → High
Martin Pitt (pitti) wrote :

This needs some deeper fixing. CDs still don't build:

The following packages have unmet dependencies:
  libgstfarsight0.10-0: Depends: libnice0 (>= 0.0.6) but it is not installable
                        Depends: gstreamer0.10-plugins-bad (>= 0.10.11) but it is not installable
                        Depends: gstreamer0.10-nice but it is not installable

-plugins-bad pulls in a big set of further dependencies, none of which are very appropriate in main, and they would also take a lot of CD space. Look at current http://people.ubuntu.com/~ubuntu-archive/component-mismatches.txt . Is it possible to strip down the dependencies of farsight, or reorganize the gstreamer packages in a way to move the required codecs into -plugins-good?

Martin Pitt (pitti) wrote :

I reverted empathy -> pidgin in the desktop seed again, to unbreak CD builds.

Martin Pitt (pitti) wrote :

With pidgin back in ubuntu-meta, this isn't an alpha-3 blocker any more. Should still be fixed ASAP, to get as much testing as possible.

Changed in telepathy-farsight (Ubuntu Karmic):
milestone: karmic-alpha-3 → none
Changed in farsight2 (Ubuntu Karmic):
milestone: karmic-alpha-3 → none
Kẏra (kxra) wrote :

gstreamer0.10-plugins-bad should be removed from farsight dependencies because that conflicts with anyone who has or tries to install the fluendo codec pack

Ken VanDine (ken-vandine) wrote :

We need to work with the gstreamer guys to get rtpmanager and liveadder moved to -good. Upstream telepathy developers think at least rtpmanager should be in -good. I am checking with upstream gstreamer.

Changed in farsight2 (Fedora):
status: Unknown → In Progress
Changed in farsight2 (Fedora):
status: In Progress → Fix Committed

Can you link this bug to upstream gstreamer?

On Mon, Jun 22, 2009 at 16:40, Ken VanDine <email address hidden>wrote:

> We need to work with the gstreamer guys to get rtpmanager and liveadder
> moved to -good. Upstream telepathy developers think at least rtpmanager
> should be in -good. I am checking with upstream gstreamer.
>
> --
> move to main
> https://bugs.launchpad.net/bugs/388898
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
http://www.google.com/profiles/danny.piccirillo

Steve Langasek (vorlon) on 2009-06-26
Changed in gstreamer0.10 (Ubuntu Karmic):
importance: Undecided → High
status: New → Triaged
Changed in telepathy-farsight (Ubuntu Karmic):
status: Incomplete → Fix Released
Changed in farsight2 (Ubuntu Karmic):
status: Incomplete → Fix Released

Fixed? Great! How'd it get worked out?

Laurent Bigonville (bigon) wrote :

I was just to quick in closing this bug sorry :o

Changed in telepathy-farsight (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in farsight2 (Ubuntu Karmic):
status: Fix Released → Fix Committed
Kẏra (kxra) wrote :

Fixed? Great! How'd it get worked out?

Kẏra (kxra) wrote :

Oops, don't know how that got posted again. Anyways, does the fix by removing the dependency or move things to plugins-good?

Laurent Bigonville (bigon) wrote :

Removing the dependency is not possible as it will break things :/

Kẏra (kxra) wrote :

So what was the fix?

Kẏra (kxra) wrote :
Changed in gstreamer:
importance: Undecided → Unknown
status: New → Unknown
Changed in gstreamer:
status: Unknown → Confirmed
Laurent Bigonville (bigon) wrote :

libnice also need to be moved to main

Kẏra (kxra) on 2009-07-01
Changed in gstreamer:
status: Confirmed → Unknown
Ken VanDine (ken-vandine) wrote :

debdiff adding the required plugins to gst-plugins-good

Ken VanDine (ken-vandine) wrote :

debdiff removing the plugins from gst-plugins-bad that have been moved to gst-plugins-good

Changed in gst-plugins-bad0.10 (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gst-plugins-good0.10 (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
Ken VanDine (ken-vandine) wrote :

Both -good and -bad should be uploaded at the same time to prevent conflicts

Kẏra (kxra) wrote :

So when will we see Empathy instead of Pidgin and Ekiga on the daily live cds?

Laurent Bigonville (bigon) wrote :

Have these changes been coordinated with debian?

Martin Pitt (pitti) wrote :

Ken, I added this to control.in to not break upgrades:

Conflicts: gstreamer0.10-plugins-bad (<< 0.10.13-1ubuntu1)
Replaces: gstreamer0.10-plugins-bad (<< 0.10.13-1ubuntu1)

(The replaces was already there, I just bumped the version). Please do that in the future for similar updates, when stuff moves between packages.

Martin Pitt (pitti) wrote :

Ken, I added this to control.in to not break upgrades:

Conflicts: gstreamer0.10-plugins-bad (<< 0.10.13-1ubuntu1)
Replaces: gstreamer0.10-plugins-bad (<< 0.10.13-1ubuntu1)

(The replaces was already there, I just bumped the version). Please do that in the future for similar updates, when stuff moves between packages.

Changed in gst-plugins-good0.10 (Ubuntu Karmic):
status: New → In Progress
Martin Pitt (pitti) wrote :

farsight2 still needs a MIR written.

Changed in farsight2 (Ubuntu Karmic):
status: Fix Committed → Incomplete
Martin Pitt (pitti) wrote :

telepathy-farsight needs MIR.

Changed in telepathy-farsight (Ubuntu Karmic):
status: Fix Committed → Incomplete
Martin Pitt (pitti) wrote :

This doesn't affect the gstreamer0.10 package, invalidating task.

Changed in gstreamer0.10 (Ubuntu Karmic):
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

libnice needs MIR to be written.

Changed in libnice (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-good0.10 - 0.10.15-2ubuntu1

---------------
gst-plugins-good0.10 (0.10.15-2ubuntu1) karmic; urgency=low

  * debian/patches/04_move_farsight_plugins_to_good.patch
    - Move farsight related plugins to -good (LP: #388898)
  * debian/gstreamer-plugins-good.install
    - Added plugins needed for farsight
      - libgstdtmf.so
      - libgstvalve.so
      - libgstautoconvert.so
      - libgstrtpmux.so
      - libgstliveadder.so
      - libgstrtpmanager.so
  * debian/control.in
    - Bump Standards-Version to 3.8.2

 -- Ken VanDine <email address hidden> Wed, 01 Jul 2009 14:58:32 -0400

Changed in gst-plugins-good0.10 (Ubuntu Karmic):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

gst-plugins-bad0.10 (0.10.13-1ubuntu1) karmic; urgency=low

  * debian/gstreamer-plugins-bad.install
    - Removed plugins that are now provided -good (LP #388898)
      - libgstdtmf.so
      - libgstvalve.so
      - libgstautoconvert.so
      - libgstrtpmux.so
      - libgstliveadder.so
      - libgstrtpmanager.so
  * debian/control.in
    - Bump Standards-Version to 3.8.2

 -- Ken VanDine <email address hidden> Wed, 01 Jul 2009 16:02:18 -0400

With the moving of the required codecs to -good, we won't move -bad to main.

Changed in gst-plugins-bad0.10 (Ubuntu Karmic):
status: New → Won't Fix
Changed in gst-plugins-bad0.10 (Ubuntu):
status: New → Won't Fix
Ken VanDine (ken-vandine) wrote :
Changed in telepathy-farsight (Ubuntu Karmic):
status: Incomplete → In Progress
Ken VanDine (ken-vandine) wrote :
Changed in farsight2 (Ubuntu Karmic):
status: Incomplete → In Progress
Ken VanDine (ken-vandine) wrote :
Changed in libnice (Ubuntu Karmic):
status: Incomplete → In Progress
Martin Pitt (pitti) wrote :

Won't promote farsight2 as long as that still pulls in -bad:

Package: libgstfarsight0.10-0
Depends: [...] gstreamer0.10-plugins-bad (>= 0.10.11)

I think this dependency might be moot now, since the codecs moved to -good?

Changed in farsight2 (Ubuntu Karmic):
status: In Progress → Incomplete
Laurent Bigonville (bigon) wrote :

I think too. I will upload a new version soon

Laurent Bigonville (bigon) wrote :

oh right farsight2 is already in main cannot upload :/

Martin Pitt (pitti) wrote :

I fixed the dependency. This should clean most of the noise in component-mismatches:

farsight2 (0.0.12-1ubuntu1) karmic; urgency=low

  * debian/control: Drop gstreamer0.10-plugins-bad dependency, the codecs
    moved to -good. (see LP #388898)

 -- Martin Pitt <email address hidden> Fri, 03 Jul 2009 13:16:37 +0200

Changed in farsight2 (Ubuntu Karmic):
status: Incomplete → New
Laurent Bigonville (bigon) wrote :

maybe interesting to bump the version of gstreamer0.10-plugins-good to 0.10.15-2ubuntu1

Martin Pitt (pitti) wrote :

libnice approved and promoted. Nice and small, and well-packaged.

Changed in libnice (Ubuntu Karmic):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Laurent, indeed, thanks for spotting.

farsight2 (0.0.12-1ubuntu2) karmic; urgency=low

  * debian/control: Bump dependency to -good to >= 0.10.15-2ubuntu1 to ensure
    necessary codec support.

 -- Martin Pitt <email address hidden> Fri, 03 Jul 2009 13:45:43 +0200

Laurent Bigonville (bigon) wrote :

@martin do we want upnp support in libnice? I've packages gupnp-idg in debian but it still stuck in new queue I could maybe upload it directly in ubuntu (but it will be a new dependendy for libnice)

Laurent Bigonville [2009-07-03 12:59 -0000]:
> @martin do we want upnp support in libnice? I've packages gupnp-idg in
> debian but it still stuck in new queue I could maybe upload it directly
> in ubuntu (but it will be a new dependendy for libnice)

-> Ken?

libempathy-gtk24 pulls in geoclue (Depends:) and geoclue-hostip, geoclue-localnet, geoclue-manual (Recommends). So this either needs an MIR, or dropped.

geoclue itself needs to be fixed to not pull in glib 1.2 (!), its build dep on libglib-dev is probably just misnamed. If you fix this, please send to Debian as well. Thanks!

Changed in geoclue (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
status: New → Incomplete
Martin Pitt (pitti) wrote :

farsight2 MIR approved.

Changed in farsight2 (Ubuntu Karmic):
status: New → Fix Released
Martin Pitt (pitti) wrote :

telepathy-farsight is a simple glue package, approved.

Changed in telepathy-farsight (Ubuntu Karmic):
status: In Progress → Fix Released
Kẏra (kxra) wrote :

Why is Pidgin still included on LiveCD's instead of Empathy?

Martin Pitt (pitti) wrote :

Danny, please see above. empathy still pulls in geoclue, which we either need to disable, or promote (which needs a MIR).

Laurent Bigonville (bigon) wrote :

@martin (I tought I had answered before)

The geoclue dependency is a mistake on my part booth depends and recommends can be dropped

I upload a new version of the package right now

Kẏra (kxra) wrote :

@martin Yeah, i assumed geoclue was disabled until it could get an MIR so that the current builds would enclude empathy.

@laurent does this mean Empathy will be on tomorrow's current liveCD?

Laurent Bigonville (bigon) wrote :

dropped geoclue dependency

Changed in geoclue (Ubuntu Karmic):
status: Incomplete → Invalid
Martin Pitt (pitti) wrote :

This pulls in more:

 o telepathy-butterfly: telepathy-butterfly
   [Reverse-Recommends: empathy]

 o telepathy-python: python-telepathy
   [Reverse-Depends: telepathy-butterfly]

 o pymsn: python-msn
   [Reverse-Depends: telepathy-butterfly]

 o elementtree: python-elementtree python-elementtree-doc
   [Reverse-Depends: Rescued from elementtree]
   [Reverse-Build-Depends: pymsn]

pymsn's build dependencies just need to be fixed to be "python (>= 2.5) | python-elementtree", since 2.5 and later include elementtree. Do we want to install butterfly by default? If so, please add tasks and MIRs, otherwise please demote the recommends to suggests.

Changed in telepathy-butterfly (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
status: New → Incomplete

note that the next release of telepathy-butterfly are going to depends on papyon instead of python-msn. papyon is a fork of python-msn since it was nearly unmaintained and 0.4 just got released a few days ago, it's not packaged yet AFAIK

Kẏra (kxra) on 2009-07-10
summary: - move to main
+ Move Empathy Dependencies to Main and Update Desktop Seed
Changed in farsight2 (Fedora):
status: Fix Committed → Fix Released
Changed in gupnp-igd (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
Martin Pitt (pitti) wrote :

As discussed in the desktop team meeting, we decided to temporarily drop the -butterfly recommends, so that we can add it to the CDs right now, and get more testing. papyon etc. is currently being sorted out in Debian.

In the meantime, MSN support is provided through -haze.

Nicolò Chieffo (yelo3) wrote :

PS: anyway butterfly and papyon have lots of bugs, crashes and lost messages. haze is really better now.
Upstream say that only one person is working on butterfly, but he does not have enough time.

Kẏra (kxra) wrote :

Awesome, so can this be included for tomorrow's LiveCD build?

Danny Piccirillo [2009-07-14 20:11 -0000]:
> Awesome, so can this be included for tomorrow's LiveCD build?

That was the idea. I already switched seeds and uploaded ubuntu-meta,
let's see what breaks this time. :-)

any thought about libnice upnp support?

Kẏra (kxra) wrote :

Sweet! Just tried the lated liveCD and Empathy looks happy in there =]

Will we now remove Pidgin?

Danny Piccirillo [2009-07-15 7:37 -0000]:
> Sweet! Just tried the lated liveCD and Empathy looks happy in there =]

Thanks for testing!

> Will we now remove Pidgin?

Yes, this was a glitch in the seeds, fixed now. We also need to teach
libpurple to not pull in pidgin-data any more.

Changed in gstreamer:
status: Unknown → Confirmed

New version of telepathy-butterfly now use papyon

so papyon should be moved to main and telepathy-butterfly added to the cd seed again

Loïc Minier (lool) wrote :

Papyon needs a MIR, please mark as New when the wiki page is ready; thanks

Changed in papyon (Ubuntu Karmic):
status: New → Incomplete
Changed in papyon (Ubuntu Karmic):
status: Incomplete → New
Loïc Minier (lool) wrote :

Packaging looks good. The Secunia security entries URL was typoed but no entries either way, nor for pymsn.

You note: "# Network activity: does it open any port ? Does it handle incoming network data ? No. " It certainly DOES process data from the net.

FYI:
/build/buildd/papyon-0.4.1/papyon/util/weak.py:23: DeprecationWarning: the sets module is deprecated
  from sets import Set

You miss a Provides: ${python:Provides} in control and XB-Python-Version: ${python:Versions}.

Please fix this last policy compliance issue and it's a +1 from me.

I poked Kees in case he'd like to do a security review.

Changed in papyon (Ubuntu Karmic):
assignee: nobody → Loïc Minier (lool)
status: New → Incomplete

@Loïc Minier: about the missing XB-Python-Version, it is not needed using pysupport (it is needed only using pycentral). I'm going to upload a new package with the missing Provides field, is this ok?

Laurent Bigonville (bigon) wrote :

is the Provides: ${python:Provides} really needed?

In debian python policy
http://wiki.debian.org/DebianPython/NewPolicy it seems that it's only needed of packages where built with pythonxx-modulename before

Loïc Minier (lool) wrote :

@Ken: gupnp-igd needs a MIR wiki page

Changed in gupnp-igd (Ubuntu Karmic):
status: New → Incomplete
Changed in telepathy-butterfly (Ubuntu Karmic):
importance: Undecided → High
Changed in gupnp-igd (Ubuntu Karmic):
importance: Undecided → High
Loïc Minier (lool) wrote :

@Devid: I'd prefer if you would include it for now until the python policy gets revised to match the unilateral changes on the pysupport side.

@Laurent: but the package IS named python-papyon, right? it's uesful to allow other packages to depend on a particular version of the package, e.g. a python2.5 only package could depend on python2.5-papyon or the same for 2.6.

I've uploaded the new papyon package with the fixes and I've adjusted the MIR page.

Changed in papyon (Ubuntu Karmic):
status: Incomplete → New
Loïc Minier (lool) wrote :

papyon approved

Changed in papyon (Ubuntu Karmic):
status: New → Fix Committed
Loïc Minier (lool) on 2009-08-25
Changed in papyon (Ubuntu Karmic):
assignee: Loïc Minier (lool) → nobody
Martin Pitt (pitti) wrote :

Ken, Seb, so should we switch from purple to butterfly/papylon for MSN?

summary: - Move Empathy Dependencies to Main and Update Desktop Seed
+ [MIR] empathy dependencies
Ken VanDine (ken-vandine) wrote :

Based on our conversation with upstream at GCDS I would vote for butterfly/papyon. Can we drop haze from the CD if we do that?

The next papyon release (that will be released in the next few days) will add AFAIK support to one of the most requested MSN features: audio/video call. So IMHO we should use butterfly. I will request a FF exception, there are a lot of bug reports and brainstorm ideas asking for that feature, I think we should provide it in karmic in order to properly test it before karmic+1. I'm sorry if the release is not ready before FF but AFAIK there are still few (very few) things to do before releasing it.

Some (not all) links to show how many users want audio/video call support:
http://brainstorm.ubuntu.com/idea/164/
http://brainstorm.ubuntu.com/idea/11685/
https://bugs.edge.launchpad.net/ubuntu/+source/pidgin/+bug/127861

Regression in papyon compared to pidgin:
 - no OIMs support (upstream is working in order to get it working, it is already supported by papyon)
 - no file transfer (like telepathy-haze), but upstream is working on it too

Kẏra (kxra) wrote :

people might complain a lot, but it might be worth it for the LTS

Ken VanDine [2009-08-26 21:02 -0000]:
> Can we drop haze from the CD if we do that?

Don't we need it for a plethora of other protocols? If none of them
are that important any more, it would be nice to drop, since it takes
quite a lot of space.

We just need to lower empathy's recommends to a suggests for that.

Laurent Bigonville (bigon) wrote :

tp-mc-5 will be needed for the 2.28 release so it must be in main.

OTOH libtelepathy and telepathy-mission-control are not needed anymore and may be demoted to universe

Changed in telepathy-mission-control-5 (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)
Martin Pitt (pitti) wrote :

t-m-c-5 approved and promoted, it's just a newer version of t-m-c. I demoted t-m-c and libtelepathy. Thanks!

Changed in telepathy-mission-control-5 (Ubuntu Karmic):
status: New → Fix Released
Ken VanDine (ken-vandine) wrote :

Looks like we need to keep purple and telepathy-haze for yahoo access.

Brian Curtis (bcurtiswx) wrote :

Laurent/Martin/Ken

I have found that a lot of people are disappointed that telepathy-idle is not installed by default when they try to move their IRC account from pidgin to empathy. I was thinking, something that may (or may not) work for saving space on the LiveCD and stop users from complaining that their spec isn't available by default would be to have empathy install the connection managers (idle, butterfly, haze, etc...) upon request when the user tries to create these accounts. I assume the user will have to have an internet connection when wanting to use empathy, so its just the means of installing the small packages to get the connection managers working.

Workflow would be:
-hi thank you for installing empathy, would you like to import accounts from pidgin?
-because you are trying to install (AIM,IRC,MSN) we need to install the connection managers, please click next to continue with this operation
-Importing accounts, please wait...

It may also work to remove the connection managers if nobody is using an account with them anymore.

Thoughts/Bashings/Comments?

Kẏra (kxra) wrote :

excellent idea, just like our codec manager-- should be filed as a separate
bug i think

On Mon, Aug 31, 2009 at 09:27, Brian Curtis <email address hidden> wrote:

> Laurent/Martin/Ken
>
> I have found that a lot of people are disappointed that telepathy-idle
> is not installed by default when they try to move their IRC account from
> pidgin to empathy. I was thinking, something that may (or may not) work
> for saving space on the LiveCD and stop users from complaining that
> their spec isn't available by default would be to have empathy install
> the connection managers (idle, butterfly, haze, etc...) upon request
> when the user tries to create these accounts. I assume the user will
> have to have an internet connection when wanting to use empathy, so its
> just the means of installing the small packages to get the connection
> managers working.
>
> Workflow would be:
> -hi thank you for installing empathy, would you like to import accounts
> from pidgin?
> -because you are trying to install (AIM,IRC,MSN) we need to install the
> connection managers, please click next to continue with this operation
> -Importing accounts, please wait...
>
> It may also work to remove the connection managers if nobody is using an
> account with them anymore.
>
> Thoughts/Bashings/Comments?
>
> --
> [MIR] empathy dependencies
> https://bugs.launchpad.net/bugs/388898
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
☮♥Ⓐ - http://www.google.com/profiles/danny.piccirillo

Martin Pitt (pitti) wrote :

Brian Curtis [2009-08-31 13:27 -0000]:
> Laurent/Martin/Ken
>
> I have found that a lot of people are disappointed that telepathy-idle
> is not installed by default when they try to move their IRC account from
> pidgin to empathy.

But it is now! :-)

It's actually curious that it doesn't work through -haze, I thought
libpurple had IRC support, too (at least the package description
claims that). But anyway, it's in ubuntu-desktop now for a few days.

Loïc Minier (lool) wrote :

No remaining active MIRs, I'm unsubscribing ~ubuntu-mir from the bug; please subscribe us again if there's something new to look at. Thanks!

Martin Pitt (pitti) wrote :
Changed in telepathy-butterfly (Ubuntu Karmic):
status: Incomplete → Fix Committed
Changed in gstreamer:
importance: Unknown → Undecided
status: Confirmed → New
Martin Pitt (pitti) wrote :

Closing gstreamer upstream task for this MIR bug

Changed in gstreamer:
status: New → Invalid
Martin Pitt (pitti) wrote :
Changed in papyon (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

telepathy-butterfly approved and promoted.

I'll upload empathy with the recommends re-added now.

Changed in telepathy-butterfly (Ubuntu Karmic):
status: Fix Committed → Fix Released
Laurent Bigonville (bigon) wrote :

Great! :)

What the status of gupnp-igd for main inclusion?

Martin Pitt (pitti) wrote :

Laurent Bigonville [2009-09-10 14:13 -0000]:
> What the status of gupnp-igd for main inclusion?

Ken said he'd talk to upstream today to figure out how this works. He
tried a local build, with the result that "this only serves to make it
fail faster". Still on the radar, though.

Changed in gupnp-igd (Ubuntu Karmic):
status: Incomplete → In Progress
Ken VanDine (ken-vandine) wrote :

MIR wiki page for gupnp-igd is at:

https://wiki.ubuntu.com/MainInclusionReport/Gupnpigd

Changed in gupnp-igd (Ubuntu Karmic):
status: In Progress → New
assignee: Ken VanDine (ken-vandine) → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

gupnp-igd fixed to run test suite on build, approved.

Changed in gupnp-igd (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

gssdp approved. Package has test programs, but they can't be run automatically and noninteractively, and require network, so they aren't suitable to run at build time.

Changed in gssdp (Ubuntu Karmic):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

gupnp approved and promoted (together with gssdp and gupnp-igd). Same test program situation as with gssdp.

Changed in gupnp (Ubuntu Karmic):
status: New → Fix Released
Changed in gssdp (Ubuntu Karmic):
status: Fix Committed → Fix Released
Brian Curtis (bcurtiswx) wrote :

Would it be too hard to get geoloc so it can be supported in Ubuntu?

On Sat, Sep 12, 2009 at 7:07 AM, Martin Pitt <email address hidden> wrote:
> gupnp approved and promoted (together with gssdp and gupnp-igd). Same
> test program situation as with gssdp.
>
> ** Changed in: gupnp (Ubuntu Karmic)
>       Status: New => Fix Released
>
> ** Changed in: gssdp (Ubuntu Karmic)
>       Status: Fix Committed => Fix Released
>
> --
> [MIR] empathy dependencies
> https://bugs.launchpad.net/bugs/388898
> You received this bug notification because you are a member of
> Telepathy, which is subscribed to telepathy-butterfly in ubuntu.
>
> --
> Ubuntu-telepathy mailing list
> <email address hidden>
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-telepathy
>

--
Research is what I'm doing when I don't know what I'm doing.
--Wernher Von Braun
"The second law of thermodynamics: If you think things are in a mess
now, JUST WAIT!!"
----------------------------------------------------------------
The Statement Below is True
The Statement Above is False
----------------------------------------------------------------

Ken VanDine (ken-vandine) wrote :

Not hard, but we aren't ready for that. Enabling geoclue in empathy will drag clutter onto the CD. Perhaps for karmic+1

Kẏra (kxra) wrote :

that's quite disappointing for people who want to use geoclue and will actively use the PPA to get it because most of our buddies won't have it =[

Brian Curtis (bcurtiswx) wrote :

Ok Kevin, Thats fine. Is there a place I can list to make sure
geoclue gets added to empathy for Karmic+1?

New bug?

~Brian

On Sat, Sep 12, 2009 at 6:24 PM, Ken VanDine <email address hidden> wrote:
> Not hard, but we aren't ready for that.  Enabling geoclue in empathy
> will drag clutter onto the CD.  Perhaps for karmic+1
>
> --
> [MIR] empathy dependencies
> https://bugs.launchpad.net/bugs/388898
> You received this bug notification because you are a member of
> Telepathy, which is subscribed to telepathy-butterfly in ubuntu.
>
> --
> Ubuntu-telepathy mailing list
> <email address hidden>
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-telepathy
>

--
Research is what I'm doing when I don't know what I'm doing.
--Wernher Von Braun
"The second law of thermodynamics: If you think things are in a mess
now, JUST WAIT!!"
----------------------------------------------------------------
The Statement Below is True
The Statement Above is False
----------------------------------------------------------------

Ken VanDine (ken-vandine) wrote :

File a new bug against the empathy package and we will mark it as wishlist. I would really like to enable it and I suspect there will be enough stuff needing clutter for karmic+1 that it won't be an issue.

It would be nice of some things like this could be an optional dep for empathy, like a plugin architecture. So it doesn't require uses get empathy from a ppa, just install the right plugin package to enable the feature.

Brian Curtis (bcurtiswx) wrote :

Kevin,

I mentioned this to some people before, but I don't have the skills
myself to write something like this, and I think it would benefit the
CD size too.

Just like using the music/video programs will tell you that you need a
codec and it will download it for you. I imagine doing something like
this for the telepathy connection managers (butterfly,haze,idle,
etc..) would take space off of the CD for other more important things.
 Maybe also resolve bugs in which someones CM isn't installed by
default with empathy.

Workflow:
-user installs empathy or creates new account
-code recognizes that user doesn't have telepathy-* and asks the user
to download applicable ones.
-upon removal of account package manager recognizes it's not used
anymore and upon next autoremove will delete the package.

~Brian

On Mon, Sep 14, 2009 at 1:22 PM, Ken VanDine <email address hidden> wrote:
> File a new bug against the empathy package and we will mark it as
> wishlist.  I would really like to enable it and I suspect there will be
> enough stuff needing clutter for karmic+1 that it won't be an issue.
>
> It would be nice of some things like this could be an optional dep for
> empathy, like a plugin architecture.  So it doesn't require uses get
> empathy from a ppa, just install the right plugin package to enable the
> feature.
>
> --
> [MIR] empathy dependencies
> https://bugs.launchpad.net/bugs/388898
> You received this bug notification because you are a member of
> Telepathy, which is subscribed to telepathy-butterfly in ubuntu.
>
> --
> Ubuntu-telepathy mailing list
> <email address hidden>
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-telepathy
>

--
Research is what I'm doing when I don't know what I'm doing.
--Wernher Von Braun
"The second law of thermodynamics: If you think things are in a mess
now, JUST WAIT!!"
----------------------------------------------------------------
The Statement Below is True
The Statement Above is False
----------------------------------------------------------------

Martin Pitt (pitti) on 2009-09-15
Changed in gupnp-igd (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.