Ubuntu

telepathy-butterfly crashed with AttributeError in on_addressbook_contact_added()

Reported by Guillaume Pascal on 2010-01-28
156
This bug affects 28 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly
Fix Released
Medium
telepathy-butterfly (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

Telepathy buterfly crash when I add a contact or add me in MSN protocol

ProblemType: Crash
Architecture: i386
Date: Thu Jan 28 19:43:04 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100127)
InterpreterPath: /usr/bin/python2.6
Package: telepathy-butterfly 0.5.4-1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.utf8
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with AttributeError in on_addressbook_contact_added()
Uname: Linux 2.6.32-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: removed: need-duplicate-check
Martin Albisetti (beuno) on 2010-02-02
visibility: private → public

Same error message when someone adds me to their messenger

Scott Shields (atomicspark) wrote :

I also get this error while trying to add a contact to MSN.

Ubuntu 10.04 x86_64

Telepathy buterfly crash when I add a contact or add me in MSN protocol

Orignal report: https://bugs.launchpad.net/ubuntu/+source/telepathy-butterfly/+bug/513922

This looks like a trivial typo.

I've fixed it in the branch in the URL field. Olivier, could you quickly review this please?

Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
Brian Curtis (bcurtiswx) wrote :

Thanks for your bug report and helping to make Ubuntu better. This bug is an upstream one and would be nice if someone having the bug can report this upstream at http://bugs.freedesktop.org.

Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Changed in telepathy-butterfly (Ubuntu):
status: Incomplete → New
description: updated
Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
Changed in telepathy-butterfly:
status: Unknown → Confirmed
Brian Curtis (bcurtiswx) wrote :

Marking as triaged as it has been pushed upstream

Changed in telepathy-butterfly (Ubuntu):
status: Confirmed → Triaged

Reviewed and merged, thanks for the patch

Changed in telepathy-butterfly:
status: Confirmed → Fix Released
Omer Akram (om26er) wrote :

changing to fix committed as its fixed upstream

Changed in telepathy-butterfly (Ubuntu):
status: Triaged → Fix Committed
Omer Akram (om26er) wrote :

marking this fixed as telepathy-butterfly 0.5.6 is in Lucid

Changed in telepathy-butterfly (Ubuntu):
status: Fix Committed → Fix Released
gero (tkd4) wrote :

i was adding a new contact, but I dint select a group, so a i pressed the "add" button and the error occurs...

Changed in telepathy-butterfly:
importance: Unknown → Medium
Changed in telepathy-butterfly:
importance: Medium → Unknown
Changed in telepathy-butterfly:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.