Ubuntu

missing feature: friendly names

Reported by Fibonacci on 2009-11-18
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly
Fix Released
Wishlist
empathy (Ubuntu)
Low
Unassigned
telepathy-butterfly (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

When chatting with an MSN group (e.g. those on http://groups.im/) on Empathy, I can't see the name of the members who write each message - I only see the name of the group.
WLM (of course), aMSN, emesene, and Mercury all display the right names on MSN groups. I don't know what the right name for this feature is, but emesene calls it "friendly names", so I'm sticking with that.

Fibonacci (fibonacci-prower) wrote :

Update: apparently this only happens when I am chatting offline. When chatting online friendly names are displayed.
Still, the fact remains that all other apps I mentioned support it.

Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Low
Fibonacci (fibonacci-prower) wrote :

My bad, actually friendly names don't show even when online.

When chatting with an MSN group (e.g. those on http://groups.im/) on Empathy, I can't see the name of the members who write each message - I only see the name of the group.
WLM (of course), aMSN, emesene, and Mercury all display the right names on MSN groups. I don't know what the right name for this feature is, but emesene calls it "friendly names", so I'm sticking with that.

This has also been reported on Launchpad: https://bugs.launchpad.net/ubuntu/+source/telepathy-butterfly/+bug/485017

Brian Curtis (bcurtiswx) wrote :

Thank you for your bug report and helping to make Ubuntu better. I am marking this as wishlist as it is such. It would be good if someone could push this bug to the developers upstream. This can be done at https://bugs.freedesktop.org/ .

Changed in telepathy-butterfly (Ubuntu):
importance: Low → Wishlist
status: New → Incomplete
Fibonacci (fibonacci-prower) wrote :

Perhaps you could tell me why you marked it as incomplete. What is this bug report missing?

Changed in telepathy-butterfly (Ubuntu):
status: Incomplete → New
Brian Curtis (bcurtiswx) wrote :

@ Fibonacci: It would be good if someone could push this bug to the developers upstream. This can be done at https://bugs.freedesktop.org/ . i said this in my previous comment.. That makes it incomplete.

Changed in telepathy-butterfly (Ubuntu):
status: New → Incomplete
Fibonacci (fibonacci-prower) wrote :
Changed in telepathy-butterfly (Ubuntu):
status: Incomplete → New
Brian Curtis (bcurtiswx) on 2009-11-25
Changed in telepathy-butterfly (Ubuntu):
status: New → Triaged
Changed in telepathy-butterfly:
status: Unknown → Confirmed

To quote the illustrious Youness Alaoui from the empathy bug:

> The problem is that it's not the nickname that's being used in aMSN, it's the
> 'Friendly name'.. MSN has the ability to specify a "friendly name" *per
> message*.. this allows people to have huge ascii-art nicknames that do not
> bloat the chat windows when chatting. That's also what groups.im uses, I can
> confirm.
> This "Friendly name" is sent as a header in the message, the header is called
> "P4-Context". papyon supports it and sets it as the message.display_name on the
> event on_conversation_message_received.
> Telepathy-butterfly does not support it though.

There's currently no way to expose a new alias per message in the spec. I opened bug #27568 about this.

We don't actually have to wait for the spec change to go through and get released because that's just a list of "well-known keys".

Check out my patch.

Looks good to me.

Merged, this fix is available in butterfly 0.5.10
Note it won't work in empathy as of now since it rely on the Messages interface which is not yet implemented

Changed in telepathy-butterfly (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the telepathy-butterfly issue is fixed but it will changes in empathy as well

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the new version is in maverick as well now

Changed in telepathy-butterfly (Ubuntu):
status: Fix Committed → Fix Released
Kamus (kamus) wrote :

@Fibonnaci, could you test if this behaviour is fixed in latest release of empathy included in Ubuntu Maverick? Because according to Sebastien comments this is solved.

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
Fibonacci (fibonacci-prower) wrote :

I haven't upgraded to Maverick yet. How can I test the program without upgrading my whole system?

Brian Curtis (bcurtiswx) wrote :

Since this is a bug in butterfly I am closing the empathy task. The butterfly issue is fixed in maverick.

Changed in empathy (Ubuntu):
status: Incomplete → Invalid
Changed in telepathy-butterfly:
importance: Unknown → Wishlist
status: Confirmed → Fix Released
Franklin (franklin-goodhorse) wrote :

I'm using empathy 2.30.2, telepathy-butterfly-0.5.11 installed from Mandriva packages.

However, this problem still occurred. I could not tell who were talking in the MSN group chat.

Glauco (glauco-hass) wrote :

Still present in empathy 2.32.0.1 and telepathy-butterfly-0.5.14-1, Ubuntu 10.10. No P4-Context support at all.

Changed in telepathy-butterfly:
importance: Wishlist → Unknown
Changed in telepathy-butterfly:
importance: Unknown → Wishlist

I can confirm this issue as well, Friendly Names aren't displayed at all.

Brian Curtis (bcurtiswx) wrote :

butterfly has had a lot of work for Natty, could someone having this issue please test this on Natty to see if this is still an issue?

Fibonacci (fibonacci-prower) wrote :

This is still an issue.

Still happening in Natty.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.