[FFE] Please merge telepathy-butterfly 0.5.2-1 (universe) from Debian unstable (main).

Bug #437828 reported by Devid Antonio Filoni on 2009-09-27
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly (Ubuntu)
Low
Ken VanDine
Karmic
Low
Ken VanDine

Bug Description

Binary package hint: telepathy-butterfly

Please merge telepathy-butterfly 0.5.1-1 (universe) from Debian unstable (main).

==================== CHANGELOG: ====================

telepathy-butterfly (0.5.1-1ubuntu1) karmic; urgency=low

  * Merge from Debian unstable, remaining Ubuntu change:
    - debian/patches/001_lp410376_python_syntax.patch: fix syntax error
      that breaks package upgrade/install.

 -- Devid Antonio Filoni <email address hidden> Sun, 27 Sep 2009 22:05:13 +0200

telepathy-butterfly (0.5.1-1) unstable; urgency=low

  * New upstream release (Closes: #526376)
  * debian/control:
    - Bump python-telepathy version
    - Bump papyon version
    - Add the fact that telepathy-butterfly supports audio/video chat \o/

 -- Laurent Bigonville <email address hidden> Tue, 15 Sep 2009 12:07:19 +0200

telepathy-butterfly (0.5.0-1) unstable; urgency=low

  * New upstream release
  * debian/control:
    - Bump Standards-Version to 3.8.3 (no further changes)
    - Replace python-msn by python-papyon
    - Bump python-telepathy version
    - Bump debhelper version
    - Bump minimal python version to 2.5

 -- Laurent Bigonville <email address hidden> Mon, 17 Aug 2009 13:35:49 +0200

==================== UPSTREAM CHANGELOG: ====================

telepathy-butterfly-0.5.1 (14-09-2009)
======================================

The "if you look real closely you can see the butterflies mating" release.

Dependencies:
 * python 2.5
 * papyon 0.4.2
 * telepathy-python 0.15.11

Enhancements:
 * Add support for audio/video conferences
 * Implement the Debug interface

Fixes:
 * Don't add a contact to the publish and subscribe lists at the same time

==================== INSTALL LOG (in Italian): ====================

dfiloni@dfiloni-desktop:~$ sudo dpkg -i '/home/dfiloni/Scrivania/Development/result/telepathy-butterfly_0.5.1-1ubuntu1_all.deb'
[sudo] password for dfiloni:
(Lettura del database... 124610 file e directory attualmente installati.)
Preparativi per sostituire telepathy-butterfly v.0.5.0-0ubuntu2 (utilizzando .../telepathy-butterfly_0.5.1-1ubuntu1_all.deb)...
Estrazione del sostituto di telepathy-butterfly...
Configurazione di telepathy-butterfly (0.5.1-1ubuntu1)...

dfiloni@dfiloni-desktop:~$

==================== BUILD LOG: ====================

Attached.

==================== COMMENTS: ====================

This new upstream version AFAIK fixes two bugs reported in launchpad: #333675 and #427087 . Please note that video/audio call support is one of the most requested MSN features as you can see at the following links:
http://brainstorm.ubuntu.com/idea/164/
http://brainstorm.ubuntu.com/idea/11685/
https://bugs.edge.launchpad.net/ubuntu/+source/pidgin/+bug/127861
In order to get it working we will need to add python-gst0.10 and python-farsight to papyon dependencies. I think we should have this feature in karmic in order to properly test and fix it in karmic+1 which will be an LTS.
See the following blog post for some screenshots: http://cass.no-ip.com/~cassidy/blog/index.php/post/2009/09/14/MSN-audio/video-chat-in-Telepathy

About the new debug interface: I think it is really useful in order to get good bug reports from users.

Devid Antonio Filoni (d.filoni) wrote :
Devid Antonio Filoni (d.filoni) wrote :
Devid Antonio Filoni (d.filoni) wrote :
Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
summary: - Please merge telepathy-butterfly 0.5.1-1 (universe) from Debian unstable
- (main).
+ [FFE] Please merge telepathy-butterfly 0.5.1-1 (universe) from Debian
+ unstable (main).

Unsubscribing archive admins, nothing to do for them here.

This is very intrusive, so I don't want to rush it into beta. Given how many problems jabber A/V still causes, this should be tested a bit before it goes into karmic.

Can you please upload this into a PPA (feel free to use ~ubuntu-desktop) and ask on ubuntu-devel@ and #ubuntu-desktop, blog posts, etc. for testing feedback? Feedback should preferably happen here, but on u-devel@ it's ok as well.

Thanks!

Devid Antonio Filoni (d.filoni) wrote :

I cannot upload to ubuntu-desktop PPA but there is a package in the telepathy PPA so we can probably test it, what do you think?

Devid Antonio Filoni [2009-09-28 13:12 -0000]:
> I cannot upload to ubuntu-desktop PPA but there is a package in the
> telepathy PPA so we can probably test it, what do you think?

Sure, that sounds fine. Can you please send out a call for testing?

I just tried this with my fiancée, she is running Vista with the latest client while I am on the latest Karmic plus the telepathy-ppa using empathy.

 I have forwarded ports 6890-6900 (both tcp and udp as this was not specified) as requested in the mail. Upon sending the invite my webcam is visible but once she accepts it disappears and she reports that I am not visble on her end. I can see her though and the video feed is perfect no glitches or lag.

There also seems to be no way to request only a webcam, you get voice like it or not. Since my workflow normally is having her on skype via a Nokia n810 so I can talk to her while I do my daily chores around the house, this is mildly annoying.

I think your problem is caused by the official client bug, please take a look at http://www.amsn-project.net/forums/viewtopic.php?t=6412 for more infos about that.

I doubt it, it works with aMSN and I did forward the ports for testing as is described as a workaround for the official client issue.

Does aMSN work with the same contact?

Absolutely, the only difference is that aMSN is forwarded to 61000 and telepathy as requested gets 6890-6900. 1863 is also forwarded to this machine.

@David: can you try forwarding ports 1025 to 1035?

(TCP)

I did that and tested with the same result (actually a bit worse since this time I didn't get a live feed back on a still image). I wasn't with the same contact but this one likewise is on the latest MSN client according to him at least. I don't know if that invalidates the test.

Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Wishlist
Steve Langasek (vorlon) wrote :

Setting back to new, as the FFe hasn't been granted and information gathering appears to still be in progress.

Changed in telepathy-butterfly (Ubuntu):
status: Confirmed → New

In this new package A/V support is disabled.

Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Setting back to New /again/, the Confirmed state on FFe bugs is reserved for FFes that have been /granted/ by the release team.

Changed in telepathy-butterfly (Ubuntu):
status: Confirmed → New
Ken VanDine (ken-vandine) wrote :

I think we should merge from debian, 0.5.1 adds the debug hooks which allows us to actually get logs and fixes bugs. I haven't decided if we should apply the patch to completely disable AV, trying to test that now myself.

Ken VanDine (ken-vandine) wrote :

OK, after some testing we should apply that disable AV patch. 0.5.1 is an improvement over 0.5.0, and the addition of debug hooks makes it well worth the update. The latest diff attached to this bug should be good to apply, the one that includes 002_disable_a-v_support.patch

tgpraveen (tgpraveen89) wrote :

@Ken
just to inform you that telepathy-butterfly 0.5.2 has also been recently released, which brings in offline messaging support which many people have been asking for, as well as fixing a few crashers.

http://lists.freedesktop.org/archives/telepathy/2009-October/003946.html

Ken VanDine (ken-vandine) wrote :

Yeah, I discussed that with istaz on irc this morning, if we are disabling AV anyway it doesn't seem to be worth updating to 0.5.2.

Ken VanDine (ken-vandine) wrote :

After further discussion with istaz, we should update to 0.5.2. Prior to 0.5.2, if msn messages are sent while you are offline, you lose them and the sender will assume you received them.

OK for updating if A/V stays disabled, too intrusive after RC (!).

Please get this uploaded to unapproved ASAP, so that we can kick it
into Karmic on Friday. Thanks!

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Ken VanDine (ken-vandine) wrote :

This updated to 0.5.2

Changed in telepathy-butterfly (Ubuntu):
milestone: none → ubuntu-9.10
Martin Pitt (pitti) wrote :

Uploaded, waiting in unapproved now. Will be accepted post-RC.

The diff is quite large because this also adds audio/video support, but this got disabled in a patch for karmic, since it's too late. Ken tested this, and it's much more robust than the previous version. He also confirmed that A/V support is disabled.

summary: - [FFE] Please merge telepathy-butterfly 0.5.1-1 (universe) from Debian
+ [FFE] Please merge telepathy-butterfly 0.5.2-1 (universe) from Debian
unstable (main).
Changed in telepathy-butterfly (Ubuntu Karmic):
status: New → Fix Committed
importance: Wishlist → Low
assignee: nobody → Ken VanDine (ken-vandine)
Laurent Bigonville (bigon) wrote :

FYI the debian package will be uploaded this evening (CEST)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-butterfly - 0.5.2-0ubuntu1

---------------
telepathy-butterfly (0.5.2-0ubuntu1) karmic; urgency=low

  * New upstream release (LP: #437828)
    - offline messages no longer get lost
  * debian/patches/001_lp410376_python_syntax.patch
    - Updated to apply to 0.5.2
  * debian/patches/002_disable_a-v_support.patch
    - Updated to apply to 0.5.2

 -- Ken VanDine <email address hidden> Tue, 20 Oct 2009 10:33:53 -0400

Changed in telepathy-butterfly (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers