OIM not supported but present in python-msn

Bug #382500 reported by Nicolò Chieffo on 2009-06-01
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly
Fix Released
Wishlist
telepathy-butterfly (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

Offline messages are supported in python-msn but there's no wrapper in telepathy-glib.
The same for chatting with invisible users.
This will be a regression when the switch pidgin->empathy will happen.

Upstream does not seem much interested in msn bugs, so I hope canonical developers will work on it.

ProblemType: Bug
Architecture: amd64
Date: Mon Jun 1 20:07:09 2009
DistroRelease: Ubuntu 9.10
Package: telepathy-butterfly 0.3.3-2
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-6.7-generic
SourcePackage: telepathy-butterfly
Uname: Linux 2.6.30-6-generic x86_64

Reading the pymsn feature list here http://telepathy.freedesktop.org/wiki/Pymsn it seems that offline messages are already supported.

Shhould we close this bug? or does telepathy-butterfly have to add support for them too?

Well, do they work in Butterfly? If so, the bug is fixed; if not, it is not!

Simply, how can I test it?
I only know empathy as a way to test telepathy, but empaty does not let to open chat windows with offline (or apparently offline) users

Sure it does! Show offline contacts, and then double click one.

If that doesn't work, then butterfly is broken.

Double click does nothing. (empathy 2.26)
in empathy 2.27.1 everyone is always shown as offline, so I don't know if it is an empathy bug.

the telepathy-butterfly version is 0.3.3 which is dated 6 Jan 2009
the pymsn version is 0.3.3 which is dated 05-Aug-2008

I can't find the telepathy-butterfly webpage, because I would like to see what it is currently supported.

Nicolò Chieffo (yelo3) wrote :

Binary package hint: telepathy-butterfly

Offline messages are supported in python-msn but there's no wrapper in telepathy-glib.
The same for chatting with invisible users.
This will be a regression when the switch pidgin->empathy will happen.

Upstream does not seem much interested in msn bugs, so I hope canonical developers will work on it.

ProblemType: Bug
Architecture: amd64
Date: Mon Jun 1 20:07:09 2009
DistroRelease: Ubuntu 9.10
Package: telepathy-butterfly 0.3.3-2
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-6.7-generic
SourcePackage: telepathy-butterfly
Uname: Linux 2.6.30-6-generic x86_64

Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) on 2009-06-02
tags: added: transition-regression
removed: amd64 apport-bug

Don't you think we should raise the priority in order to achieve feature parity with pidgin?

Changed in telepathy-butterfly:
status: Unknown → Confirmed

This is effectively a problem with Butterfly not supporting OIM and so refusing to open a channel with disconnected users.

Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Low
status: New → Triaged

I don't think it's LOW because in this way you loose messages, since
offline messages are not delivered to you, you can miss something
important.

*** Bug 23574 has been marked as a duplicate of this bug. ***

What's the status of this branch? I had a little look at it and it looked okay. It'd be cool if Louis-Francis could take a look though.

It'd be nice to get this merged.

Merged into master :)

Changed in telepathy-butterfly:
status: Confirmed → Fix Released

Fixed in 0.5.2 which is packaged in karmic

Changed in telepathy-butterfly (Ubuntu):
status: Triaged → Fix Released
Changed in telepathy-butterfly:
importance: Unknown → Wishlist
Changed in telepathy-butterfly:
importance: Wishlist → Unknown
Changed in telepathy-butterfly:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.