telepathy-butterfly crashed with NameError in on_conversation_nudge_received()

Bug #274400 reported by K. Aning on 2008-09-25
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly
Fix Released
Medium
telepathy-butterfly (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

Apparently I was nudged by someone on MSN

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InterpreterPath: /usr/bin/python2.5
Package: telepathy-butterfly 0.3.2-1
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with NameError in on_conversation_nudge_received()
Uname: Linux 2.6.27-4-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

K. Aning (constrictor) wrote :
visibility: private → public

This bug was originally reported by K. Aning on Launchpad (see URL).

"Apparently I was nudged by someone on MSN"

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pymsn/switchboard_manager.py", line 365, in _sb_message_received
    handler._on_message_received(message)
  File "/usr/lib/python2.5/site-packages/pymsn/conversation.py", line 374, in _on_message_received
    self._dispatch("on_conversation_nudge_received", sender)
  File "/usr/lib/python2.5/site-packages/pymsn/event/__init__.py", line 44, in _dispatch
    if event_handler._dispatch_event(name, *args):
  File "/usr/lib/python2.5/site-packages/pymsn/event/__init__.py", line 65, in _dispatch_event
    handler(*params)
  File "/usr/lib/python2.5/site-packages/butterfly/channel/text.py", line 121, in on_conversation_nudge_received
    text = unicode(_("sends you a nudge"), "utf-8")
NameError: global name '_' is not defined

Dev note :
I don't even know why we are passing it to _() since we don't use gettext at all. Easy fix

Thanks for your bug report. It's still present in telepathy-butterfly so I will forward it upstream

Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
Changed in telepathy-butterfly:
status: Unknown → Confirmed

CM are not supposed to contain translatable strings.

Created an attachment (id=27186)
nudge.patch

if so it's a simple patch

Nicolò Chieffo (yelo3) wrote :

this patch fixes it, I've also forwarded it upstream

Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

Thanks for your patch Nicolò, it has been merged in master

Merged upstream in master, thanks Nicolò

Changed in telepathy-butterfly:
status: Confirmed → Fix Released

Fixed in telepathy-butterfly 0.5.1

Changed in telepathy-butterfly (Ubuntu):
status: Triaged → Fix Released
Changed in telepathy-butterfly:
importance: Unknown → Medium
Changed in telepathy-butterfly:
importance: Medium → Unknown
Changed in telepathy-butterfly:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.