Apps don't use Wayland by default

Bug #1916469 reported by Max Vincent Goldgamer
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Olivier Tilloy
qdirstat (Ubuntu)
Undecided
Unassigned
telegram-desktop (Ubuntu)
Undecided
Unassigned
thunderbird (Ubuntu)
Medium
Olivier Tilloy

Bug Description

The Ubuntu universe has a big Wayland problem!

What does that mean?

So a lot of packages in the Universe repository are not compiled with Wayland support which is really bad and would lead to bad performance after 21.04 comes out.

Here are the following packages that I detected with wrong compilation:

telegram-desktop (Wayland support work with snap version)
kiwix
firefox (everything works fine with this env variable set:"MOZ_ENABLE_WAYLAND=1")

tags: added: wayland
tags: added: hirsute
Changed in ubuntu:
status: New → Confirmed
status: Confirmed → New
description: updated
Revision history for this message
Bernard Stafford (bernard010) wrote :
no longer affects: ubuntu
summary: - Ubuntu universe Wayland problem
+ Apps don't use Wayland by default
no longer affects: wayland (Ubuntu)
tags: added: wayland-session
Changed in firefox (Ubuntu):
status: New → Confirmed
description: updated
Changed in vlc (Ubuntu):
status: New → Invalid
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Looks like Chromium has bug 1897454 for this.

no longer affects: chromium-browser (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qdirstat (Ubuntu):
status: New → Confirmed
Changed in telegram-desktop (Ubuntu):
status: New → Confirmed
Revision history for this message
Olivier Tilloy (osomon) wrote :
Changed in firefox (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 87.0+build3-0ubuntu2

---------------
firefox (87.0+build3-0ubuntu2) hirsute; urgency=medium

  * Enable native Wayland support (LP: #1916469)
    - debian/firefox.sh.in

 -- Olivier Tilloy <email address hidden> Fri, 26 Mar 2021 18:22:24 +0100

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
Changed in thunderbird (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
importance: Undecided → Medium
Revision history for this message
Olivier Tilloy (osomon) wrote :
Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Olivier Tilloy (osomon)
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Olivier: what does this change imply? I'm asking since it's past FF, and it's hard for me to say if this falls under the brackets of a feature or not.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Łukasz: this change makes firefox (and thunderbird) a native Wayland client application when run under Wayland, as opposed to using XWayland. Functionally, there shouldn't be any difference, but visual/perceived performance should be better.

Revision history for this message
Iain Lane (laney) wrote :

It does seem like it requires a feature freeze exception, but we should do it, so I'll accept.

Revision history for this message
Paweł Drewniak (woody) wrote :

Setting MOZ_ENABLE_WAYLAND=1 on Firefox 87.0 breaks WebGL on Xorg sessions: see bug 1923116.

Mathew Hodson (mhodson)
no longer affects: vlc (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 1:78.11.0+build1-0ubuntu2

---------------
thunderbird (1:78.11.0+build1-0ubuntu2) impish; urgency=medium

  * Reduce the rust optimization level on ppc64el to fix FTBFS (LP: #1923505)
    - debian/patches/reduce-rust-optlevel-on-ppc64el.patch

 -- Olivier Tilloy <email address hidden> Tue, 01 Jun 2021 22:52:36 +0200

Changed in thunderbird (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

^^^
Sounds confusing, but it is true. This bug fix is included from previously unreleased version:

https://launchpad.net/ubuntu/+source/thunderbird/1:78.9.0+build2-0ubuntu2

Revision history for this message
corrado venturini (corradoventu) wrote :

FF 91.0a1 started in Wayland session uses Xwayland instead wayland
environment variable MOZ_ENABLE_WAYLAND=1 is automatically added in FF 89 when started in Wayland session but NOT added for FF 91.0a1

Revision history for this message
Rico Tzschichholz (ricotz) wrote :

@corradoventu I have checked and ran firefox-trunk (91.0~a1~hg20210613r582921-0ubuntu0.20.04.1~umd1) in a ubuntu-wayland session on Ubuntu 20.04/Focal and it runs natively as expected.

Revision history for this message
corrado venturini (corradoventu) wrote (last edit ):

On my PC I have 6 partitions with different Ubuntu releases (with or without proposed) and Firefox behaves differently
Ubuntu 89.0.1 91.0a1
x2-impish-0615 5.11.0-18-generic wayland xwayland
x3-groovy 5.8.0-55-generic xwayland xwayland
x4-focal 5.8.0-55-generic xwayland xwayland
x5-hippo-x 5.11.0-18-generic wayland xwayland
x6-impish-0501 5.11.0-18-generic wayland xwayland
x7-hippo 5.11.0-18-generic wayland xwayland
My hardware:
corrado@corrado-x2-ii-0615:~$ inxi -CG
CPU:
  Info: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP
  L2 cache: 3 MiB
  Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800
Graphics:
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Device-2: ARC USB 2.0 Camera type: USB driver: uvcvideo
  Display: wayland server: X.Org 1.21.1.1 driver: loaded: i915
  note: n/a (using device driver) resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.1.0
corrado@corrado-x2-ii-0615:~$

Revision history for this message
corrado venturini (corradoventu) wrote :

Also starting in troublesooting mode I see Xwayland instead Wayland
attached: text from about:support in troublesooting mode

Revision history for this message
errogaht (7018407-o) wrote :

Boycott Wayland!
Just tried another time to work with Wayland! as i tried it each time previous years.
NOT WORKINK EVERYWHERE.
IDEA - NOT WORKING with fractional scaling with 2 displays - blurry
CHROME - blurry out of the box
ENDLESS popups about "app wants inhibit shortcuts wayland"
xfce terminal is NOT working.
Don't use wayland.

Revision history for this message
Daniel van Vugt (vanvugt) wrote (last edit ):

errogaht,

That comment is probably not helpful, borderline trolling, and reported in the wrong place. Here are some tips:

> IDEA - NOT WORKING with fractional scaling with 2 displays - blurry

You should track that in https://youtrack.jetbrains.com/issue/IDEA-218458

> CHROME - blurry out of the box

The latest releases are sharp at high DPI on Wayland out of the box. It only gets blurry if you enable fractional scaling because Chrome is still using X11 by default (bug 1897454). It becomes sharp again even with fractional scaling, if you start Chrome with Wayland support:

  google-chrome --enable-features=UseOzonePlatform --ozone-platform=wayland

> ENDLESS popups about "app wants inhibit shortcuts wayland"

Never seen or heard of that problem. Please open a new bug.

> xfce terminal is NOT working.

The official bug list suggests it does work already, but with some issues. Please report any problems to https://gitlab.xfce.org/apps/xfce4-terminal/-/issues

Revision history for this message
Tim Passingham (tim-8aw3u04umo) wrote (last edit ):

This is still buggy.

Every time there's a new ubuntu release of Thunderbird (now on 91.3.1) I have to repatch /usr/lib/thunderbird/thunderbird.sh and comment out "export MOZ_ENABLE_WAYLAND=1"

See https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1932328

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Comment #20 really is irrelevant here. Please subscribe to bug 1932328 instead.

Revision history for this message
Andrea (mario-futire) wrote :

I disagree with #21. Ubuntu should disable WAYLAND for thunderbird until it is ready to be used.

The problem has existed for a log time and nobody seems to "own" it (Ubuntu? Gnome? Thunderbird?), redirecting users to some other bug report, and nothing changes.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Most Ubuntu users stick to the default session type which is now Wayland. And most Ubuntu users probably never open Thunderbird. So the subset of users affected by bug 1932328 is small compared to the overall set size (millions?). A fix is committed for bug 1932328 and coming in the next update.

We've been focussed on and discussing this issue for several years now, waiting for the right time to default to Wayland. We waited longer than other distros and made the switch in the April 2021 release. Asking to change it back for one Thunderbird bug makes no sense.

Aside from anything else, you can just choose Xorg on the login screen if you don't like the Wayland session. Change it once and your choice is remembered. You will never see Wayland again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions