Package out of date

Bug #1823299 reported by Mattia on 2019-04-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
telegram-desktop (Ubuntu)
Undecided
Unassigned

Bug Description

The package is very out of date. There are missing features and bugfixes, especially the ability to visualize and make polls.

Mattia (io-mattia98) wrote :
Graham Inggs (ginggs) wrote :

Which version of Ubuntu are you using?

You can try switching from the packaged version to the snap version:
https://snapcraft.io/telegram-desktop
It can be updated more frequently.

Mattia (io-mattia98) wrote :

It happens on 18.04 and 18.10.

Nicholas Guriev (mymedia) wrote :

These Ubuntu series have already been released and have frozen repositories, no new versions will be uploaded there. But you can try to use my PPA with backports of the telegram-desktop package and those related to it.

https://launchpad.net/~mymedia/+archive/ubuntu/telegram

Gavan Fantom (gavanfantom) wrote :

Telegram-desktop (as currently in Ubuntu 18.04) is now showing popups telling the user that their software is out of date and that they should upgrade.

Nicholas Guriev (mymedia) wrote :

That popup message is coming with updateServiceNotification from Telegram backend.

[23:58:28.811 01-0001754] (dc:2) Recv: { core_message
  msg_id: 6753703395900790785 [LONG],
  seq_no: 85 [INT],
  bytes: 184 [INT],
  body: { updates
    updates: [ vector<0x0>
      { updateServiceNotification
        flags: 1 [INT],
        popup: YES [ BY BIT 0 IN FIELD flags ],
        inbox_date: [ SKIPPED BY BIT 1 IN FIELD flags ],
        type: "API_ERROR_UPDATE_UNOFFICIAL" [STRING],
        message: "Error. Please update your app to the latest version or switch to the official version of Telegram." [STRING],
        media: { messageMediaEmpty },
        entities: [ vector<0x0> ],
      },
    ],
    users: [ vector<0x0> ],
    chats: [ vector<0x0> ],
    date: 1572469107 [INT],
    seq: 1774 [INT],
  },
}

I believe we are able to backport a new version to Bionic Beaver. At least v1.8.15 is successfully compiled against Qt 5.9.5 and FFmpeg 3.4.6. Moreover, we could provide a new version via the bionic-updates repository like Firefox or Thunderbird get updates

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telegram-desktop (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments