application doesn't start

Bug #1797801 reported by marneu on 2018-10-14
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
telegram-desktop (Ubuntu)
Undecided
Unassigned

Bug Description

I tried starting the application from both my app launcher and a terminal. When I ran "telegram-desktop" in my terminal,the only thing it did was printing the following:

$ telegram-desktop
QEventLoop: Cannot be used without QApplication

(telegram-desktop:3625): GLib-GObject-WARNING **: 22:07:57.298: cannot register existing type 'GdkDisplayManager'

(telegram-desktop:3625): GLib-CRITICAL **: 22:07:57.298: g_once_init_leave: assertion 'result != 0' failed

(telegram-desktop:3625): GLib-GObject-CRITICAL **: 22:07:57.298: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

It doesn't exit, and htop shows that it doesn't have any CPU use.

The snap version works fine.

---

Additional system information:

- VirtualBox VM
- 3D acceleration disabled
- i3-wm

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: telegram-desktop 1.4.0-1
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: LXQt
Date: Sun Oct 14 22:08:25 2018
InstallationDate: Installed on 2018-10-14 (0 days ago)
InstallationMedia: Lubuntu 18.10 "Cosmic Cuttlefish" - Beta amd64 (20181013)
SourcePackage: telegram-desktop
UpgradeStatus: No upgrade log present (probably fresh install)

marneu (marneu) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telegram-desktop (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers