[apport] tegrobot crashed with SIGSEGV

Bug #82770 reported by Conrad Knauer on 2007-02-02
4
Affects Status Importance Assigned to Milestone
teg (Ubuntu)
Medium
MOTU

Bug Description

Binary package hint: teg

Just using TEG and Ubuntu informed me that part of it crashed.

ProblemType: Crash
Date: Thu Feb 1 18:49:18 2007
Dependencies:

ExecutablePath: /usr/games/tegrobot
Package: teg 0.11.1-3ubuntu5
ProcCmdline: /usr/games/tegrobot --connected
ProcCwd: /home/conrad
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: teg
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
UserGroups: adm admin audio cdrom dialout dip fax floppy lpadmin plugdev scanner tape video

Vassilis Pandis (pandisv) wrote :

Any idea on how to reproduce this?

Emmet Hikory (persia) wrote :

Could you please attach the original crash report file? I'm having difficulty retracing the bug with the unpacked files.

Changed in teg:
status: Unconfirmed → Needs Info
Conrad Knauer (atheoi) wrote :

Not really :) Basically what happened was that there two computer players and myself left and one of them was going to win when their robot crashed. Which was convenient because I was able to beat the other robot without too much trouble ;) I seem to recall this occasionally happening before when the round number got high (like over 30 or something) and the computer player had a lot more armies than I did. You might want to set the status to 'needs info' or such.

Conrad Knauer (atheoi) wrote :

Emmet: sure, here you go :)

Sorry that the info posted wasn't overly usable; I just let Ubuntu do its thing. You might want to file a bug on that ;)

Emmet Hikory (persia) wrote :

Thank you. The uploaded data is by spec: I just don't know how to use it yet :).

Changed in teg:
status: Needs Info → Unconfirmed
Daniel Holbach (dholbach) wrote :

Thanks for your bug report.

Changed in teg:
assignee: nobody → motu
importance: Undecided → Medium
Daniel Holbach (dholbach) wrote :

Does this still happen to you? Can you attach a newer crash report by any chance?

Changed in teg:
status: Unconfirmed → Needs Info
Conrad Knauer (atheoi) wrote :

It took a while, but I managed to get in a game where I was playing against two computer-controlled opponents and we were in a bit of a stalemate; at round 38 one of the tegrobots crashed (perhaps when one of the robots traded in some cards? but that might be a red herring). I'm attaching the crash report.

Conrad Knauer (atheoi) wrote :

Oh and BTW, teg opens a terminal window and here was the output from when the one tegrobot crashed:

---
teg v0.11.1 server - by Ricardo Quesada

Bound to port: 2000
Using seed: 891729238

Type 'metaserver on' to publish this server in the metaserver
Type 'help' for more help
> Using client version: TEG client version 0.11.1
> Player conrad(0) is connected from ..ffff.127.0.0.1
> Player conrad(0) has color blue
> Launching robot with options: /usr/games/tegrobot --connected
> Using client version: TEG client version 0.11.1
> Player Tehuelche(1) is connected from 127.0.0.1
> TEG server version 0.11.1
Player Tehuelche(1) has color green
> Launching robot with options: /usr/games/tegrobot --connected
> Using client version: TEG client version 0.11.1
> Player Clinton(2) is connected from 127.0.0.1
> TEG server version 0.11.1
Player Clinton(2) has color red
> Launching robot with options: /usr/games/tegrobot --connected
> Using client version: TEG client version 0.11.1
> Player Gaturro(3) is connected from 127.0.0.1
> TEG server version 0.11.1
Player Gaturro(3) has color pink
> Launching robot with options: /usr/games/tegrobot --connected
> Using client version: TEG client version 0.11.1
> Player Batistuta(4) is connected from 127.0.0.1
> TEG server version 0.11.1
Player Batistuta(4) has color yellow
> Launching robot with options: /usr/games/tegrobot --connected
> Using client version: TEG client version 0.11.1
> Player Spice Girls(5) is connected from 127.0.0.1
> TEG server version 0.11.1
Player Spice Girls(5) has color black
> Setting conquer_world variable to: TRUE -> TRUE
Setting fog_of_war variable to: FALSE -> FALSE
Setting common_mission variable to: TRUE -> FALSE
'armies' variable is set to: (5,3)
Starting game number: 0 with seed: 891729238
> Player Batistuta(4) lost the game
> Player Clinton(2) lost the game
> Player Spice Girls(5) lost the game
> Player Tehuelche(1) quit the game
> uncountryelibre(down): Abnormal error
uncountryelibre(down): Abnormal error

Conrad Knauer (atheoi) wrote :

I just finished playing to the end, wiping out the green (crashed tegrobot) first and then the remaining working one. Here's the rest of the terminal output from that:

Player Tehuelche(1) lost the game
> Player Gaturro(3) lost the game
> Player conrad(0) is the winner! Game Over
>

Conrad Knauer (atheoi) wrote :

I got into another game where tegrobot crashed and it ended the same way, though this time there was nothing on the terminal output to indicate it. I did note again that the tegrobot that crashed appeared to have just cashed in some cards and it was after quite a few rounds.

Conrad Knauer (atheoi) wrote :

I got it to crash again :) Pretty much the same conditions too; three players and the dominant player in a late round (29 iiRC) with lots of armies after probably trading in cards suddenly 'quits the game'. Thinking about it, as I recall its crashed before when there were just two players (me and the computer) and that manifests itself as a sudden 'you won' message.

Conrad Knauer (atheoi) wrote :

One final crash log attachment, which happened after Feisty was released; hopefully this will get fixed in Gutsy! :)

Emmet Hikory (persia) wrote :

This is clearly a reproducible crash (although I'm not sure of the cause). I'm not sure what further information is required to justify a "Needs Info" status.

Changed in teg:
status: Needs Info → Unconfirmed
Emmet Hikory (persia) on 2007-10-08
Changed in teg:
status: New → Confirmed
Conrad Knauer (atheoi) wrote :

Since upgrading to Gutsy, then Hardy and now Intrepid, this bug hasn't bitten me again and since no one else seems to be getting bit by this bug, I'm going to mark it as Invalid. I will reopen if it bites again :)

Changed in teg:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers