[PATCH] tcsh-6.17.06-2 $COLUMNS $LINES not set

Bug #546032 reported by B Bobo on 2010-03-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tcsh (Debian)
Fix Released
Unknown
tcsh (Ubuntu)
Low
B Bobo

Bug Description

Environment variables COLUMNS and LINES are not set at all in /etc/csh.* files.
Patches attached and confirmed to work on Ubuntu Precise 12.04.

Related branches

B Bobo (yout-bobo123) wrote :
tags: added: environment tcsh-6.14.00
B Bobo (yout-bobo123) wrote :

patch 2

Changed in linuxmint:
assignee: nobody → B Bobo (yout-bobo123)
status: New → Fix Released
Changed in ubuntu:
status: New → Fix Released
assignee: nobody → B Bobo (yout-bobo123)
B Bobo (yout-bobo123) on 2010-03-24
Changed in linuxmint:
status: Fix Released → In Progress
Changed in ubuntu:
status: Fix Released → In Progress
Changed in linuxmint:
status: In Progress → New
Changed in ubuntu:
status: In Progress → New
tags: added: patch
Philip Muškovac (yofel) wrote :

Assigning to tcsh.

affects: ubuntu → tcsh (Ubuntu)
Changed in linuxmint:
status: New → Triaged
Philip Muškovac (yofel) wrote :

Reported to Debian.

tags: added: patch-forwarded-debian
Changed in tcsh (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in tcsh (Debian):
status: Unknown → New
Philip Muškovac (yofel) on 2010-05-08
tags: removed: patch
Lucas Nussbaum (lucas) wrote :

fixed in the debian git tree

Changed in tcsh (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tcsh - 6.17.02-3

---------------
tcsh (6.17.02-3) unstable; urgency=low

  * Re-add 12_unknown_lscolors.patch. Closes segfault when removed.
    Closes: #592089.

tcsh (6.17.02-2) unstable; urgency=low

  * Set $COLUMNS and $LINES in csh.{cshrc,login}. Closes: #580498. LP: #546032
  * Standards-Version bumped to 3.8.4. No changes needed.
  * Upload to unstable.

tcsh (6.17.02-1) experimental; urgency=low

  * New upstream release.
  * Merged patches:
    + 01_build.1.patch
    + 06_man.patch
    + 10_hurd.patch
  * Removed patches:
    + 02_fix.patch - no longer needed
    + 12_unknown_lscolors.patch - upstream says:
        "rejected - will not apply now, I'd rather see the error and
         fix $LS_COLORS than eat it up silently."
  * Bug fixes:
    + "Crash with autoexpand and no histchars" (LP: #96490)
    + "tcsh history file fails to save commands with "!" properly" (LP: #139537)
    + "tcsh's sending of HUPs to children is broken" (Closes: #314641)
    + "tcsh doesn't support CR/LF end-of-lines in some cases, contrary to csh"
      (Closes: #462346)
    + "complete.tcsh bug in postmap" (Closes: #552632)
  * Fix catalogs generation to use the charset
  * Add disable-lexical.at-31.patch:
    disable broken comments test
  * Upload to experimental as it is a pre-release.
 -- Ubuntu Archive Auto-Sync <email address hidden> Fri, 15 Oct 2010 10:02:07 +0000

Changed in tcsh (Ubuntu):
status: Fix Committed → Fix Released
Changed in tcsh (Debian):
status: New → Fix Released
B Bobo (yout-bobo123) wrote :

Just noticed a regression to the unpatched version of tcsh in Precise 12.04.

Can the maintainer please fix this?

B Bobo (yout-bobo123) on 2012-08-07
Changed in tcsh (Ubuntu):
status: Fix Released → New
B Bobo (yout-bobo123) wrote :

Can the maintainer please fix this regression in the Ubuntu package?

tags: added: regression-release tcsh-6.17.06
removed: tcsh-6.14.00
summary: - [PATCH] tcsh-6.14.00-astron $COLUMNS $LINES not set
+ [PATCH] tcsh-6.17.06-2 $COLUMNS $LINES not set
description: updated
B Bobo (yout-bobo123) wrote :

Err, hello?! Is anybody there at launchpad these days?

B Bobo (yout-bobo123) wrote :

HELLO, PHILIP MUŠKOVAC!?!? ARE YOU THERE? I have been trying to report since August 2012 that this bug still exists due to a reversion in the tcsh packaged in Ubuntu Precise 12.04. Seriously what does one actually have to do these days to get the attention of an Ubuntu package maintainer?

THANK YOU FOR YOUR ATTENTION.

B Bobo (yout-bobo123) on 2013-01-22
Changed in tcsh (Ubuntu):
status: New → Confirmed
Philip Muškovac (yofel) wrote :

Sorry that there has not been a response for quite a while, but please understand that in Ubuntu there are no specific Package maintainers, tcsh is collectively maintained by the MOTU Team and I haven't touched it in a long time.

The "regression" happened because the variables are unset to fix
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23623330 and
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23605279 in
tcsh 6.17.06-1.

As those are valid reasons for this change I don't believe much can be done here from a quick look. If you feel that they're still needed please contact the debian maintainer Thomas Lange <email address hidden>, work out a solution that can be uploaded to the development release and then follow the SRU [1] procedure to get it fixed in precise.
Thank you for your effort.

[1] https://wiki.ubuntu.com/StableReleaseUpdates

B Bobo (yout-bobo123) wrote :

Thank you for the reply. Since you said you have not been able to look at tcsh in a long time, can I offer myself as a specific maintainer of tcsh in Ubuntu?

no longer affects: linuxmint
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.